Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 656232 - dev-python/PyQt5-5.10.1 qgraphicswebview.sip:124:10: fatal error: QGraphicsWebView: No such file or directory
Summary: dev-python/PyQt5-5.10.1 qgraphicswebview.sip:124:10: fatal error: QGraphicsWe...
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: PPC Linux
: Normal normal (vote)
Assignee: Qt Bug Alias
URL:
Whiteboard:
Keywords:
Depends on: 624404
Blocks:
  Show dependency tree
 
Reported: 2018-05-21 13:14 UTC by ernsteiswuerfel
Modified: 2018-07-13 21:00 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
emerge --info (file_656232.txt,5.89 KB, text/plain)
2018-05-21 13:14 UTC, ernsteiswuerfel
Details
build.log (build.log,682.21 KB, text/plain)
2018-05-21 13:16 UTC, ernsteiswuerfel
Details

Note You need to log in before you can comment on or make changes to this bug.
Description ernsteiswuerfel 2018-05-21 13:14:17 UTC
Created attachment 532568 [details]
emerge --info

[ebuild  N    ] dev-python/PyQt5-5.10.1  USE="dbus declarative designer examples gui help network opengl positioning printsupport sensors serialport sql svg webchannel webkit websockets widgets x11extras xmlpatterns (-bluetooth) -debug (-gles2) (-location) -multimedia -testlib (-webengine)" PYTHON_TARGETS="python2_7 python3_6 -python3_4 -python3_5"


cd QtWebKitWidgets/ && ( test -e Makefile || /usr/lib/qt5/bin/qmake -o Makefile /var/tmp/portage/dev-python/PyQt5-5.10.1/work/PyQt5_gpl-5.10.1-python2_7/QtWebKitWidgets/QtWebKitWidgets.pro 'QMAKE_AR=powerpc-unknown-linux-gnu-ar cqs' QMAKE_CC=powerpc-unknown-linux-gnu-gcc QMAKE_LINK_C=powerpc-unknown-linux-gnu-gcc QMAKE_LINK_C_SHLIB=powerpc-unknown-linux-gnu-gcc QMAKE_CXX=powerpc-unknown-linux-gnu-g++ QMAKE_LINK=powerpc-unknown-linux-gnu-g++ QMAKE_LINK_SHLIB=powerpc-unknown-linux-gnu-g++ QMAKE_OBJCOPY=powerpc-unknown-linux-gnu-objcopy QMAKE_RANLIB= QMAKE_STRIP= 'QMAKE_CFLAGS=-O2 -mcpu=970 -mtune=970 -maltivec -mabi=altivec -pipe' QMAKE_CFLAGS_RELEASE= QMAKE_CFLAGS_DEBUG= 'QMAKE_CXXFLAGS=-O2 -mcpu=970 -mtune=970 -maltivec -mabi=altivec -pipe' QMAKE_CXXFLAGS_RELEASE= QMAKE_CXXFLAGS_DEBUG= 'QMAKE_LFLAGS=-Wl,-O1 -Wl,--as-needed' QMAKE_LFLAGS_RELEASE= QMAKE_LFLAGS_DEBUG= ) && make -f Makefile 
make[1]: Entering directory '/var/tmp/portage/dev-python/PyQt5-5.10.1/work/PyQt5_gpl-5.10.1-python2_7/QtWebKitWidgets'
powerpc-unknown-linux-gnu-g++ -c -O2 -mcpu=970 -mtune=970 -maltivec -mabi=altivec -pipe -fno-exceptions -Wall -W -D_REENTRANT -fPIC -DSIP_PROTECTED_IS_PUBLIC -Dprotected=public -DQT_NO_EXCEPTIONS -DQT_NO_DEBUG -DQT_PLUGIN -DQT_WEBKITWIDGETS_LIB -DQT_PRINTSUPPORT_LIB -DQT_WIDGETS_LIB -DQT_WEBKIT_LIB -DQT_GUI_LIB -DQT_NETWORK_LIB -DQT_CORE_LIB -I. -I. -isystem /usr/include/python2.7 -isystem /usr/include/qt5 -isystem /usr/include/qt5/QtWebKitWidgets -isystem /usr/include/qt5/QtPrintSupport -isystem /usr/include/qt5/QtWidgets -isystem /usr/include/qt5/QtWebKit -isystem /usr/include/qt5/QtGui -isystem /usr/include/qt5/QtNetwork -isystem /usr/include/qt5/QtCore -I. -isystem /usr/include/libdrm -I/usr/lib/qt5/mkspecs/linux-g++ -o sipQtWebKitWidgetsQGraphicsWebView.o sipQtWebKitWidgetsQGraphicsWebView.cpp
In file included from sipQtWebKitWidgetsQGraphicsWebView.cpp:24:0:
/var/tmp/portage/dev-python/PyQt5-5.10.1/work/PyQt5_gpl-5.10.1/sip/QtWebKitWidgets/qgraphicswebview.sip:124:10: fatal error: QGraphicsWebView: No such file or directory
 #include <QGraphicsWebView>
          ^~~~~~~~~~~~~~~~~~
compilation terminated.
Comment 1 ernsteiswuerfel 2018-05-21 13:16:04 UTC
Created attachment 532570 [details]
build.log
Comment 2 George Diamantopoulos 2018-05-25 02:18:04 UTC
Same here
Comment 3 mong00se 2018-06-06 23:39:55 UTC
I had this problem, I suspect it is due to webkit dependency, where QGraphicsWebView is provided. Webkit is deprecated since Qt 5.6 (I think). I don't pretend to know how this is handled in gentoo (I read there was a fork that is maintained). In my case portage didn't tell me that the package (qutebrowser-0.9.1) previously needing the webkit use keyword was now unnecessary (qutebrowser-1.3.1), so I deleted it from my PyQt5 package.use, and it compiled fine.
Comment 4 Andreas Sturmlechner gentoo-dev 2018-07-01 20:07:42 UTC
It seems this is solved by new qtwebkit.
Comment 5 Andreas Sturmlechner gentoo-dev 2018-07-03 09:21:27 UTC
Please try rebuild after upgrade to qtwebkit-5.212.0_pre20180120.
Comment 6 ernsteiswuerfel 2018-07-04 15:34:27 UTC
Can't confirm this 'cause qtwebkit-5.212.0_pre20180120 does not build on my setup (see bug #660356).
Comment 7 Andreas Sturmlechner gentoo-dev 2018-07-13 21:00:50 UTC
So far all instances of this error seems to have been fixed by updating to the latest qtwebkit snapshot. Closing this as fixed until someone is able to reproduce the same error with dev-qt/qtwebkit-5.212.0_pre20180120.