Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 656028 - dev-db/plr-8.3.0.17 : [TEST] Makefile:<snip>: /.../contrib-global.mk: No such file or directory
Summary: dev-db/plr-8.3.0.17 : [TEST] Makefile:<snip>: /.../contrib-global.mk: No such...
Status: CONFIRMED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: PgSQL Bugs
URL:
Whiteboard:
Keywords: TESTFAILURE
Depends on:
Blocks:
 
Reported: 2018-05-18 14:25 UTC by Toralf Förster
Modified: 2020-12-09 14:34 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
emerge-info.txt (emerge-info.txt,16.78 KB, text/plain)
2018-05-18 14:25 UTC, Toralf Förster
Details
dev-db:plr-8.3.0.17:20180518-020840.log (dev-db:plr-8.3.0.17:20180518-020840.log,5.24 KB, text/plain)
2018-05-18 14:25 UTC, Toralf Förster
Details
emerge-history.txt (emerge-history.txt,137.60 KB, text/plain)
2018-05-18 14:25 UTC, Toralf Förster
Details
environment (environment,38.21 KB, text/plain)
2018-05-18 14:26 UTC, Toralf Förster
Details
etc.portage.tbz2 (etc.portage.tbz2,13.11 KB, application/x-bzip)
2018-05-18 14:26 UTC, Toralf Förster
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Toralf Förster gentoo-dev 2018-05-18 14:25:50 UTC
 * 9.5: running run_in_build_dir emake installcheck
make -j1 installcheck 
Makefile:41: /contrib/contrib-global.mk: No such file or directory
make: *** No rule to make target '/contrib/contrib-global.mk'.  Stop.
 * ERROR: dev-db/plr-8.3.0.17::gentoo failed (test phase):
 *   emake failed

  -------------------------------------------------------------------

  This is an unstable amd64 chroot image at a tinderbox (==build bot)
  name: 17.0-desktop-plasma-systemd_test_20180513-102141

  -------------------------------------------------------------------

gcc-config -l:
 [1] x86_64-pc-linux-gnu-7.3.0 *

Available Python interpreters, in order of preference:
  [1]   python3.5
  [2]   python2.7 (fallback)

java-config:
The following VMs are available for generation-2:
*)	IcedTea JDK 3.7.0 [icedtea-bin-8]
Available Java Virtual Machines:
  [1]   icedtea-bin-8  system-vm

emerge -qpv dev-db/plr
[ebuild  N    ] dev-db/plr-8.3.0.17  POSTGRES_TARGETS="postgres9_5 -postgres10 -postgres9_3 -postgres9_4 -postgres9_6"
Comment 1 Toralf Förster gentoo-dev 2018-05-18 14:25:52 UTC
Created attachment 532010 [details]
emerge-info.txt
Comment 2 Toralf Förster gentoo-dev 2018-05-18 14:25:56 UTC
Created attachment 532012 [details]
dev-db:plr-8.3.0.17:20180518-020840.log
Comment 3 Toralf Förster gentoo-dev 2018-05-18 14:25:59 UTC
Created attachment 532014 [details]
emerge-history.txt
Comment 4 Toralf Förster gentoo-dev 2018-05-18 14:26:02 UTC
Created attachment 532016 [details]
environment
Comment 5 Toralf Förster gentoo-dev 2018-05-18 14:26:05 UTC
Created attachment 532018 [details]
etc.portage.tbz2
Comment 6 Aaron W. Swenson gentoo-dev 2019-01-17 13:58:58 UTC
This may just need USE_PGXS to be defined.

If PGXS is used, there's some QA things that need to be ignored since PGXS will force this package to be built with the same CFLAGS and other bits that dev-db/postgresql was built with regardless of CFLAGS current setting in /etc/portage/make.conf