Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 655856 - media-libs/sdl-pango with >=sys-apps/file-5.33, Linux and CHOST not in alpha*|hppa*|i*86|ia64*|m68*|mips*|powerpc*|sparc*|s390*|sh* fails to install shared object (.so) library
Summary: media-libs/sdl-pango with >=sys-apps/file-5.33, Linux and CHOST not in alpha*...
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Gentoo Games
URL:
Whiteboard:
Keywords:
: 653424 654896 655354 655376 (view as bug list)
Depends on:
Blocks:
 
Reported: 2018-05-16 10:57 UTC by Lars Wendler (Polynomial-C)
Modified: 2018-06-22 20:31 UTC (History)
4 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
build.log (build.log,22.62 KB, text/plain)
2018-05-16 10:57 UTC, Lars Wendler (Polynomial-C) (RETIRED)
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Lars Wendler (Polynomial-C) (RETIRED) gentoo-dev 2018-05-16 10:57:44 UTC
Created attachment 531686 [details]
build.log

/bin/bash ../libtool --mode=link x86_64-pc-linux-gnu-gcc  -march=native -mtune=native -O2 -pipe -I/usr/include/pango-1.0 -I/usr/include/glib-2.0 -I/usr/lib64/glib-2.0/include -I/usr/include/fribidi -I/usr/include/pango-1.0 -I/usr/include/fribidi -I/usr/include/uuid -I/usr/include/freetype2 -I/usr/include/harfbuzz -I/usr/include/glib-2.0 -I/usr/lib64/glib-2.0/include -I/usr/include/SDL -D_GNU_SOURCE=1 -D_REENTRANT  -Wl,-O1 -Wl,--hash-style=gnu -Wl,--sort-common -Wl,--as-needed -o libSDL_Pango.la -rpath /usr/lib64 -no-undefined -version-info 2:0:1 SDL_Pango.lo  -lpango-1.0 -lgobject-2.0 -lglib-2.0 -lfribidi -lpangoft2-1.0 -lpango-1.0 -lgobject-2.0 -lglib-2.0 -lfribidi -lfontconfig -lfreetype -lSDL -lpthread

*** Warning: linker path does not have real file for library -lpangoft2-1.0.
*** I have the capability to make that library automatically link in when
*** you link to this library.  But I can only do this if you have a
*** shared version of the library, which you do not appear to have
*** because I did check the linker path looking for a file starting
*** with libpangoft2-1.0 and none of the candidates passed a file format test
*** using a file magic. Last file checked: /usr/lib//libpangoft2-1.0.so.0.4200.1

*** Warning: linker path does not have real file for library -lpango-1.0.
*** I have the capability to make that library automatically link in when
*** you link to this library.  But I can only do this if you have a
*** shared version of the library, which you do not appear to have
*** because I did check the linker path looking for a file starting
*** with libpango-1.0 and none of the candidates passed a file format test
*** using a file magic. Last file checked: /usr/lib//libpango-1.0.so.0.4200.1

*** Warning: linker path does not have real file for library -lgobject-2.0.
*** I have the capability to make that library automatically link in when
*** you link to this library.  But I can only do this if you have a
*** shared version of the library, which you do not appear to have
*** because I did check the linker path looking for a file starting
*** with libgobject-2.0 and none of the candidates passed a file format test
*** using a file magic. Last file checked: /usr/lib//libgobject-2.0.so.0.5600.1

*** Warning: linker path does not have real file for library -lglib-2.0.
*** I have the capability to make that library automatically link in when
*** you link to this library.  But I can only do this if you have a
*** shared version of the library, which you do not appear to have
*** because I did check the linker path looking for a file starting
*** with libglib-2.0 and none of the candidates passed a file format test
*** using a file magic. Last file checked: /usr/lib//libglib-2.0.so.0.5600.1

*** Warning: linker path does not have real file for library -lfribidi.
*** I have the capability to make that library automatically link in when
*** you link to this library.  But I can only do this if you have a
*** shared version of the library, which you do not appear to have
*** because I did check the linker path looking for a file starting
*** with libfribidi and none of the candidates passed a file format test
*** using a file magic. Last file checked: /usr/lib//libfribidi.so.0.4.0

*** Warning: linker path does not have real file for library -lfontconfig.
*** I have the capability to make that library automatically link in when
*** you link to this library.  But I can only do this if you have a
*** shared version of the library, which you do not appear to have
*** because I did check the linker path looking for a file starting
*** with libfontconfig and none of the candidates passed a file format test
*** using a file magic. Last file checked: /usr/lib//libfontconfig.so.1.11.1

*** Warning: linker path does not have real file for library -lfreetype.
*** I have the capability to make that library automatically link in when
*** you link to this library.  But I can only do this if you have a
*** shared version of the library, which you do not appear to have
*** because I did check the linker path looking for a file starting
*** with libfreetype and none of the candidates passed a file format test
*** using a file magic. Last file checked: /usr/lib//libfreetype.so.6.16.1

*** Warning: linker path does not have real file for library -lSDL.
*** I have the capability to make that library automatically link in when
*** you link to this library.  But I can only do this if you have a
*** shared version of the library, which you do not appear to have
*** because I did check the linker path looking for a file starting
*** with libSDL and none of the candidates passed a file format test
*** using a file magic. Last file checked: /usr/lib//libSDL-1.2.so.0.11.4

*** Warning: linker path does not have real file for library -lpthread.
*** I have the capability to make that library automatically link in when
*** you link to this library.  But I can only do this if you have a
*** shared version of the library, which you do not appear to have
*** because I did check the linker path looking for a file starting
*** with libpthread and none of the candidates passed a file format test
*** using a file magic. Last file checked: /usr/lib//libpthread.so
*** The inter-library dependencies that have been dropped here will be
*** automatically added whenever a program is linked with this library
*** or is declared to -dlopen it.

*** Since this library must not contain undefined symbols,
*** because either the platform does not support them or
*** it was explicitly requested with -no-undefined,
*** libtool will only create a static version of it.
x86_64-pc-linux-gnu-ar cru .libs/libSDL_Pango.a .libs/SDL_Pango.o
x86_64-pc-linux-gnu-ranlib .libs/libSDL_Pango.a
creating libSDL_Pango.la



And no .so file is being built.
Comment 1 Arfrever Frehtes Taifersar Arahesis 2018-05-17 02:04:17 UTC
The main hint is:

> *** Warning: linker path does not have real file for library -lpangoft2-1.0.
> *** I have the capability to make that library automatically link in when
> *** you link to this library.  But I can only do this if you have a
> *** shared version of the library, which you do not appear to have
> *** because I did check the linker path looking for a file starting
> *** with libpangoft2-1.0 and none of the candidates passed a file format test
                                                               ^^^^^^^^^^^^^^^^
> *** using a file magic. Last file checked: /usr/lib//libpangoft2-1.0.so.0.4200.1
              ^^^^^^^^^^


sys-apps/file-5.33 changed output for ELF PIE shared libraries from *"SB shared object"* to *"SB pie executable"*.

libtool.m4 was changed to not check type of libraries on Linux using `file` on 2003-09-29:
https://git.savannah.gnu.org/cgit/libtool.git/commit/?id=faebb80cef3e8e4e7355ec526ce176eca3bf32af
https://git.savannah.gnu.org/cgit/libtool.git/commit/?id=4ac8f641f77bf7d46d1f0a7885a31df66769780a


media-libs/sdl-pango-0.1.2 contains old version of Libtool macros from 2003-04-05.
`eautoreconf` is sufficient here.


A more complicated solution would be to add some patch(es) to app-portage/elt-patches and use `elibtoolize`.
Comment 2 Arfrever Frehtes Taifersar Arahesis 2018-05-17 03:57:14 UTC
*** Bug 653424 has been marked as a duplicate of this bug. ***
Comment 3 Arfrever Frehtes Taifersar Arahesis 2018-05-17 03:57:19 UTC
*** Bug 654896 has been marked as a duplicate of this bug. ***
Comment 4 Arfrever Frehtes Taifersar Arahesis 2018-05-17 03:57:27 UTC
*** Bug 655354 has been marked as a duplicate of this bug. ***
Comment 5 Arfrever Frehtes Taifersar Arahesis 2018-05-17 03:57:33 UTC
*** Bug 655376 has been marked as a duplicate of this bug. ***
Comment 6 Larry the Git Cow gentoo-dev 2018-05-17 06:17:04 UTC
The bug has been closed via the following commit(s):

https://gitweb.gentoo.org/repo/gentoo.git/commit/?id=934f8250f76673d3cac61753ed71d83d49fb961e

commit 934f8250f76673d3cac61753ed71d83d49fb961e
Author:     Lars Wendler <polynomial-c@gentoo.org>
AuthorDate: 2018-05-17 06:16:34 +0000
Commit:     Lars Wendler <polynomial-c@gentoo.org>
CommitDate: 2018-05-17 06:16:57 +0000

    media-libs/sdl-pango: Revbump to fix installation of .so file.
    
    Also bumped to EAPI-6. Thanks to Arfrever Frehtes Taifersar Arahesis for
    his outstanding analysis on the issue.
    
    Closes: https://bugs.gentoo.org/655856
    Package-Manager: Portage-2.3.36, Repoman-2.3.9

 media-libs/sdl-pango/sdl-pango-0.1.2-r1.ebuild | 43 ++++++++++++++++++++++++++
 1 file changed, 43 insertions(+)