Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bugzilla DB migration completed. Please report issues to Infra team via email via infra@gentoo.org or IRC
Bug 65485 - initrd modprobe script is un-needed
Summary: initrd modprobe script is un-needed
Status: RESOLVED WONTFIX
Alias: None
Product: Gentoo Release Media
Classification: Unclassified
Component: Everything (show other bugs)
Hardware: All Linux
: High enhancement (vote)
Assignee: Gentoo Genkernel Maintainers
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2004-09-26 19:51 UTC by postmodern
Modified: 2004-10-10 01:39 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description postmodern 2004-09-26 19:51:17 UTC
The kernel version bug in previous versions of busybox which inspired the /sbin/modprobe bash script have been fixed in the latest releases of busybox. I suggest that the initrd be upgraded to use the latest BusyBox (maybe cvs) that is concidered stable.

Reproducible: Always
Steps to Reproduce:
1.
2.
3.
Comment 1 Chris Gianelloni (RETIRED) gentoo-dev 2004-09-27 07:09:11 UTC
The initrd creation is totally done by genkernel, so I am reassigning to them.
Comment 2 Tim Yamin (RETIRED) gentoo-dev 2004-09-27 08:35:14 UTC
Do we have a upstream busybox that now supports mounting cryptoloop on 2.6 using the new 2.6 API and mounting plain loops on 2.4?
Comment 3 postmodern 2004-09-27 15:15:16 UTC
As of the current CVS snapshot of busybox losetup util does not support enabling encryption upon its loops.
Comment 4 Tim Yamin (RETIRED) gentoo-dev 2004-10-10 01:39:26 UTC
Hrm, well we need a busybox that can do 2.6 and 2.4 loop mounting, and since the CVS ones don't provide this, I don't think it is worth the effort of getting the support into a new busybox - the current method works without any problems anyway...
Comment 5 Tim Yamin (RETIRED) gentoo-dev 2004-10-10 01:39:58 UTC
Closing as WONTFIX; comment #4.