Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 654418 - media-video/gpac-0.7.1 : audio_decoder.c:313:48: error: AVFrame {aka struct AVFrame} has no member named channels
Summary: media-video/gpac-0.7.1 : audio_decoder.c:313:48: error: AVFrame {aka struct A...
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: media-video herd
URL:
Whiteboard:
Keywords:
: 655026 (view as bug list)
Depends on:
Blocks:
 
Reported: 2018-04-30 13:26 UTC by Toralf Förster
Modified: 2020-08-20 12:30 UTC (History)
2 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
emerge-info.txt (emerge-info.txt,16.37 KB, text/plain)
2018-04-30 13:26 UTC, Toralf Förster
Details
emerge-history.txt (emerge-history.txt,198.51 KB, text/plain)
2018-04-30 13:26 UTC, Toralf Förster
Details
environment (environment,89.56 KB, text/plain)
2018-04-30 13:26 UTC, Toralf Förster
Details
etc.portage.tbz2 (etc.portage.tbz2,13.33 KB, application/x-bzip)
2018-04-30 13:26 UTC, Toralf Förster
Details
logs.tbz2 (logs.tbz2,4.29 KB, application/x-bzip)
2018-04-30 13:26 UTC, Toralf Förster
Details
media-video:gpac-0.7.1:20180430-111336.log (media-video:gpac-0.7.1:20180430-111336.log,227.28 KB, text/plain)
2018-04-30 13:26 UTC, Toralf Förster
Details
temp.tbz2 (temp.tbz2,31.65 KB, application/x-bzip)
2018-04-30 13:26 UTC, Toralf Förster
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Toralf Förster gentoo-dev 2018-04-30 13:26:29 UTC
 void av_free_packet(AVPacket *pkt);
      ^~~~~~~~~~~~~~
audio_decoder.c:313:48: error: ‘AVFrame {aka struct AVFrame}’ has no member named ‘channels’
     int num_channels = audio_input_data->aframe->channels;
                                                ^~
audio_decoder.c:316:34: error: ‘AVFrame {aka struct AVFrame}’ has no member named ‘channels’

  -------------------------------------------------------------------

  This is an unstable amd64 chroot image at a tinderbox (==build bot)
  name: 17.0_ffmpeg4_20180425-210301

  -------------------------------------------------------------------

gcc-config -l:
 [1] x86_64-pc-linux-gnu-7.3.0 *

Available Python interpreters, in order of preference:
  [1]   python3.5
  [2]   python3.6 (fallback)
  [3]   python2.7 (fallback)
  [4]   pypy3 (fallback)
  [5]   pypy (fallback)
Available Ruby profiles:
  [1]   ruby23 (with Rubygems) *
java-config:
The following VMs are available for generation-2:


emerge -qpv media-video/gpac
[ebuild  N    ] media-video/gpac-0.7.1  USE="ffmpeg ipv6 libav ssl truetype -X -a52 -aac -alsa -debug -dvb -jack -jpeg -jpeg2k -libressl -mad -opengl -oss -png -pulseaudio -sdl -static-libs -theora -vorbis -xml -xvid"
Comment 1 Toralf Förster gentoo-dev 2018-04-30 13:26:32 UTC
Created attachment 529080 [details]
emerge-info.txt
Comment 2 Toralf Förster gentoo-dev 2018-04-30 13:26:37 UTC
Created attachment 529082 [details]
emerge-history.txt
Comment 3 Toralf Förster gentoo-dev 2018-04-30 13:26:41 UTC
Created attachment 529084 [details]
environment
Comment 4 Toralf Förster gentoo-dev 2018-04-30 13:26:44 UTC
Created attachment 529086 [details]
etc.portage.tbz2
Comment 5 Toralf Förster gentoo-dev 2018-04-30 13:26:47 UTC
Created attachment 529088 [details]
logs.tbz2
Comment 6 Toralf Förster gentoo-dev 2018-04-30 13:26:50 UTC
Created attachment 529090 [details]
media-video:gpac-0.7.1:20180430-111336.log
Comment 7 Toralf Förster gentoo-dev 2018-04-30 13:26:53 UTC
Created attachment 529092 [details]
temp.tbz2
Comment 8 Alexis Ballier gentoo-dev 2018-04-30 18:02:21 UTC
Toralf, USE=libav is not testing ffmpeg4
Comment 9 Reuben Martin 2018-05-06 00:34:17 UTC
*** Bug 655026 has been marked as a duplicate of this bug. ***
Comment 10 Rolf Eike Beer 2018-12-15 11:03:36 UTC
I see the same happening with 0.7.1-r1 on sparc:

FEATURES=' test' USE='' succeeded for =media-video/gpac-0.7.1-r1
USE='X a52 aac alsa -ffmpeg ipv6 jack jpeg jpeg2k -libav -mad opengl oss -png -pulseaudio -sdl ssl -static-libs theora truetype -vorbis -xml -xvid' succeeded for =media-video/gpac-0.7.1-r1
USE='X a52 aac alsa -ffmpeg ipv6 jack -jpeg jpeg2k libav -mad opengl oss png pulseaudio sdl -ssl static-libs theora truetype -vorbis -xml -xvid' succeeded for =media-video/gpac-0.7.1-r1
USE='-X a52 aac -alsa ffmpeg -ipv6 -jack -jpeg -jpeg2k libav -mad -opengl -oss png pulseaudio sdl ssl -static-libs theora truetype vorbis -xml -xvid' failed for =media-video/gpac-0.7.1-r1
    log has been saved as /root/tatt/logs/media-video_gpac-0.7.1-r1_use_A5AGh
USE='-X -a52 -aac -alsa -ffmpeg -ipv6 -jack -jpeg -jpeg2k -libav mad opengl oss -png -pulseaudio -sdl ssl -static-libs -theora -truetype -vorbis xml -xvid' succeeded for =media-video/gpac-0.7.1-r1
USE='X -a52 aac alsa ffmpeg -ipv6 -jack jpeg -jpeg2k libav -mad opengl oss png pulseaudio sdl ssl -static-libs -theora -truetype -vorbis xml -xvid' failed for =media-video/gpac-0.7.1-r1
    log has been saved as /root/tatt/logs/media-video_gpac-0.7.1-r1_use_nsM3f
USE='-X -a52 -aac alsa ffmpeg ipv6 -jack -jpeg -jpeg2k libav mad -opengl -oss png -pulseaudio -sdl -ssl -static-libs theora -truetype -vorbis xml -xvid' failed for =media-video/gpac-0.7.1-r1
    log has been saved as /root/tatt/logs/media-video_gpac-0.7.1-r1_use_3j7Py
USE='-X -a52 aac -alsa ffmpeg -ipv6 jack jpeg -jpeg2k libav mad -opengl oss -png -pulseaudio sdl -ssl -static-libs -theora truetype -vorbis xml -xvid' failed for =media-video/gpac-0.7.1-r1
    log has been saved as /root/tatt/logs/media-video_gpac-0.7.1-r1_use_Jcy2D
USE='-X a52 aac -alsa -ffmpeg ipv6 -jack -jpeg jpeg2k libav -mad opengl oss -png pulseaudio sdl -ssl static-libs -theora truetype -vorbis xml -xvid' succeeded for =media-video/gpac-0.7.1-r1
USE='X -a52 -aac alsa ffmpeg ipv6 jack -jpeg jpeg2k libav mad -opengl -oss -png -pulseaudio -sdl -ssl static-libs -theora truetype vorbis xml -xvid' failed for =media-video/gpac-0.7.1-r1
    log has been saved as /root/tatt/logs/media-video_gpac-0.7.1-r1_use_PTDeq
USE='-X a52 aac -alsa ffmpeg -ipv6 -jack -jpeg jpeg2k -libav -mad opengl oss -png -pulseaudio sdl ssl -static-libs theora -truetype -vorbis -xml xvid' : unkeyworded dependencies (probably) for =media-video/gpac-0.7.1-r1
USE='X a52 -aac -alsa -ffmpeg -ipv6 jack -jpeg jpeg2k libav mad opengl -oss png pulseaudio -sdl ssl static-libs theora -truetype -vorbis -xml xvid' succeeded for =media-video/gpac-0.7.1-r1
USE='X a52 -aac -alsa ffmpeg ipv6 jack -jpeg -jpeg2k -libav mad opengl oss png pulseaudio sdl -ssl -static-libs -theora -truetype -vorbis xml xvid' : unkeyworded dependencies (probably) for =media-video/gpac-0.7.1-r1
Comment 11 Larry the Git Cow gentoo-dev 2020-08-20 12:30:50 UTC
The bug has been closed via the following commit(s):

https://gitweb.gentoo.org/repo/gentoo.git/commit/?id=4b34462e1b49b4b30ed014713f3011d5a246a91e

commit 4b34462e1b49b4b30ed014713f3011d5a246a91e
Author:     Sam James <sam@gentoo.org>
AuthorDate: 2020-08-20 12:12:54 +0000
Commit:     Sam James <sam@gentoo.org>
CommitDate: 2020-08-20 12:30:44 +0000

    media-video/gpac: security bump to 0.8.1
    
    We're bumping to 0.8.1 before 1.0.0 because there was
    a substantial rewrite. The aim is to stabilise this release
    first, give 1.0.0 (later commit) a few days in ~arch, then do that.
    
    Bug: https://bugs.gentoo.org/711262
    Closes: https://bugs.gentoo.org/701538
    Closes: https://bugs.gentoo.org/654418
    Closes: https://bugs.gentoo.org/658062
    Package-Manager: Portage-3.0.3, Repoman-3.0.0
    Signed-off-by: Sam James <sam@gentoo.org>

 media-video/gpac/Manifest                         |   1 +
 media-video/gpac/files/gpac-0.8.1-configure.patch | 100 +++++++++++++++
 media-video/gpac/gpac-0.8.1.ebuild                | 149 ++++++++++++++++++++++
 3 files changed, 250 insertions(+)