Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 654062 - app-emulation/libvirt with >=sys-libs/glibc-2.26: lxc/lxc_monitor_protocol.h:9:10: fatal error: rpc/rpc.h: No such file or directory
Summary: app-emulation/libvirt with >=sys-libs/glibc-2.26: lxc/lxc_monitor_protocol.h:...
Status: RESOLVED NEEDINFO
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Matthias Maier
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: glibc-rpc
  Show dependency tree
 
Reported: 2018-04-25 10:29 UTC by OzTiram
Modified: 2018-08-19 21:28 UTC (History)
3 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
emerge-info.txt (emerge-info.txt,23.67 KB, text/plain)
2018-05-10 06:59 UTC, Sergei Trofimovich
Details
build.log (build.log.gz,68.67 KB, application/gzip)
2018-06-14 22:04 UTC, Alexey
Details
emerge --info (file_654062.txt,19.17 KB, text/plain)
2018-06-14 22:05 UTC, Alexey
Details

Note You need to log in before you can comment on or make changes to this bug.
Description OzTiram 2018-04-25 10:29:47 UTC
Modern versions of glibc remove rpc API. 

I was able build libvirt with net-libs/libtirpc.
I got the hint from Fedora [1].



[1] https://fedoraproject.org/wiki/Changes/SunRPCRemoval
Comment 1 Jeroen Roovers gentoo-dev 2018-04-27 07:54:44 UTC
Please post your `emerge --info` output in a comment.
Please attach the entire build log to this bug report.
Comment 2 OzTiram 2018-04-29 19:12:36 UTC
I am sorry, I am unable to do this anymore, because I re-installed my machine.
Having a glibc which does not support libvirt forced me to re-install the machine, because there was no safe downgrade path.
Comment 3 Sergei Trofimovich gentoo-dev 2018-05-10 06:57:33 UTC
libtool: compile:  x86_64-pc-linux-gnu-gcc -DHAVE_CONFIG_H -I. -I.. -I../gnulib/lib -I../gnulib/lib -I.. -I../include -I../include -I./util -I./util -DIN_LIBVIRT -Dabs_topbuilddir=\"/tmp/portage/app-emulation/libvirt-4.1.0-r3/work/libvirt-4.1.0\" -Dabs_topsrcdir=\"/tmp/portage/app-emulation/libvirt-4.1.0-r3/work/libvirt-4.1.0\" -O0 -DLIBXL_API_VERSION=0x040400 -c lxc/lxc_monitor_protocol.c  -fPIC -DPIC -o lxc/.libs/libvirt_driver_lxc_impl_la-lxc_monitor_protocol.o
In file included from lxc/lxc_monitor_protocol.c:7:
lxc/lxc_monitor_protocol.h:9:10: fatal error: rpc/rpc.h: No such file or directory
 #include <rpc/rpc.h>
          ^~~~~~~~~~~
compilation terminated.
Comment 4 Sergei Trofimovich gentoo-dev 2018-05-10 06:59:26 UTC
Created attachment 530670 [details]
emerge-info.txt
Comment 5 Sergei Trofimovich gentoo-dev 2018-05-11 19:29:46 UTC
Seems to be fixed in newer upstream release of libvirt-4.3.0.
Comment 6 Larry the Git Cow gentoo-dev 2018-05-11 21:39:17 UTC
The bug has been closed via the following commit(s):

https://gitweb.gentoo.org/repo/gentoo.git/commit/?id=a9fab850263cf3256559e0c15696598f95df4153

commit a9fab850263cf3256559e0c15696598f95df4153
Author:     Matthias Maier <tamiko@gentoo.org>
AuthorDate: 2018-05-11 21:29:16 +0000
Commit:     Matthias Maier <tamiko@gentoo.org>
CommitDate: 2018-05-11 21:39:06 +0000

    app-emulation/libvirt: version bump to 4.3.0
    
    Closes: https://bugs.gentoo.org/654062
    Package-Manager: Portage-2.3.36, Repoman-2.3.9

 app-emulation/libvirt/Manifest             |   1 +
 app-emulation/libvirt/libvirt-4.3.0.ebuild | 382 +++++++++++++++++++++++++++++
 2 files changed, 383 insertions(+)
Comment 7 Alexey 2018-06-14 22:04:02 UTC
I'm getting the same error on 4.3.0
Comment 8 Alexey 2018-06-14 22:04:37 UTC
Created attachment 535932 [details]
build.log
Comment 9 Alexey 2018-06-14 22:05:44 UTC
Created attachment 535934 [details]
emerge --info
Comment 10 Matthias Maier gentoo-dev 2018-07-04 15:24:47 UTC
I am sorry, I cannot reproduce (in a clean stage-3).
Comment 11 Alexey 2018-08-19 21:28:43 UTC
Do you have tests enabled?