Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 653890 - app-office/libreoffice-6.0.3.2 with dev-libs/icu-61.1 - i18npool/source/collator/gencoll_rule.cxx:116:35: error: ‘RuleBasedCollator’ was not declared in this scope
Summary: app-office/libreoffice-6.0.3.2 with dev-libs/icu-61.1 - i18npool/source/colla...
Status: RESOLVED DUPLICATE of bug 651702
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Gentoo Linux bug wranglers
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2018-04-23 13:32 UTC by iGentoo
Modified: 2018-04-23 13:36 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments
libreoffice-6.0.3.2-build.log.tar.xz (libreoffice-6.0.3.2-build.log.tar.xz,287.75 KB, application/x-xz-compressed-tar)
2018-04-23 13:32 UTC, iGentoo
Details
patches from upstream (libreoffice-6.0.3.2-patches.tar.xz,4.39 KB, application/x-xz-compressed-tar)
2018-04-23 13:33 UTC, iGentoo
Details

Note You need to log in before you can comment on or make changes to this bug.
Description iGentoo 2018-04-23 13:32:57 UTC
Created attachment 528258 [details]
libreoffice-6.0.3.2-build.log.tar.xz

i18npool/source/collator/gencoll_rule.cxx:116:35: error: ‘RuleBasedCollator’ was not declared in this scope
i18npool/source/collator/gencoll_rule.cxx:116:108: error: no matching function for call to ‘make_unique<<expression error> >(const sal_Unicode*, UErrorCode&)’
i18npool/source/collator/gencoll_rule.cxx:116:108: error: template argument 1 is invalid
i18npool/source/collator/gencoll_rule.cxx:116:108: error: template argument 1 is invalid
opencl/source/openclconfig.cxx:122:5: error: ‘RegexMatcher’ was not declared in this scope
opencl/source/openclconfig.cxx:124:36: error: ‘aMatcher’ was not declared in this scope
i18nutil/source/utility/unicode.cxx:753:21: error: ‘NumberFormat’ was not declared in this scope
i18nutil/source/utility/unicode.cxx:753:33: error: template argument 1 is invalid
i18nutil/source/utility/unicode.cxx:753:33: error: template argument 2 is invalid
i18nutil/source/utility/unicode.cxx:754:9: error: ‘NumberFormat’ is not a class, namespace, or enumeration
i18nutil/source/utility/unicode.cxx:761:5: error: ‘UnicodeString’ was not declared in this scope
i18nutil/source/utility/unicode.cxx:762:7: error: base operand of ‘->’ is not a pointer
i18nutil/source/utility/unicode.cxx:762:29: error: ‘output’ was not declared in this scope
vcl/inc/scrptrun.h:61:34: error: expected class-name before ‘{’ token
vcl/inc/scrptrun.h:85:22: error: ‘virtual void* vcl::ScriptRun::getDynamicClassID() const’ marked ‘override’, but does not override
lotuswordpro/source/filter/localtime.cxx:177:9: error: ‘TimeZone’ was not declared in this scope
lotuswordpro/source/filter/localtime.cxx:177:19: error: ‘pLocalZone’ was not declared in this scope
lotuswordpro/source/filter/localtime.cxx:177:32: error: ‘TimeZone’ is not a class, namespace, or enumeration
lotuswordpro/source/filter/localtime.cxx:179:16: error: type ‘<type error>’ argument given to ‘delete’, expected pointer



Portage 2.3.31 (python 3.6.5-final-0, default/linux/amd64/17.1, gcc-7.3.0, glibc-2.27-r1, 4.15.18-gentoo.x86_64 x86_64)
=================================================================
                         System Settings
=================================================================
System uname: Linux-4.15.18-gentoo.x86_64-x86_64-Intel-R-_Core-TM-2_Quad_CPU_Q9300_@_2.50GHz-with-gentoo-2.4.1
KiB Mem:     6112380 total,   1664412 free
KiB Swap:    6291452 total,   5874212 free
Head commit of repository gentoo: 7c832997cc88ac284da61b772ca6c8dc98ad8765

sh dash 0.5.9.1-r3
ld GNU gold (Gentoo 2.30 p1 2.30.0) 1.15
ccache version 3.4.2 [disabled]
app-shells/bash:          4.4_p19::gentoo
dev-java/java-config:     2.2.0-r4::gentoo
dev-lang/perl:            5.26.1-r2::gentoo
dev-lang/python:          2.7.14-r2::gentoo, 3.6.5-r1::gentoo
dev-util/ccache:          3.4.2::local-repo
dev-util/cmake:           3.11.1::gentoo
dev-util/pkgconfig:       0.29.2::gentoo
sys-apps/baselayout:      2.4.1-r2::gentoo
sys-apps/sandbox:         2.13::gentoo
sys-devel/autoconf:       2.13::gentoo, 2.69-r4::gentoo
sys-devel/automake:       1.16.1-r1::gentoo
sys-devel/binutils:       2.30-r1::gentoo
sys-devel/gcc:            7.3.0-r2::gentoo
sys-devel/gcc-config:     1.9.1::gentoo
sys-devel/libtool:        2.4.6-r5::gentoo
sys-devel/make:           4.2.1-r3::gentoo
sys-kernel/linux-headers: 4.16-r1::gentoo (virtual/os-headers)
sys-libs/glibc:           2.27-r1::gentoo
Repositories:

gentoo
    location: /usr/portage
    sync-type: git
    sync-uri: https://anongit.gentoo.org/git/repo/gentoo.git
    sync-user: portage
    priority: -1000
    eclass-overrides: local-repo

local-repo
    location: /usr/local/portage
    masters: gentoo

Installed sets: @local
ACCEPT_KEYWORDS="amd64 ~amd64"
ACCEPT_LICENSE="* -@EULA"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-Wall -march=native -O2 -pipe -frecord-gcc-switches"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/lib64/libreoffice/program/sofficerc /usr/share/gnupg/qualified.txt"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/dconf /etc/env.d /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo"
CXXFLAGS="-Wall -march=native -O2 -pipe -frecord-gcc-switches"
DISTDIR="/var/portage/distfiles"
EMERGE_DEFAULT_OPTS="--color=n --keep-going --oneshot"
FCFLAGS="-Wall -march=native -O2 -pipe -frecord-gcc-switches"
FEATURES="assume-digests binpkg-logs buildpkg collision-protect config-protect-if-modified distlocks ebuild-locks fixlafiles merge-sync metadata-transfer multilib-strict news parallel-fetch preserve-libs protect-owned sandbox sfperms split-log strict test-fail-continue unknown-features-warn unmerge-logs unmerge-orphans userfetch userpriv usersandbox usersync xattr"
FFLAGS="-Wall -march=native -O2 -pipe -frecord-gcc-switches"
GENTOO_MIRRORS="https://mirrors.163.com/gentoo http://distfiles.gentoo.org"
LANG="en_US.UTF-8"
LDFLAGS="-Wl,-O1 -Wl,--as-needed -Wl,--defsym=__gentoo_check_ldflags__=0"
LINGUAS="zh_CN"
MAKEOPTS="V=1 -j3"
PKGDIR="/var/portage/packages"
PORTAGE_BZIP2_COMMAND="lbzip2"
PORTAGE_COMPRESS="xz"
PORTAGE_COMPRESS_FLAGS="-9T0"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --omit-dir-times --compress --force --whole-file --delete --stats --human-readable --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages --exclude=/.git"
PORTAGE_TMPDIR="/var/tmp"
USE="X acl amd64 audit berkdb bzip2 cli crypt cxx dbus dri egl fortran gdbm gles2 iconv icu ipv6 jpeg modules multilib ncurses nls nptl opengl openmp pam pax_kernel pcre pic png policykit pulseaudio readline seccomp ssl systemd tcpd unicode vdpau vim-syntax wayland xattr zlib" ABI_X86="64 32 x32" ALSA_CARDS="hda-intel" APACHE2_MODULES="authn_core authz_core socache_shmcb unixd actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" CALLIGRA_FEATURES="karbon plan sheets stage words" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" CPU_FLAGS_X86="mmx mmxext sse sse2 sse3 sse4_1 ssse3" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock isync itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf skytraq superstar2 timing tsip tripmate tnt ublox ubx" INPUT_DEVICES="libinput" KERNEL="linux" L10N="zh-CN" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LIBREOFFICE_EXTENSIONS="presenter-console presenter-minimizer" OFFICE_IMPLEMENTATION="libreoffice" PHP_TARGETS="php5-6 php7-0" POSTGRES_TARGETS="postgres9_5" PYTHON_SINGLE_TARGET="python3_6" PYTHON_TARGETS="python2_7 python3_6" RUBY_TARGETS="ruby25" USERLAND="GNU" VIDEO_CARDS="nouveau nvidia" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"
Unset:  CC, CPPFLAGS, CTARGET, CXX, ENV_UNSET, INSTALL_MASK, LC_ALL, PORTAGE_BINHOST, PORTAGE_BUNZIP2_COMMAND, PORTAGE_RSYNC_EXTRA_OPTS

=================================================================
                        Package Settings
=================================================================

app-office/libreoffice-6.0.3.2::gentoo was built with the following:
USE="branding cups dbus gtk -bluetooth -coinmp -debug -eds -firebird -googledrive -gstreamer -gtk2 -java -jemalloc -kde -libressl -mysql -odk -pdfimport -postgres -test -vlc" ABI_X86="64" LIBREOFFICE_EXTENSIONS="-nlpsolver -scripting-beanshell -scripting-javascript -wiki-publisher" PYTHON_SINGLE_TARGET="python3_6 -python2_7 -python3_4 -python3_5" PYTHON_TARGETS="python2_7 python3_6 -python3_4 -python3_5"


dev-libs/icu-61.1::gentoo was built with the following:
USE="-debug -doc -examples -static-libs" ABI_X86="32 64 x32"
CXXFLAGS="-Wall -march=native -O2 -pipe -frecord-gcc-switches -std=c++14"
Comment 1 iGentoo 2018-04-23 13:33:51 UTC
Created attachment 528260 [details]
patches from upstream
Comment 2 Lars Wendler (Polynomial-C) gentoo-dev 2018-04-23 13:36:02 UTC

*** This bug has been marked as a duplicate of bug 651702 ***