Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 653676 - rekeyword >=media-video/ffmpeg-4.0
Summary: rekeyword >=media-video/ffmpeg-4.0
Status: CONFIRMED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Keywording (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: media-video herd
URL:
Whiteboard:
Keywords: KEYWORDREQ
Depends on: 658068
Blocks: 673420 670618
  Show dependency tree
 
Reported: 2018-04-21 09:52 UTC by Alexis Ballier
Modified: 2019-04-04 12:01 UTC (History)
3 users (show)

See Also:
Package list:
media-video/ffmpeg-4.1.1 media-libs/libaom-1.0.0-r1 media-libs/lv2-1.14.0-r1 media-libs/lilv-0.24.2-r3 media-libs/codec2-0.8.1 media-libs/sratom-0.6.0-r1 dev-libs/sord-0.16.0-r1 dev-libs/serd-0.28.0-r1 dev-python/rdflib-4.2.2 media-plugins/gst-plugins-libav-1.14.4.4.1.3_p20190329 alpha arm64 amd64-fbsd
Runtime testing required: ---
stable-bot: sanity-check-


Attachments
build.log.xz (ppc64) (ffmpeg-4.0.2:20181113-002156.log.xz,69.23 KB, application/x-xz)
2018-11-13 00:32 UTC, ernsteiswuerfel
no flags Details
build.log.xz (ppc) (ffmpeg-4.0.2:20181118-145147.log.xz,133.91 KB, application/x-xz)
2018-11-18 15:44 UTC, ernsteiswuerfel
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Alexis Ballier gentoo-dev 2018-04-21 09:52:30 UTC
new deps, see list
Comment 1 Alexis Ballier gentoo-dev 2018-04-21 09:57:21 UTC
Note for arch teams: I would suggest *not* masking the aom useflag as this is supposed to be the next standard video codec
Comment 2 Stabilization helper bot gentoo-dev 2018-04-21 10:01:32 UTC
An automated check of this bug failed - the following atoms are unknown:

media-libs/libaom-0_pre20180421
media-video/ffmpeg-4.0

Please verify the atom list.
Comment 3 Larry the Git Cow gentoo-dev 2018-04-28 17:40:19 UTC
The bug has been referenced in the following commit(s):

https://gitweb.gentoo.org/repo/gentoo.git/commit/?id=c63c4f224afbdf7994c7c9db372de91934937a3e

commit c63c4f224afbdf7994c7c9db372de91934937a3e
Author:     Sergei Trofimovich <slyfox@gentoo.org>
AuthorDate: 2018-04-28 17:40:10 +0000
Commit:     Sergei Trofimovich <slyfox@gentoo.org>
CommitDate: 2018-04-28 17:40:10 +0000

    media-video/ffmpeg: keyworded 4.0 for ia64, bug #653676
    
    Bug: https://bugs.gentoo.org/653676
    Package-Manager: Portage-2.3.31, Repoman-2.3.9
    RepoMan-Options: --include-arches="ia64"

 media-video/ffmpeg/ffmpeg-4.0.ebuild | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)

https://gitweb.gentoo.org/repo/gentoo.git/commit/?id=49f52f7c261dc98501b2c6a864abc930d70a8c23

commit 49f52f7c261dc98501b2c6a864abc930d70a8c23
Author:     Sergei Trofimovich <slyfox@gentoo.org>
AuthorDate: 2018-04-28 17:40:01 +0000
Commit:     Sergei Trofimovich <slyfox@gentoo.org>
CommitDate: 2018-04-28 17:40:01 +0000

    media-libs/libaom: keyworded 0_pre20180421 for ia64, bug #653676
    
    Bug: https://bugs.gentoo.org/653676
    Package-Manager: Portage-2.3.31, Repoman-2.3.9
    RepoMan-Options: --include-arches="ia64"

 media-libs/libaom/libaom-0_pre20180421.ebuild | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)}
Comment 4 Jeroen Roovers gentoo-dev 2018-05-01 11:21:03 UTC
   media-video/ffmpeg/ffmpeg-4.0.ebuild: DEPEND: ~ia64(default/linux/ia64/17.0)
[     'media-libs/codec2[abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?,abi_ppc_32(-)?,abi_ppc_64(-)?,abi_s39
0_32(-)?,abi_s390_64(-)?]',
      'media-libs/lv2[abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?,abi_ppc_32(-)?,abi_ppc_64(-)?,abi_s390_3
2(-)?,abi_s390_64(-)?]',
      'media-libs/lilv[abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?,abi_ppc_32(-)?,abi_ppc_64(-)?,abi_s390_
32(-)?,abi_s390_64(-)?]']
   media-video/ffmpeg/ffmpeg-4.0.ebuild: RDEPEND: ~ia64(default/linux/ia64/17.0)
[     'media-libs/codec2[abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?,abi_ppc_32(-)?,abi_ppc_64(-)?,abi_s39
0_32(-)?,abi_s390_64(-)?]',
      'media-libs/lv2[abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?,abi_ppc_32(-)?,abi_ppc_64(-)?,abi_s390_32(-)?,abi_s390_64(-)?]',
      'media-libs/lilv[abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?,abi_ppc_32(-)?,abi_ppc_64(-)?,abi_s390_32(-)?,abi_s390_64(-)?]']
   media-video/ffmpeg/ffmpeg-4.0.ebuild: DEPEND: ~ia64(default/linux/ia64/17.0/desktop)
[     'media-libs/codec2[abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?,abi_ppc_32(-)?,abi_ppc_64(-)?,abi_s390_32(-)?,abi_s390_64(-)?]',
      'media-libs/lv2[abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?,abi_ppc_32(-)?,abi_ppc_64(-)?,abi_s390_32(-)?,abi_s390_64(-)?]',
      'media-libs/lilv[abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?,abi_ppc_32(-)?,abi_ppc_64(-)?,abi_s390_32(-)?,abi_s390_64(-)?]']
   media-video/ffmpeg/ffmpeg-4.0.ebuild: RDEPEND: ~ia64(default/linux/ia64/17.0/desktop)
[     'media-libs/codec2[abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?,abi_ppc_32(-)?,abi_ppc_64(-)?,abi_s390_32(-)?,abi_s390_64(-)?]',
      'media-libs/lv2[abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?,abi_ppc_32(-)?,abi_ppc_64(-)?,abi_s390_32(-)?,abi_s390_64(-)?]',
      'media-libs/lilv[abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?,abi_ppc_32(-)?,abi_ppc_64(-)?,abi_s390_32(-)?,abi_s390_64(-)?]']
   media-video/ffmpeg/ffmpeg-4.0.ebuild: DEPEND: ~ia64(default/linux/ia64/17.0/desktop/gnome)
[     'media-libs/codec2[abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?,abi_ppc_32(-)?,abi_ppc_64(-)?,abi_s390_32(-)?,abi_s390_64(-)?]',
      'media-libs/lv2[abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?,abi_ppc_32(-)?,abi_ppc_64(-)?,abi_s390_32(-)?,abi_s390_64(-)?]',
      'media-libs/lilv[abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?,abi_ppc_32(-)?,abi_ppc_64(-)?,abi_s390_32(-)?,abi_s390_64(-)?]']
   media-video/ffmpeg/ffmpeg-4.0.ebuild: RDEPEND: ~ia64(default/linux/ia64/17.0/desktop/gnome)
[     'media-libs/codec2[abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?,abi_ppc_32(-)?,abi_ppc_64(-)?,abi_s390_32(-)?,abi_s390_64(-)?]',
      'media-libs/lv2[abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?,abi_ppc_32(-)?,abi_ppc_64(-)?,abi_s390_32(-)?,abi_s390_64(-)?]',
      'media-libs/lilv[abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?,abi_ppc_32(-)?,abi_ppc_64(-)?,abi_s390_32(-)?,abi_s390_64(-)?]']
   media-video/ffmpeg/ffmpeg-4.0.ebuild: DEPEND: ~ia64(default/linux/ia64/17.0/desktop/gnome/systemd)
[     'media-libs/codec2[abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?,abi_ppc_32(-)?,abi_ppc_64(-)?,abi_s390_32(-)?,abi_s390_64(-)?]',
      'media-libs/lv2[abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?,abi_ppc_32(-)?,abi_ppc_64(-)?,abi_s390_32(-)?,abi_s390_64(-)?]',
      'media-libs/lilv[abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?,abi_ppc_32(-)?,abi_ppc_64(-)?,abi_s390_32(-)?,abi_s390_64(-)?]']
   media-video/ffmpeg/ffmpeg-4.0.ebuild: RDEPEND: ~ia64(default/linux/ia64/17.0/desktop/gnome/systemd)
[     'media-libs/codec2[abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?,abi_ppc_32(-)?,abi_ppc_64(-)?,abi_s390_32(-)?,abi_s390_64(-)?]',
      'media-libs/lv2[abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?,abi_ppc_32(-)?,abi_ppc_64(-)?,abi_s390_32(-)?,abi_s390_64(-)?]',
      'media-libs/lilv[abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?,abi_ppc_32(-)?,abi_ppc_64(-)?,abi_s390_32(-)?,abi_s390_64(-)?]']
   media-video/ffmpeg/ffmpeg-4.0.ebuild: DEPEND: ~ia64(default/linux/ia64/17.0/developer)
[     'media-libs/codec2[abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?,abi_ppc_32(-)?,abi_ppc_64(-)?,abi_s390_32(-)?,abi_s390_64(-)?]',
      'media-libs/lv2[abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?,abi_ppc_32(-)?,abi_ppc_64(-)?,abi_s390_32(-)?,abi_s390_64(-)?]',
      'media-libs/lilv[abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?,abi_ppc_32(-)?,abi_ppc_64(-)?,abi_s390_32(-)?,abi_s390_64(-)?]']
   media-video/ffmpeg/ffmpeg-4.0.ebuild: RDEPEND: ~ia64(default/linux/ia64/17.0/developer)
[     'media-libs/codec2[abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?,abi_ppc_32(-)?,abi_ppc_64(-)?,abi_s390_32(-)?,abi_s390_64(-)?]',
      'media-libs/lv2[abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?,abi_ppc_32(-)?,abi_ppc_64(-)?,abi_s390_32(-)?,abi_s390_64(-)?]',
      'media-libs/lilv[abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?,abi_ppc_32(-)?,abi_ppc_64(-)?,abi_s390_32(-)?,abi_s390_64(-)?]']
Comment 5 Stabilization helper bot gentoo-dev 2018-05-01 22:03:25 UTC
An automated check of this bug failed - repoman reported dependency errors (92 lines truncated): 

> dependency.bad media-libs/lilv/lilv-0.24.2-r2.ebuild: DEPEND: ~amd64-fbsd(default/bsd/fbsd/amd64/11.1) ['>=media-libs/sratom-0.6.0-r1[abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?,abi_ppc_32(-)?,abi_ppc_64(-)?,abi_s390_32(-)?,abi_s390_64(-)?]', '>=dev-libs/serd-0.28.0-r1[abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?,abi_ppc_32(-)?,abi_ppc_64(-)?,abi_s390_32(-)?,abi_s390_64(-)?]', '>=dev-libs/sord-0.16.0-r1[abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?,abi_ppc_32(-)?,abi_ppc_64(-)?,abi_s390_32(-)?,abi_s390_64(-)?]']
> dependency.bad media-libs/lilv/lilv-0.24.2-r2.ebuild: RDEPEND: ~amd64-fbsd(default/bsd/fbsd/amd64/11.1) ['>=media-libs/sratom-0.6.0-r1[abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?,abi_ppc_32(-)?,abi_ppc_64(-)?,abi_s390_32(-)?,abi_s390_64(-)?]', '>=dev-libs/serd-0.28.0-r1[abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?,abi_ppc_32(-)?,abi_ppc_64(-)?,abi_s390_32(-)?,abi_s390_64(-)?]', '>=dev-libs/sord-0.16.0-r1[abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?,abi_ppc_32(-)?,abi_ppc_64(-)?,abi_s390_32(-)?,abi_s390_64(-)?]']
> dependency.bad media-libs/lilv/lilv-0.24.2-r2.ebuild: DEPEND: ~alpha(default/linux/alpha/13.0) ['>=media-libs/sratom-0.6.0-r1[abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?,abi_ppc_32(-)?,abi_ppc_64(-)?,abi_s390_32(-)?,abi_s390_64(-)?]', '>=dev-libs/serd-0.28.0-r1[abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?,abi_ppc_32(-)?,abi_ppc_64(-)?,abi_s390_32(-)?,abi_s390_64(-)?]', '>=dev-libs/sord-0.16.0-r1[abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?,abi_ppc_32(-)?,abi_ppc_64(-)?,abi_s390_32(-)?,abi_s390_64(-)?]']
> dependency.bad media-libs/lv2/lv2-1.14.0-r1.ebuild: DEPEND: ~amd64-fbsd(default/bsd/fbsd/amd64/11.1) ['dev-python/rdflib']
> dependency.bad media-libs/lv2/lv2-1.14.0-r1.ebuild: RDEPEND: ~amd64-fbsd(default/bsd/fbsd/amd64/11.1) ['dev-python/rdflib[python_targets_python2_7(-)?,python_targets_python3_4(-)?,python_targets_python3_5(-)?,python_targets_python3_6(-)?,-python_single_target_jython2_7(-),-python_single_target_pypy(-),-python_single_target_pypy3(-),python_single_target_python2_7(+)?,python_single_target_python3_4(+)?,python_single_target_python3_5(+)?,python_single_target_python3_6(+)?]']
> dependency.badindev media-libs/lv2/lv2-1.14.0-r1.ebuild: RDEPEND: ~arm64(default/linux/arm64/17.0) ['dev-python/rdflib[python_targets_python2_7(-)?,python_targets_python3_4(-)?,python_targets_python3_5(-)?,python_targets_python3_6(-)?,-python_single_target_jython2_7(-),-python_single_target_pypy(-),-python_single_target_pypy3(-),python_single_target_python2_7(+)?,python_single_target_python3_4(+)?,python_single_target_python3_5(+)?,python_single_target_python3_6(+)?]']
Comment 6 Markus Meier gentoo-dev 2018-05-02 16:14:16 UTC
libaom doesn't build on arm as is:

 * Package:    media-libs/libaom-0_pre20180421
 * Repository: gentoo
 * Maintainer: media-video@gentoo.org
 * USE:        arm elibc_glibc kernel_linux userland_GNU
 * FEATURES:   preserve-libs sandbox test userpriv usersandbox
>>> Unpacking source...
>>> Unpacking libaom-0_pre20180421.tar.xz to /mnt/distfiles/tmp/portage/media-libs/libaom-0_pre20180421/work
>>> Source unpacked in /mnt/distfiles/tmp/portage/media-libs/libaom-0_pre20180421/work
>>> Preparing source in /mnt/distfiles/tmp/portage/media-libs/libaom-0_pre20180421/work/libaom ...
 * Applying libdirpc.patch ...
 [ ok ]
 * Applying pthread_lib.patch ...
 [ ok ]
>>> Source prepared.
>>> Configuring source in /mnt/distfiles/tmp/portage/media-libs/libaom-0_pre20180421/work/libaom ...
 * .arm: running multilib-minimal_abi_src_configure
>>> Working in BUILD_DIR: "/mnt/distfiles/tmp/portage/media-libs/libaom-0_pre20180421/work/libaom-.arm"
cmake -C /mnt/distfiles/tmp/portage/media-libs/libaom-0_pre20180421/work/libaom-.arm/gentoo_common_config.cmake -G Unix Makefiles -DCMAKE_INSTALL_PREFIX=/usr -DENABLE_DOCS=OFF -DENABLE_EXAMPLES=OFF -DENABLE_NASM=OFF -DENABLE_TOOLS=ON -DEN
ABLE_WERROR=OFF -DENABLE_NEON=OFF -DENABLE_NEON_ASM=OFF -DENABLE_MMX=OFF -DENABLE_SSE=OFF -DENABLE_SSE2=OFF -DENABLE_SSE3=OFF -DENABLE_SSSE3=OFF -DENABLE_SSE4_1=OFF -DENABLE_AVX=OFF -DENABLE_AVX2=OFF -DBUILD_SHARED_LIBS=ON -DCMAKE_BUILD_T
YPE=Gentoo -DCMAKE_USER_MAKE_RULES_OVERRIDE=/mnt/distfiles/tmp/portage/media-libs/libaom-0_pre20180421/work/libaom-.arm/gentoo_rules.cmake -DCMAKE_TOOLCHAIN_FILE=/mnt/distfiles/tmp/portage/media-libs/libaom-0_pre20180421/work/libaom-.arm/
gentoo_toolchain.cmake  /mnt/distfiles/tmp/portage/media-libs/libaom-0_pre20180421/work/libaom
loading initial cache file /mnt/distfiles/tmp/portage/media-libs/libaom-0_pre20180421/work/libaom-.arm/gentoo_common_config.cmake
-- The C compiler identification is GNU 7.3.0
-- The CXX compiler identification is GNU 7.3.0
-- Check for working C compiler: /usr/bin/armv7a-hardfloat-linux-gnueabi-gcc
-- Check for working C compiler: /usr/bin/armv7a-hardfloat-linux-gnueabi-gcc -- works
-- Detecting C compiler ABI info
-- Detecting C compiler ABI info - done
-- Detecting C compile features
-- Detecting C compile features - done
-- Check for working CXX compiler: /usr/bin/armv7a-hardfloat-linux-gnueabi-g++
-- Check for working CXX compiler: /usr/bin/armv7a-hardfloat-linux-gnueabi-g++ -- works
-- Detecting CXX compiler ABI info
-- Detecting CXX compiler ABI info - done
-- Detecting CXX compile features
-- Detecting CXX compile features - done
-- Found Git: /usr/bin/git (found version "2.17.0")
-- Found Perl: /usr/bin/perl (found version "5.26.2")
-- Looking for pthread.h
-- Looking for pthread.h - found
-- Looking for pthread_create
-- Looking for pthread_create - not found
-- Looking for pthread_create in pthreads
-- Looking for pthread_create in pthreads - not found
-- Looking for pthread_create in pthread
-- Looking for pthread_create in pthread - found
-- Found Threads: TRUE
--- aom_configure: Detected CPU: armv7l
CMake Error at build/cmake/aom_configure.cmake:120 (message):
  No RTCD support for armv7l.  Create it, or add -DAOM_TARGET_CPU=generic to
  your cmake command line for a generic build of libaom and tools.
Call Stack (most recent call first):
  CMakeLists.txt:75 (include)


-- Configuring incomplete, errors occurred!
See also "/mnt/distfiles/tmp/portage/media-libs/libaom-0_pre20180421/work/libaom-.arm/CMakeFiles/CMakeOutput.log".
See also "/mnt/distfiles/tmp/portage/media-libs/libaom-0_pre20180421/work/libaom-.arm/CMakeFiles/CMakeError.log".
 * ERROR: media-libs/libaom-0_pre20180421::gentoo failed (configure phase):
 *   cmake failed
 *
 * Call stack:  
 *     ebuild.sh, line  124:  Called src_configure
 *   environment, line 3359:  Called cmake-multilib_src_configure
 *   environment, line  665:  Called multilib-minimal_src_configure
 *   environment, line 2527:  Called multilib_foreach_abi 'multilib-minimal_abi_src_configure'
 *   environment, line 2741:  Called multibuild_foreach_variant '_multilib_multibuild_wrapper' 'multilib-minimal_abi_src_configure'
 *   environment, line 2457:  Called _multibuild_run '_multilib_multibuild_wrapper' 'multilib-minimal_abi_src_configure'
 *   environment, line 2455:  Called _multilib_multibuild_wrapper 'multilib-minimal_abi_src_configure'
 *   environment, line  528:  Called multilib-minimal_abi_src_configure
 *   environment, line 2521:  Called multilib_src_configure
 *   environment, line 2958:  Called cmake-utils_src_configure
 *   environment, line  840:  Called die
 * The specific snippet of code:
 *       "${CMAKE_BINARY}" "${cmakeargs[@]}" "${CMAKE_USE_DIR}" || die "cmake failed";
Comment 7 Larry the Git Cow gentoo-dev 2018-05-05 12:52:34 UTC
The bug has been referenced in the following commit(s):

https://gitweb.gentoo.org/repo/gentoo.git/commit/?id=3bf17dfe0934a60a4aed56fafc9608ac33a0d63a

commit 3bf17dfe0934a60a4aed56fafc9608ac33a0d63a
Author:     Sergei Trofimovich <slyfox@gentoo.org>
AuthorDate: 2018-05-05 11:59:08 +0000
Commit:     Sergei Trofimovich <slyfox@gentoo.org>
CommitDate: 2018-05-05 12:52:27 +0000

    dev-libs/sord: keyworded 0.16.0-r1 for ia64, bug #653676
    
    Bug: https://bugs.gentoo.org/653676
    Package-Manager: Portage-2.3.36, Repoman-2.3.9
    RepoMan-Options: --include-arches="ia64"

 dev-libs/sord/sord-0.16.0-r1.ebuild | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)

https://gitweb.gentoo.org/repo/gentoo.git/commit/?id=97901f11fc818b886dfd63595a2ce23e1f2b14de

commit 97901f11fc818b886dfd63595a2ce23e1f2b14de
Author:     Sergei Trofimovich <slyfox@gentoo.org>
AuthorDate: 2018-05-05 11:59:02 +0000
Commit:     Sergei Trofimovich <slyfox@gentoo.org>
CommitDate: 2018-05-05 12:52:27 +0000

    media-libs/sratom: keyworded 0.6.0-r1 for ia64, bug #653676
    
    Bug: https://bugs.gentoo.org/653676
    Package-Manager: Portage-2.3.36, Repoman-2.3.9
    RepoMan-Options: --include-arches="ia64"

 media-libs/sratom/sratom-0.6.0-r1.ebuild | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)

https://gitweb.gentoo.org/repo/gentoo.git/commit/?id=39f416c4cf58ac6c3a00e08173f18639ef8f43d8

commit 39f416c4cf58ac6c3a00e08173f18639ef8f43d8
Author:     Sergei Trofimovich <slyfox@gentoo.org>
AuthorDate: 2018-05-05 11:58:46 +0000
Commit:     Sergei Trofimovich <slyfox@gentoo.org>
CommitDate: 2018-05-05 12:52:27 +0000

    media-libs/lilv: keyworded 0.24.2-r2 for ia64, bug #653676
    
    Bug: https://bugs.gentoo.org/653676
    Package-Manager: Portage-2.3.36, Repoman-2.3.9
    RepoMan-Options: --include-arches="ia64"

 media-libs/lilv/lilv-0.24.2-r2.ebuild | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)

https://gitweb.gentoo.org/repo/gentoo.git/commit/?id=9b2418687b9e23eec7cc56bc58f30c71e7bf9b67

commit 9b2418687b9e23eec7cc56bc58f30c71e7bf9b67
Author:     Sergei Trofimovich <slyfox@gentoo.org>
AuthorDate: 2018-05-05 11:49:41 +0000
Commit:     Sergei Trofimovich <slyfox@gentoo.org>
CommitDate: 2018-05-05 12:52:26 +0000

    dev-libs/serd: keyworded 0.28.0-r1 for ia64, bug #653676
    
    Bug: https://bugs.gentoo.org/653676
    Package-Manager: Portage-2.3.36, Repoman-2.3.9
    RepoMan-Options: --include-arches="ia64"

 dev-libs/serd/serd-0.28.0-r1.ebuild | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)

https://gitweb.gentoo.org/repo/gentoo.git/commit/?id=f637f4ca0d59fc11caa41cbfaad0855625f1e47c

commit f637f4ca0d59fc11caa41cbfaad0855625f1e47c
Author:     Sergei Trofimovich <slyfox@gentoo.org>
AuthorDate: 2018-05-05 11:49:16 +0000
Commit:     Sergei Trofimovich <slyfox@gentoo.org>
CommitDate: 2018-05-05 12:52:26 +0000

    media-libs/lv2: keyworded 1.14.0-r1 for ia64, bug #653676
    
    Bug: https://bugs.gentoo.org/653676
    Package-Manager: Portage-2.3.36, Repoman-2.3.9
    RepoMan-Options: --include-arches="ia64"

 media-libs/lv2/lv2-1.14.0-r1.ebuild | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)

https://gitweb.gentoo.org/repo/gentoo.git/commit/?id=2d923d420a344c97bdb22e67aa170d8478867e57

commit 2d923d420a344c97bdb22e67aa170d8478867e57
Author:     Sergei Trofimovich <slyfox@gentoo.org>
AuthorDate: 2018-05-05 11:49:05 +0000
Commit:     Sergei Trofimovich <slyfox@gentoo.org>
CommitDate: 2018-05-05 12:52:26 +0000

    media-libs/codec2: keyworded 0.7 for ia64, bug #653676
    
    Bug: https://bugs.gentoo.org/653676
    Package-Manager: Portage-2.3.36, Repoman-2.3.9
    RepoMan-Options: --include-arches="ia64"

 media-libs/codec2/codec2-0.7.ebuild | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)
Comment 8 Stabilization helper bot gentoo-dev 2018-05-05 13:05:32 UTC
An automated check of this bug failed - repoman reported dependency errors (2 lines truncated): 

> dependency.bad media-libs/lv2/lv2-1.14.0-r1.ebuild: DEPEND: ~amd64-fbsd(default/bsd/fbsd/amd64/11.1) ['dev-python/rdflib']
> dependency.bad media-libs/lv2/lv2-1.14.0-r1.ebuild: RDEPEND: ~amd64-fbsd(default/bsd/fbsd/amd64/11.1) ['dev-python/rdflib[python_targets_python2_7(-)?,python_targets_python3_4(-)?,python_targets_python3_5(-)?,python_targets_python3_6(-)?,-python_single_target_jython2_7(-),-python_single_target_pypy(-),-python_single_target_pypy3(-),python_single_target_python2_7(+)?,python_single_target_python3_4(+)?,python_single_target_python3_5(+)?,python_single_target_python3_6(+)?]']
> dependency.badindev media-libs/lv2/lv2-1.14.0-r1.ebuild: RDEPEND: ~arm64(default/linux/arm64/17.0) ['dev-python/rdflib[python_targets_python2_7(-)?,python_targets_python3_4(-)?,python_targets_python3_5(-)?,python_targets_python3_6(-)?,-python_single_target_jython2_7(-),-python_single_target_pypy(-),-python_single_target_pypy3(-),python_single_target_python2_7(+)?,python_single_target_python3_4(+)?,python_single_target_python3_5(+)?,python_single_target_python3_6(+)?]']
Comment 9 Stabilization helper bot gentoo-dev 2018-05-06 16:05:43 UTC
An automated check of this bug failed - repoman reported dependency errors (43 lines truncated): 

> dependency.bad dev-python/rdflib/rdflib-4.2.2.ebuild: DEPEND: ~amd64-fbsd(default/bsd/fbsd/amd64/11.1) ['dev-python/isodate[python_targets_python2_7(-)?,python_targets_python3_4(-)?,python_targets_python3_5(-)?,python_targets_python3_6(-)?,-python_single_target_python2_7(-),-python_single_target_python3_4(-),-python_single_target_python3_5(-),-python_single_target_python3_6(-)]', 'dev-python/bsddb3[python_targets_python2_7(-)?,python_targets_python3_4(-)?,python_targets_python3_5(-)?,python_targets_python3_6(-)?,-python_single_target_python2_7(-),-python_single_target_python3_4(-),-python_single_target_python3_5(-),-python_single_target_python3_6(-)]', 'dev-libs/redland-bindings[python,python_targets_python2_7(-)?,-python_single_target_python2_7(-)]', 'dev-python/sparql-wrapper[python_targets_python2_7(-)?,python_targets_python3_4(-)?,python_targets_python3_5(-)?,python_targets_python3_6(-)?,-python_single_target_python2_7(-),-python_single_target_python3_4(-),-python_single_target_python3_5(-),-python_single_target_python3_6(-)]']
> dependency.bad dev-python/rdflib/rdflib-4.2.2.ebuild: RDEPEND: ~amd64-fbsd(default/bsd/fbsd/amd64/11.1) ['dev-python/isodate[python_targets_python2_7(-)?,python_targets_python3_4(-)?,python_targets_python3_5(-)?,python_targets_python3_6(-)?,-python_single_target_python2_7(-),-python_single_target_python3_4(-),-python_single_target_python3_5(-),-python_single_target_python3_6(-)]', 'dev-python/bsddb3[python_targets_python2_7(-)?,python_targets_python3_4(-)?,python_targets_python3_5(-)?,python_targets_python3_6(-)?,-python_single_target_python2_7(-),-python_single_target_python3_4(-),-python_single_target_python3_5(-),-python_single_target_python3_6(-)]', 'dev-libs/redland-bindings[python,python_targets_python2_7(-)?,-python_single_target_python2_7(-)]']
> dependency.badindev dev-python/rdflib/rdflib-4.2.2.ebuild: DEPEND: ~arm64(default/linux/arm64/17.0) ['dev-python/isodate[python_targets_python2_7(-)?,python_targets_python3_4(-)?,python_targets_python3_5(-)?,python_targets_python3_6(-)?,-python_single_target_python2_7(-),-python_single_target_python3_4(-),-python_single_target_python3_5(-),-python_single_target_python3_6(-)]', 'dev-python/bsddb3[python_targets_python2_7(-)?,python_targets_python3_4(-)?,python_targets_python3_5(-)?,python_targets_python3_6(-)?,-python_single_target_python2_7(-),-python_single_target_python3_4(-),-python_single_target_python3_5(-),-python_single_target_python3_6(-)]', 'dev-libs/redland-bindings[python,python_targets_python2_7(-)?,-python_single_target_python2_7(-)]', 'dev-python/sparql-wrapper[python_targets_python2_7(-)?,python_targets_python3_4(-)?,python_targets_python3_5(-)?,python_targets_python3_6(-)?,-python_single_target_python2_7(-),-python_single_target_python3_4(-),-python_single_target_python3_5(-),-python_single_target_python3_6(-)]']
> dependency.bad media-libs/lv2/lv2-1.14.0.ebuild: RDEPEND: ppc(default/linux/powerpc/ppc32/13.0) ['dev-python/rdflib[python_targets_python2_7(-)?,python_targets_python3_4(-)?,python_targets_python3_5(-)?,python_targets_python3_6(-)?,-python_single_target_jython2_7(-),-python_single_target_pypy(-),-python_single_target_pypy3(-),python_single_target_python2_7(+)?,python_single_target_python3_4(+)?,python_single_target_python3_5(+)?,python_single_target_python3_6(+)?]']
> dependency.bad media-libs/lv2/lv2-1.14.0.ebuild: RDEPEND: ppc(default/linux/powerpc/ppc32/13.0/desktop) ['dev-python/rdflib[python_targets_python2_7(-)?,python_targets_python3_4(-)?,python_targets_python3_5(-)?,python_targets_python3_6(-)?,-python_single_target_jython2_7(-),-python_single_target_pypy(-),-python_single_target_pypy3(-),python_single_target_python2_7(+)?,python_single_target_python3_4(+)?,python_single_target_python3_5(+)?,python_single_target_python3_6(+)?]']
> dependency.bad media-libs/lv2/lv2-1.14.0.ebuild: RDEPEND: ppc(default/linux/powerpc/ppc32/13.0/desktop/gnome) ['dev-python/rdflib[python_targets_python2_7(-)?,python_targets_python3_4(-)?,python_targets_python3_5(-)?,python_targets_python3_6(-)?,-python_single_target_jython2_7(-),-python_single_target_pypy(-),-python_single_target_pypy3(-),python_single_target_python2_7(+)?,python_single_target_python3_4(+)?,python_single_target_python3_5(+)?,python_single_target_python3_6(+)?]']
Comment 10 Stabilization helper bot gentoo-dev 2018-05-22 23:05:05 UTC
An automated check of this bug failed - repoman reported dependency errors (43 lines truncated): 

> dependency.bad dev-python/rdflib/rdflib-4.2.2.ebuild: DEPEND: ~amd64-fbsd(default/bsd/fbsd/amd64/11.1) ['dev-python/isodate[python_targets_python2_7(-)?,python_targets_python3_4(-)?,python_targets_python3_5(-)?,python_targets_python3_6(-)?,-python_single_target_python2_7(-),-python_single_target_python3_4(-),-python_single_target_python3_5(-),-python_single_target_python3_6(-)]', 'dev-python/bsddb3[python_targets_python2_7(-)?,python_targets_python3_4(-)?,python_targets_python3_5(-)?,python_targets_python3_6(-)?,-python_single_target_python2_7(-),-python_single_target_python3_4(-),-python_single_target_python3_5(-),-python_single_target_python3_6(-)]', 'dev-libs/redland-bindings[python,python_targets_python2_7(-)?,-python_single_target_python2_7(-)]', 'dev-python/sparql-wrapper[python_targets_python2_7(-)?,python_targets_python3_4(-)?,python_targets_python3_5(-)?,python_targets_python3_6(-)?,-python_single_target_python2_7(-),-python_single_target_python3_4(-),-python_single_target_python3_5(-),-python_single_target_python3_6(-)]']
> dependency.bad dev-python/rdflib/rdflib-4.2.2.ebuild: RDEPEND: ~amd64-fbsd(default/bsd/fbsd/amd64/11.1) ['dev-python/isodate[python_targets_python2_7(-)?,python_targets_python3_4(-)?,python_targets_python3_5(-)?,python_targets_python3_6(-)?,-python_single_target_python2_7(-),-python_single_target_python3_4(-),-python_single_target_python3_5(-),-python_single_target_python3_6(-)]', 'dev-python/bsddb3[python_targets_python2_7(-)?,python_targets_python3_4(-)?,python_targets_python3_5(-)?,python_targets_python3_6(-)?,-python_single_target_python2_7(-),-python_single_target_python3_4(-),-python_single_target_python3_5(-),-python_single_target_python3_6(-)]', 'dev-libs/redland-bindings[python,python_targets_python2_7(-)?,-python_single_target_python2_7(-)]']
> dependency.badindev dev-python/rdflib/rdflib-4.2.2.ebuild: DEPEND: ~arm64(default/linux/arm64/17.0) ['dev-python/isodate[python_targets_python2_7(-)?,python_targets_python3_4(-)?,python_targets_python3_5(-)?,python_targets_python3_6(-)?,-python_single_target_python2_7(-),-python_single_target_python3_4(-),-python_single_target_python3_5(-),-python_single_target_python3_6(-)]', 'dev-python/bsddb3[python_targets_python2_7(-)?,python_targets_python3_4(-)?,python_targets_python3_5(-)?,python_targets_python3_6(-)?,-python_single_target_python2_7(-),-python_single_target_python3_4(-),-python_single_target_python3_5(-),-python_single_target_python3_6(-)]', 'dev-libs/redland-bindings[python,python_targets_python2_7(-)?,-python_single_target_python2_7(-)]', 'dev-python/sparql-wrapper[python_targets_python2_7(-)?,python_targets_python3_4(-)?,python_targets_python3_5(-)?,python_targets_python3_6(-)?,-python_single_target_python2_7(-),-python_single_target_python3_4(-),-python_single_target_python3_5(-),-python_single_target_python3_6(-)]']
> dependency.bad media-libs/lv2/lv2-1.14.0.ebuild: RDEPEND: ppc(default/linux/powerpc/ppc32/13.0) ['dev-python/rdflib[python_targets_python2_7(-)?,python_targets_python3_4(-)?,python_targets_python3_5(-)?,python_targets_python3_6(-)?,-python_single_target_jython2_7(-),-python_single_target_pypy(-),-python_single_target_pypy3(-),python_single_target_python2_7(+)?,python_single_target_python3_4(+)?,python_single_target_python3_5(+)?,python_single_target_python3_6(+)?]']
> dependency.bad media-libs/lv2/lv2-1.14.0.ebuild: RDEPEND: ppc(default/linux/powerpc/ppc32/13.0/desktop) ['dev-python/rdflib[python_targets_python2_7(-)?,python_targets_python3_4(-)?,python_targets_python3_5(-)?,python_targets_python3_6(-)?,-python_single_target_jython2_7(-),-python_single_target_pypy(-),-python_single_target_pypy3(-),python_single_target_python2_7(+)?,python_single_target_python3_4(+)?,python_single_target_python3_5(+)?,python_single_target_python3_6(+)?]']
> dependency.bad media-libs/lv2/lv2-1.14.0.ebuild: RDEPEND: ppc(default/linux/powerpc/ppc32/13.0/desktop/gnome) ['dev-python/rdflib[python_targets_python2_7(-)?,python_targets_python3_4(-)?,python_targets_python3_5(-)?,python_targets_python3_6(-)?,-python_single_target_jython2_7(-),-python_single_target_pypy(-),-python_single_target_pypy3(-),python_single_target_python2_7(+)?,python_single_target_python3_4(+)?,python_single_target_python3_5(+)?,python_single_target_python3_6(+)?]']
Comment 11 Thomas Deutschmann gentoo-dev Security 2018-06-11 10:09:54 UTC
x86 keyworded
Comment 12 Thomas Deutschmann gentoo-dev Security 2018-06-11 10:10:04 UTC
x86 keyworded
Comment 13 Stabilization helper bot gentoo-dev 2018-06-15 10:54:07 UTC
An automated check of this bug failed - repoman reported dependency errors (30 lines truncated): 

> dependency.bad media-libs/lv2/lv2-1.14.0.ebuild: RDEPEND: ppc(default/linux/powerpc/ppc32/13.0) ['dev-python/rdflib[python_targets_python2_7(-)?,python_targets_python3_4(-)?,python_targets_python3_5(-)?,python_targets_python3_6(-)?,-python_single_target_jython2_7(-),-python_single_target_pypy(-),-python_single_target_pypy3(-),python_single_target_python2_7(+)?,python_single_target_python3_4(+)?,python_single_target_python3_5(+)?,python_single_target_python3_6(+)?]']
> dependency.bad media-libs/lv2/lv2-1.14.0.ebuild: RDEPEND: ppc(default/linux/powerpc/ppc32/13.0/desktop) ['dev-python/rdflib[python_targets_python2_7(-)?,python_targets_python3_4(-)?,python_targets_python3_5(-)?,python_targets_python3_6(-)?,-python_single_target_jython2_7(-),-python_single_target_pypy(-),-python_single_target_pypy3(-),python_single_target_python2_7(+)?,python_single_target_python3_4(+)?,python_single_target_python3_5(+)?,python_single_target_python3_6(+)?]']
> dependency.bad media-libs/lv2/lv2-1.14.0.ebuild: RDEPEND: ppc(default/linux/powerpc/ppc32/13.0/desktop/gnome) ['dev-python/rdflib[python_targets_python2_7(-)?,python_targets_python3_4(-)?,python_targets_python3_5(-)?,python_targets_python3_6(-)?,-python_single_target_jython2_7(-),-python_single_target_pypy(-),-python_single_target_pypy3(-),python_single_target_python2_7(+)?,python_single_target_python3_4(+)?,python_single_target_python3_5(+)?,python_single_target_python3_6(+)?]']
> dependency.bad dev-python/rdflib/rdflib-4.2.2.ebuild: DEPEND: ~amd64-fbsd(default/bsd/fbsd/amd64/11.1) ['dev-python/isodate[python_targets_python2_7(-)?,python_targets_python3_4(-)?,python_targets_python3_5(-)?,python_targets_python3_6(-)?,-python_single_target_python2_7(-),-python_single_target_python3_4(-),-python_single_target_python3_5(-),-python_single_target_python3_6(-)]', 'dev-python/bsddb3[python_targets_python2_7(-)?,python_targets_python3_4(-)?,python_targets_python3_5(-)?,python_targets_python3_6(-)?,-python_single_target_python2_7(-),-python_single_target_python3_4(-),-python_single_target_python3_5(-),-python_single_target_python3_6(-)]', 'dev-libs/redland-bindings[python,python_targets_python2_7(-)?,-python_single_target_python2_7(-)]', 'dev-python/sparql-wrapper[python_targets_python2_7(-)?,python_targets_python3_4(-)?,python_targets_python3_5(-)?,python_targets_python3_6(-)?,-python_single_target_python2_7(-),-python_single_target_python3_4(-),-python_single_target_python3_5(-),-python_single_target_python3_6(-)]']
> dependency.bad dev-python/rdflib/rdflib-4.2.2.ebuild: RDEPEND: ~amd64-fbsd(default/bsd/fbsd/amd64/11.1) ['dev-python/isodate[python_targets_python2_7(-)?,python_targets_python3_4(-)?,python_targets_python3_5(-)?,python_targets_python3_6(-)?,-python_single_target_python2_7(-),-python_single_target_python3_4(-),-python_single_target_python3_5(-),-python_single_target_python3_6(-)]', 'dev-python/bsddb3[python_targets_python2_7(-)?,python_targets_python3_4(-)?,python_targets_python3_5(-)?,python_targets_python3_6(-)?,-python_single_target_python2_7(-),-python_single_target_python3_4(-),-python_single_target_python3_5(-),-python_single_target_python3_6(-)]', 'dev-libs/redland-bindings[python,python_targets_python2_7(-)?,-python_single_target_python2_7(-)]']
> dependency.badindev dev-python/rdflib/rdflib-4.2.2.ebuild: DEPEND: ~arm64(default/linux/arm64/17.0) ['dev-python/isodate[python_targets_python2_7(-)?,python_targets_python3_4(-)?,python_targets_python3_5(-)?,python_targets_python3_6(-)?,-python_single_target_python2_7(-),-python_single_target_python3_4(-),-python_single_target_python3_5(-),-python_single_target_python3_6(-)]', 'dev-python/bsddb3[python_targets_python2_7(-)?,python_targets_python3_4(-)?,python_targets_python3_5(-)?,python_targets_python3_6(-)?,-python_single_target_python2_7(-),-python_single_target_python3_4(-),-python_single_target_python3_5(-),-python_single_target_python3_6(-)]', 'dev-libs/redland-bindings[python,python_targets_python2_7(-)?,-python_single_target_python2_7(-)]', 'dev-python/sparql-wrapper[python_targets_python2_7(-)?,python_targets_python3_4(-)?,python_targets_python3_5(-)?,python_targets_python3_6(-)?,-python_single_target_python2_7(-),-python_single_target_python3_4(-),-python_single_target_python3_5(-),-python_single_target_python3_6(-)]']
Comment 14 Mikle Kolyada archtester Gentoo Infrastructure gentoo-dev Security 2018-07-22 01:55:57 UTC
~arm restored
Comment 15 Stabilization helper bot gentoo-dev 2018-07-22 01:59:08 UTC
An automated check of this bug failed - the following atoms are unknown:

media-libs/libaom-0_pre20180421
media-video/ffmpeg-4.0

Please verify the atom list.
Comment 16 Stabilization helper bot gentoo-dev 2018-08-11 09:58:25 UTC
An automated check of this bug failed - the following atoms are unknown:

media-video/ffmpeg-4.0
media-libs/libaom-0_pre20180421

Please verify the atom list.
Comment 17 Stabilization helper bot gentoo-dev 2018-09-16 09:03:35 UTC
An automated check of this bug failed - repoman reported dependency errors (5 lines truncated): 

> dependency.bad dev-python/rdflib/rdflib-4.2.2.ebuild: DEPEND: ~amd64-fbsd(default/bsd/fbsd/amd64/11.1) ['dev-python/isodate[python_targets_python2_7(-)?,python_targets_python3_4(-)?,python_targets_python3_5(-)?,python_targets_python3_6(-)?,-python_single_target_python2_7(-),-python_single_target_python3_4(-),-python_single_target_python3_5(-),-python_single_target_python3_6(-)]', 'dev-python/bsddb3[python_targets_python2_7(-)?,python_targets_python3_4(-)?,python_targets_python3_5(-)?,python_targets_python3_6(-)?,-python_single_target_python2_7(-),-python_single_target_python3_4(-),-python_single_target_python3_5(-),-python_single_target_python3_6(-)]', 'dev-libs/redland-bindings[python,python_targets_python2_7(-)?,-python_single_target_python2_7(-)]', 'dev-python/sparql-wrapper[python_targets_python2_7(-)?,python_targets_python3_4(-)?,python_targets_python3_5(-)?,python_targets_python3_6(-)?,-python_single_target_python2_7(-),-python_single_target_python3_4(-),-python_single_target_python3_5(-),-python_single_target_python3_6(-)]']
> dependency.bad dev-python/rdflib/rdflib-4.2.2.ebuild: RDEPEND: ~amd64-fbsd(default/bsd/fbsd/amd64/11.1) ['dev-python/isodate[python_targets_python2_7(-)?,python_targets_python3_4(-)?,python_targets_python3_5(-)?,python_targets_python3_6(-)?,-python_single_target_python2_7(-),-python_single_target_python3_4(-),-python_single_target_python3_5(-),-python_single_target_python3_6(-)]', 'dev-python/bsddb3[python_targets_python2_7(-)?,python_targets_python3_4(-)?,python_targets_python3_5(-)?,python_targets_python3_6(-)?,-python_single_target_python2_7(-),-python_single_target_python3_4(-),-python_single_target_python3_5(-),-python_single_target_python3_6(-)]', 'dev-libs/redland-bindings[python,python_targets_python2_7(-)?,-python_single_target_python2_7(-)]']
> dependency.badindev dev-python/rdflib/rdflib-4.2.2.ebuild: DEPEND: ~arm64(default/linux/arm64/17.0) ['dev-python/isodate[python_targets_python2_7(-)?,python_targets_python3_4(-)?,python_targets_python3_5(-)?,python_targets_python3_6(-)?,-python_single_target_python2_7(-),-python_single_target_python3_4(-),-python_single_target_python3_5(-),-python_single_target_python3_6(-)]', 'dev-python/bsddb3[python_targets_python2_7(-)?,python_targets_python3_4(-)?,python_targets_python3_5(-)?,python_targets_python3_6(-)?,-python_single_target_python2_7(-),-python_single_target_python3_4(-),-python_single_target_python3_5(-),-python_single_target_python3_6(-)]', 'dev-libs/redland-bindings[python,python_targets_python2_7(-)?,-python_single_target_python2_7(-)]', 'dev-python/sparql-wrapper[python_targets_python2_7(-)?,python_targets_python3_4(-)?,python_targets_python3_5(-)?,python_targets_python3_6(-)?,-python_single_target_python2_7(-),-python_single_target_python3_4(-),-python_single_target_python3_5(-),-python_single_target_python3_6(-)]']
Comment 18 Stabilization helper bot gentoo-dev 2018-09-17 21:04:30 UTC
An automated check of this bug failed - repoman reported dependency errors (5 lines truncated): 

> dependency.bad dev-python/rdflib/rdflib-4.2.2.ebuild: DEPEND: ~amd64-fbsd(default/bsd/fbsd/amd64/11.1) ['dev-python/isodate[python_targets_python2_7(-)?,python_targets_python3_4(-)?,python_targets_python3_5(-)?,python_targets_python3_6(-)?,-python_single_target_python2_7(-),-python_single_target_python3_4(-),-python_single_target_python3_5(-),-python_single_target_python3_6(-)]', 'dev-python/bsddb3[python_targets_python2_7(-)?,python_targets_python3_4(-)?,python_targets_python3_5(-)?,python_targets_python3_6(-)?,-python_single_target_python2_7(-),-python_single_target_python3_4(-),-python_single_target_python3_5(-),-python_single_target_python3_6(-)]', 'dev-libs/redland-bindings[python,python_targets_python2_7(-)?,-python_single_target_python2_7(-)]', 'dev-python/sparql-wrapper[python_targets_python2_7(-)?,python_targets_python3_4(-)?,python_targets_python3_5(-)?,python_targets_python3_6(-)?,-python_single_target_python2_7(-),-python_single_target_python3_4(-),-python_single_target_python3_5(-),-python_single_target_python3_6(-)]']
> dependency.bad dev-python/rdflib/rdflib-4.2.2.ebuild: RDEPEND: ~amd64-fbsd(default/bsd/fbsd/amd64/11.1) ['dev-python/isodate[python_targets_python2_7(-)?,python_targets_python3_4(-)?,python_targets_python3_5(-)?,python_targets_python3_6(-)?,-python_single_target_python2_7(-),-python_single_target_python3_4(-),-python_single_target_python3_5(-),-python_single_target_python3_6(-)]', 'dev-python/bsddb3[python_targets_python2_7(-)?,python_targets_python3_4(-)?,python_targets_python3_5(-)?,python_targets_python3_6(-)?,-python_single_target_python2_7(-),-python_single_target_python3_4(-),-python_single_target_python3_5(-),-python_single_target_python3_6(-)]', 'dev-libs/redland-bindings[python,python_targets_python2_7(-)?,-python_single_target_python2_7(-)]']
> dependency.badindev dev-python/rdflib/rdflib-4.2.2.ebuild: DEPEND: ~arm64(default/linux/arm64/17.0) ['dev-python/isodate[python_targets_python2_7(-)?,python_targets_python3_4(-)?,python_targets_python3_5(-)?,python_targets_python3_6(-)?,-python_single_target_python2_7(-),-python_single_target_python3_4(-),-python_single_target_python3_5(-),-python_single_target_python3_6(-)]', 'dev-python/bsddb3[python_targets_python2_7(-)?,python_targets_python3_4(-)?,python_targets_python3_5(-)?,python_targets_python3_6(-)?,-python_single_target_python2_7(-),-python_single_target_python3_4(-),-python_single_target_python3_5(-),-python_single_target_python3_6(-)]', 'dev-libs/redland-bindings[python,python_targets_python2_7(-)?,-python_single_target_python2_7(-)]', 'dev-python/sparql-wrapper[python_targets_python2_7(-)?,python_targets_python3_4(-)?,python_targets_python3_5(-)?,python_targets_python3_6(-)?,-python_single_target_python2_7(-),-python_single_target_python3_4(-),-python_single_target_python3_5(-),-python_single_target_python3_6(-)]']
Comment 19 Matt Turner gentoo-dev 2018-09-17 21:06:47 UTC
amd64-fbsd is gumming up the works.
Comment 20 ernsteiswuerfel 2018-11-13 00:32:54 UTC
Created attachment 554998 [details]
build.log.xz (ppc64)

Situation on ppc64.

Apart from bug #671036 and bug #671038 ffmpeg-4.0.2 builds fine with almost all USE-flags.
Comment 21 Craig Andrews gentoo-dev 2018-11-13 12:59:31 UTC
Since bug 658068 has been resolved, can we please resume this keywording effort?
Comment 22 ernsteiswuerfel 2018-11-18 15:44:56 UTC
Created attachment 555620 [details]
build.log.xz (ppc)

Situation on ppc.

Same as ppc64. Apart from bug #671036 and bug #671038 ffmpeg-4.0.2 builds fine with almost all USE-flags.
Comment 23 Sergei Trofimovich gentoo-dev 2018-11-24 12:40:58 UTC
~ppc/~ppc64 keyworded thanks to ernsteiswuerfel!
Comment 24 Stabilization helper bot gentoo-dev 2018-11-24 13:02:50 UTC
An automated check of this bug failed - repoman reported dependency errors (17 lines truncated): 

> dependency.bad media-video/ffmpeg/ffmpeg-4.0.2.ebuild: DEPEND: ~alpha(default/linux/alpha/13.0) ['>=net-libs/zeromq-4.1.6']
> dependency.bad media-video/ffmpeg/ffmpeg-4.0.2.ebuild: RDEPEND: ~alpha(default/linux/alpha/13.0) ['>=net-libs/zeromq-4.1.6']
> dependency.bad media-video/ffmpeg/ffmpeg-4.0.2.ebuild: DEPEND: ~alpha(default/linux/alpha/13.0/desktop) ['>=net-libs/zeromq-4.1.6']
Comment 25 Mart Raudsepp gentoo-dev 2018-11-25 23:24:57 UTC
Should the versions be updated to latest now, e.g. ffmpeg-4.1?

Anyways, please re-keyword gst-plugins-libav as well, together with ffmpeg-4.x.

Adding amd64-fbsd@ too, who seems to have been left out here..
Comment 26 Stabilization helper bot gentoo-dev 2018-11-26 00:01:59 UTC
An automated check of this bug failed - repoman reported dependency errors (24 lines truncated): 

> dependency.bad media-video/ffmpeg/ffmpeg-4.0.2.ebuild: DEPEND: ~amd64-fbsd(default/bsd/fbsd/amd64/11.1) ['media-libs/nv-codec-headers[abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?,abi_ppc_32(-)?,abi_ppc_64(-)?,abi_s390_32(-)?,abi_s390_64(-)?]']
> dependency.bad media-video/ffmpeg/ffmpeg-4.0.2.ebuild: RDEPEND: ~amd64-fbsd(default/bsd/fbsd/amd64/11.1) ['media-libs/nv-codec-headers[abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?,abi_ppc_32(-)?,abi_ppc_64(-)?,abi_s390_32(-)?,abi_s390_64(-)?]']
> dependency.bad media-video/ffmpeg/ffmpeg-4.0.2.ebuild: DEPEND: ~alpha(default/linux/alpha/13.0) ['>=net-libs/zeromq-4.1.6']
> dependency.bad dev-python/rdflib/rdflib-4.2.2.ebuild: DEPEND: ~amd64-fbsd(default/bsd/fbsd/amd64/11.1) ['dev-python/isodate[python_targets_python2_7(-)?,python_targets_python3_4(-)?,python_targets_python3_5(-)?,python_targets_python3_6(-)?,-python_single_target_python2_7(-),-python_single_target_python3_4(-),-python_single_target_python3_5(-),-python_single_target_python3_6(-)]', 'dev-python/bsddb3[python_targets_python2_7(-)?,python_targets_python3_4(-)?,python_targets_python3_5(-)?,python_targets_python3_6(-)?,-python_single_target_python2_7(-),-python_single_target_python3_4(-),-python_single_target_python3_5(-),-python_single_target_python3_6(-)]', 'dev-libs/redland-bindings[python,python_targets_python2_7(-)?,-python_single_target_python2_7(-)]', 'dev-python/sparql-wrapper[python_targets_python2_7(-)?,python_targets_python3_4(-)?,python_targets_python3_5(-)?,python_targets_python3_6(-)?,-python_single_target_python2_7(-),-python_single_target_python3_4(-),-python_single_target_python3_5(-),-python_single_target_python3_6(-)]']
> dependency.bad dev-python/rdflib/rdflib-4.2.2.ebuild: RDEPEND: ~amd64-fbsd(default/bsd/fbsd/amd64/11.1) ['dev-python/isodate[python_targets_python2_7(-)?,python_targets_python3_4(-)?,python_targets_python3_5(-)?,python_targets_python3_6(-)?,-python_single_target_python2_7(-),-python_single_target_python3_4(-),-python_single_target_python3_5(-),-python_single_target_python3_6(-)]', 'dev-python/bsddb3[python_targets_python2_7(-)?,python_targets_python3_4(-)?,python_targets_python3_5(-)?,python_targets_python3_6(-)?,-python_single_target_python2_7(-),-python_single_target_python3_4(-),-python_single_target_python3_5(-),-python_single_target_python3_6(-)]', 'dev-libs/redland-bindings[python,python_targets_python2_7(-)?,-python_single_target_python2_7(-)]']
> dependency.badindev dev-python/rdflib/rdflib-4.2.2.ebuild: DEPEND: ~arm64(default/linux/arm64/17.0) ['dev-python/isodate[python_targets_python2_7(-)?,python_targets_python3_4(-)?,python_targets_python3_5(-)?,python_targets_python3_6(-)?,-python_single_target_python2_7(-),-python_single_target_python3_4(-),-python_single_target_python3_5(-),-python_single_target_python3_6(-)]', 'dev-python/bsddb3[python_targets_python2_7(-)?,python_targets_python3_4(-)?,python_targets_python3_5(-)?,python_targets_python3_6(-)?,-python_single_target_python2_7(-),-python_single_target_python3_4(-),-python_single_target_python3_5(-),-python_single_target_python3_6(-)]', 'dev-libs/redland-bindings[python,python_targets_python2_7(-)?,-python_single_target_python2_7(-)]', 'dev-python/sparql-wrapper[python_targets_python2_7(-)?,python_targets_python3_4(-)?,python_targets_python3_5(-)?,python_targets_python3_6(-)?,-python_single_target_python2_7(-),-python_single_target_python3_4(-),-python_single_target_python3_5(-),-python_single_target_python3_6(-)]']
Comment 27 Matt Turner gentoo-dev 2018-12-22 17:08:39 UTC
media-video/ffmpeg-4.0.2 -> media-video/ffmpeg-4.1
media-libs/libaom-1.0.0 -> media-libs/libaom-1.0.0-r1

Also dropping amd64-fbsd@ as that made a real mess per comment 26.
Comment 28 Matt Turner gentoo-dev 2018-12-23 03:24:17 UTC
added ~alpha
Comment 29 Sergei Trofimovich gentoo-dev 2018-12-25 20:34:43 UTC
~hppa keyworded. Stable keywords breakage will be sorted separately.
Comment 30 Alexis Ballier gentoo-dev 2019-02-19 13:24:47 UTC
arm64 done
Comment 31 Alexis Ballier gentoo-dev 2019-02-19 13:25:02 UTC
amd64-fbsd is missing
Comment 32 Stabilization helper bot gentoo-dev 2019-02-19 14:00:59 UTC
An automated check of this bug failed - repoman reported dependency errors: 

> dependency.bad media-video/ffmpeg/ffmpeg-4.1.1.ebuild: DEPEND: ~amd64-fbsd(default/bsd/fbsd/amd64/11.1) ['>=net-libs/srt-1.3.0[abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?,abi_ppc_32(-)?,abi_ppc_64(-)?,abi_s390_32(-)?,abi_s390_64(-)?]', '>=media-libs/nv-codec-headers-8.1.24.2[abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?,abi_ppc_32(-)?,abi_ppc_64(-)?,abi_s390_32(-)?,abi_s390_64(-)?]']
> dependency.bad media-video/ffmpeg/ffmpeg-4.1.1.ebuild: RDEPEND: ~amd64-fbsd(default/bsd/fbsd/amd64/11.1) ['>=net-libs/srt-1.3.0[abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?,abi_ppc_32(-)?,abi_ppc_64(-)?,abi_s390_32(-)?,abi_s390_64(-)?]', '>=media-libs/nv-codec-headers-8.1.24.2[abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?,abi_ppc_32(-)?,abi_ppc_64(-)?,abi_s390_32(-)?,abi_s390_64(-)?]']
> dependency.bad dev-python/rdflib/rdflib-4.2.2.ebuild: DEPEND: ~amd64-fbsd(default/bsd/fbsd/amd64/11.1) ['dev-python/isodate[python_targets_python2_7(-)?,python_targets_python3_4(-)?,python_targets_python3_5(-)?,python_targets_python3_6(-)?,-python_single_target_python2_7(-),-python_single_target_python3_4(-),-python_single_target_python3_5(-),-python_single_target_python3_6(-)]', 'dev-python/bsddb3[python_targets_python2_7(-)?,python_targets_python3_4(-)?,python_targets_python3_5(-)?,python_targets_python3_6(-)?,-python_single_target_python2_7(-),-python_single_target_python3_4(-),-python_single_target_python3_5(-),-python_single_target_python3_6(-)]', 'dev-libs/redland-bindings[python,python_targets_python2_7(-)?,-python_single_target_python2_7(-)]', 'dev-python/sparql-wrapper[python_targets_python2_7(-)?,python_targets_python3_4(-)?,python_targets_python3_5(-)?,python_targets_python3_6(-)?,-python_single_target_python2_7(-),-python_single_target_python3_4(-),-python_single_target_python3_5(-),-python_single_target_python3_6(-)]']
> dependency.bad dev-python/rdflib/rdflib-4.2.2.ebuild: RDEPEND: ~amd64-fbsd(default/bsd/fbsd/amd64/11.1) ['dev-python/isodate[python_targets_python2_7(-)?,python_targets_python3_4(-)?,python_targets_python3_5(-)?,python_targets_python3_6(-)?,-python_single_target_python2_7(-),-python_single_target_python3_4(-),-python_single_target_python3_5(-),-python_single_target_python3_6(-)]', 'dev-python/bsddb3[python_targets_python2_7(-)?,python_targets_python3_4(-)?,python_targets_python3_5(-)?,python_targets_python3_6(-)?,-python_single_target_python2_7(-),-python_single_target_python3_4(-),-python_single_target_python3_5(-),-python_single_target_python3_6(-)]', 'dev-libs/redland-bindings[python,python_targets_python2_7(-)?,-python_single_target_python2_7(-)]']
Comment 33 Stabilization helper bot gentoo-dev 2019-04-04 12:01:03 UTC
An automated check of this bug failed - repoman reported dependency errors: 

> dependency.bad media-video/ffmpeg/ffmpeg-4.1.1.ebuild: DEPEND: ~amd64-fbsd(default/bsd/fbsd/amd64/11.1) ['>=net-libs/srt-1.3.0[abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?,abi_ppc_32(-)?,abi_ppc_64(-)?,abi_s390_32(-)?,abi_s390_64(-)?]', '>=media-libs/nv-codec-headers-8.1.24.2[abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?,abi_ppc_32(-)?,abi_ppc_64(-)?,abi_s390_32(-)?,abi_s390_64(-)?]']
> dependency.bad media-video/ffmpeg/ffmpeg-4.1.1.ebuild: RDEPEND: ~amd64-fbsd(default/bsd/fbsd/amd64/11.1) ['>=net-libs/srt-1.3.0[abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?,abi_ppc_32(-)?,abi_ppc_64(-)?,abi_s390_32(-)?,abi_s390_64(-)?]', '>=media-libs/nv-codec-headers-8.1.24.2[abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?,abi_ppc_32(-)?,abi_ppc_64(-)?,abi_s390_32(-)?,abi_s390_64(-)?]']
> dependency.bad dev-python/rdflib/rdflib-4.2.2.ebuild: DEPEND: ~amd64-fbsd(default/bsd/fbsd/amd64/11.1) ['dev-python/isodate[python_targets_python2_7(-)?,python_targets_python3_5(-)?,python_targets_python3_6(-)?,-python_single_target_python2_7(-),-python_single_target_python3_5(-),-python_single_target_python3_6(-)]', 'dev-python/bsddb3[python_targets_python2_7(-)?,python_targets_python3_5(-)?,python_targets_python3_6(-)?,-python_single_target_python2_7(-),-python_single_target_python3_5(-),-python_single_target_python3_6(-)]', 'dev-libs/redland-bindings[python,python_targets_python2_7(-)?,-python_single_target_python2_7(-)]', 'dev-python/sparql-wrapper[python_targets_python2_7(-)?,python_targets_python3_5(-)?,python_targets_python3_6(-)?,-python_single_target_python2_7(-),-python_single_target_python3_5(-),-python_single_target_python3_6(-)]']
> dependency.bad dev-python/rdflib/rdflib-4.2.2.ebuild: RDEPEND: ~amd64-fbsd(default/bsd/fbsd/amd64/11.1) ['dev-python/isodate[python_targets_python2_7(-)?,python_targets_python3_5(-)?,python_targets_python3_6(-)?,-python_single_target_python2_7(-),-python_single_target_python3_5(-),-python_single_target_python3_6(-)]', 'dev-python/bsddb3[python_targets_python2_7(-)?,python_targets_python3_5(-)?,python_targets_python3_6(-)?,-python_single_target_python2_7(-),-python_single_target_python3_5(-),-python_single_target_python3_6(-)]', 'dev-libs/redland-bindings[python,python_targets_python2_7(-)?,-python_single_target_python2_7(-)]']