Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 653098 - net-vpn/tor-0.3.1.10 FAIL: src/test/test_bt.sh
Summary: net-vpn/tor-0.3.1.10 FAIL: src/test/test_bt.sh
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: PPC Linux
: Normal normal (vote)
Assignee: Anthony Basile
URL:
Whiteboard:
Keywords: TESTFAILURE
Depends on:
Blocks:
 
Reported: 2018-04-13 14:19 UTC by ernsteiswuerfel
Modified: 2018-04-14 14:31 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
emerge --info (file_653098.txt,5.55 KB, text/plain)
2018-04-13 14:19 UTC, ernsteiswuerfel
Details
build.log (build.log,708.44 KB, text/plain)
2018-04-13 14:24 UTC, ernsteiswuerfel
Details
test-suite.log (test-suite.log,1.32 KB, text/plain)
2018-04-13 14:24 UTC, ernsteiswuerfel
Details

Note You need to log in before you can comment on or make changes to this bug.
Description ernsteiswuerfel 2018-04-13 14:19:00 UTC
Created attachment 527256 [details]
emerge --info

SKIP: src/test/fuzz_static_testcases.sh
PASS: src/test/test_workqueue_cancel.sh
PASS: src/test/test_zero_length_keys.sh
PASS: src/test/test_keygen.sh
PASS: src/test/test_workqueue_efd2.sh
PASS: src/test/test_workqueue_pipe.sh
PASS: src/test/test_workqueue_pipe2.sh
PASS: src/test/test_workqueue_socketpair.sh
SKIP: src/test/test_switch_id.sh
PASS: src/test/test_ntor.sh
SKIP: src/test/test_hs_ntor.sh
FAIL: src/test/test_bt.sh
PASS: src/test/test
PASS: src/test/test-memwipe
PASS: src/test/test_workqueue_efd.sh
PASS: src/test/test_workqueue
PASS: src/test/test-slow
PASS: src/test/test-timers
============================================================================
Testsuite summary for tor 0.3.1.10
============================================================================
# TOTAL: 18
# PASS:  14
# SKIP:  3
# XFAIL: 0
# FAIL:  1
# XPASS: 0
# ERROR: 0
Comment 1 ernsteiswuerfel 2018-04-13 14:21:39 UTC
The automatically generated coredump sez:

# coredumpctl gdb
#           PID: 29263 (test-bt-cl)
           UID: 250 (portage)
           GID: 250 (portage)
        Signal: 6 (ABRT)
     Timestamp: Fri 2018-04-13 16:07:14 CEST (12min ago)
  Command Line: ./src/test/test-bt-cl crash
    Executable: /var/tmp/portage/net-vpn/tor-0.3.1.10/work/tor-0.3.1.10/src/test/test-bt-cl
 Control Group: /user.slice/user-1000.slice/session-c1.scope
          Unit: session-c1.scope
         Slice: user-1000.slice
       Session: c1
     Owner UID: 1000 (ef)
       Boot ID: 3d0a325586f94848a8d1b08368e76868
    Machine ID: a11f6dbd63d44c20941f9f48a8fbb3e4
      Hostname: T800
       Storage: /var/lib/systemd/coredump/core.test-bt-cl.250.3d0a325586f94848a8d1b08368e76868.29263.1523628434000000.lz4
       Message: Process 29263 (test-bt-cl) of user 250 dumped core.
                
                Stack trace of thread 29263:
                #0  0x00000000007098a8 __libc_signal_restore_set (libc.so.6)
                #1  0x000000000070b3ac __GI_abort (libc.so.6)
                #2  0x0000000000a25d84 n/a (/var/tmp/portage/net-vpn/tor-0.3.1.10/work/tor-0.3.1.10/src/test/test-bt-cl)

GNU gdb (Gentoo 7.12.1 vanilla) 7.12.1
Copyright (C) 2017 Free Software Foundation, Inc.
License GPLv3+: GNU GPL version 3 or later <http://gnu.org/licenses/gpl.html>
This is free software: you are free to change and redistribute it.
There is NO WARRANTY, to the extent permitted by law.  Type "show copying"
and "show warranty" for details.
This GDB was configured as "powerpc-unknown-linux-gnu".
Type "show configuration" for configuration details.
For bug reporting instructions, please see:
<https://bugs.gentoo.org/>.
Find the GDB manual and other documentation resources online at:
<http://www.gnu.org/software/gdb/documentation/>.
For help, type "help".
Type "apropos word" to search for commands related to "word"...
Reading symbols from /var/tmp/portage/net-vpn/tor-0.3.1.10/work/tor-0.3.1.10/src/test/test-bt-cl...done.
[New LWP 29263]
[Thread debugging using libthread_db enabled]
Using host libthread_db library "/lib/libthread_db.so.1".
Core was generated by `./src/test/test-bt-cl crash'.
Program terminated with signal SIGABRT, Aborted.
#0  0x007098a8 in __libc_signal_restore_set (set=0xffee2ad8) at ../sysdeps/unix/sysv/linux/nptl-signals.h:79
79	../sysdeps/unix/sysv/linux/nptl-signals.h: Datei oder Verzeichnis nicht gefunden.
Comment 2 ernsteiswuerfel 2018-04-13 14:24:26 UTC
Created attachment 527258 [details]
build.log
Comment 3 ernsteiswuerfel 2018-04-13 14:24:57 UTC
Created attachment 527260 [details]
test-suite.log
Comment 4 Anthony Basile gentoo-dev 2018-04-14 10:51:14 UTC
I am unable to reproduce

============================================================================
Testsuite summary for tor 0.3.1.10
============================================================================
# TOTAL: 18
# PASS:  15
# SKIP:  3
# XFAIL: 0
# FAIL:  0
# XPASS: 0
# ERROR: 0

I don't know what it is about your environment that is causing test_bt.sh to fail.  The latter runs test-bt-cl and checks to make sure tor is properly dealing with assertion errors, crashes, and backtraces.  So that's a clue to what's going wrong on your side.

This bug should not block stabilizations.
Comment 5 ernsteiswuerfel 2018-04-14 12:35:44 UTC
Maybe it's a ppc/ppc64 related problem then. This test keeps crashing on my setup, which is just a plain stable ppc64/32ul. Perhaps someone with ppc gear could try to reproduce it?
Comment 6 Anthony Basile gentoo-dev 2018-04-14 14:31:24 UTC
(In reply to ernsteiswuerfel from comment #5)
> Maybe it's a ppc/ppc64 related problem then. This test keeps crashing on my
> setup, which is just a plain stable ppc64/32ul. Perhaps someone with ppc
> gear could try to reproduce it?

Yeah, i just confirmed that they're broken on ppc/ppc64.  So ...


Author: Anthony G. Basile <blueness@gentoo.org>
Date:   Sat Apr 14 10:30:01 2018 -0400

    profiles: mask tests for net-vpn/tor on ppc/ppc64, bug #653098
    
    Signed-off-by: Anthony G. Basile <blueness@gentoo.org>

diff --git a/profiles/arch/powerpc/package.use.mask b/profiles/arch/powerpc/package.use.mask
index 143f2356b20..806ef205bdc 100644
--- a/profiles/arch/powerpc/package.use.mask
+++ b/profiles/arch/powerpc/package.use.mask
@@ -1,6 +1,10 @@
 # Copyright 1999-2018 Gentoo Foundation
 # Distributed under the terms of the GNU General Public License v2
 
+# Anthony G. Basile <blueness@gentoo.org> (14 Apr 2018)
+# net-vpn/tor, tests are broken on ppc/ppc64, bug #653098
+net-vpn/tor test
+