Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 65247 - livecd will not boot on new G5 dual-1.8
Summary: livecd will not boot on new G5 dual-1.8
Alias: None
Product: Gentoo Release Media
Classification: Unclassified
Component: Everything (show other bugs)
Hardware: PPC64 All
: High blocker (vote)
Assignee: ppc64 architecture team
Depends on:
Reported: 2004-09-24 15:21 UTC by atom
Modified: 2005-03-24 14:16 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---


Note You need to log in before you can comment on or make changes to this bug.
Description atom 2004-09-24 15:21:15 UTC
[boot]0025 openPic2_Done
PID hash table entries: 16 (order 4:256 bytes)
time_init: decrementer frequency = 33.333333 MHz
smp_core99_kick_cpu done
core99_setup_cpu 0 done

The machine then freezes, and the fans slowly start to rev. After a brief time the computer reboots.

i am not the only one with the issue:

both of our machines are new dual-1.8 with ATI 9600xt. i have tried the following livecds: 2004.1 ppc64, 2004.2beta5 ppc64, 2004.2 universal-ppc, as well as debian based ppc cds. i can get no kernel to boot on this machine.
Comment 1 atom 2004-09-24 15:23:33 UTC
this should probably be assigned to tgall.
Comment 2 Tom Gall (RETIRED) gentoo-dev 2004-09-24 20:01:47 UTC
Thanks ... actually ppc64 is more appropriate it :-)

Anyway ... I'm somewhat concerned about the ATI9600xt. I have no experiences with these cards and it's quite possible that's the heart of the problem. Basically the kernel takes one look at the cards, sees PCI ID and doesn't recognize it.  

I am sure you probalby can get the pci informatoin from OSX but I must confess I'm a bit to used to linux's lspci to know what the OSX equivilent is.  It might be googable.  Could you also from the system information OSX verify which 970 process or you have?  970 or 970fx. I bet it's a 970fx. 

In the meantime I'll spin a new cd. 

Did you upgrade the card or is that something that apple shipped?
Comment 3 Tom Gall (RETIRED) gentoo-dev 2004-09-24 20:04:28 UTC
aha!  confirmation, need 2.6.8 minimum. 2.6.7 is on the current livecd.  So the new livecd will fix this. Should be up sometime saturday. 
Comment 4 Tom Gall (RETIRED) gentoo-dev 2004-09-25 10:41:48 UTC
cd generated, upload in progress
Comment 5 Tom Gall (RETIRED) gentoo-dev 2004-09-25 21:01:06 UTC
beta6 for pmac hardware is released, please test
Comment 6 atom 2004-09-27 11:45:24 UTC
same thing with beta6. hangs on same output.

Hardware Overview:

  Machine Model:	Power Mac G5
  CPU Type:	PowerPC G5  (2.2)
  Number Of CPUs:	2
  CPU Speed:	1.8 GHz
  L2 Cache (per CPU):	512 KB
  Memory:	512 MB
  Bus Speed:	900 MHz
  Boot ROM Version:	5.1.8f3


  Type:	display
  Bus:	AGP
  Display Type:	CRT
  Slot:	SLOT-1
  VRAM (Total):	128 MB
  Vendor:	ATI (0x1002)
  Device ID:	0x4152
  Revision ID:	0x0000
  ROM Revision:	113-A13602-121
Comment 7 atom 2004-09-27 17:09:51 UTC
per tgall's request tested with a different video card.

ati 9600xt
nvidia 5200

its not the video card.
my machine is a powermac7,3 and the other test was a 7,2
results: 7,2+nvidia = worked. 7,2+ati = worked. 7,3+ati = no. 7,3+nvidia=no.
Comment 8 Tom Gall (RETIRED) gentoo-dev 2004-09-28 19:44:29 UTC
just to keep the bug up to date. atom, indicated that thedebug kernel i put on the cd last night revealed no new output. The quoted messages below are the last output scene before the system dies.
Comment 9 atom 2004-09-29 14:20:40 UTC
i spoke with one of the yellowdog developers and he said YD4 has some fixes for the new G5s that have been pushed upstream. tgall will build an iso with a newer kernel.
Comment 10 atom 2004-10-04 12:30:50 UTC
ISO tested on 30-Sep failed to boot. something new this time though final lines:

Linux ppc64

Comment 11 atom 2004-10-04 12:33:44 UTC
also tested a new kernel today that tgall prepared. (2.6.9-rc3 + a patch)

the kernel loaded and started init. some more success.

after Mounting Filesystems got about 25 segfaults. unable to find boot cd so dropped to shell. /dev is empty, /sys looks good.

no thermal support for powermac7,3 yet. read that it may be the same as 7,2 but not verified or tested by us.
Comment 12 atom 2004-10-21 17:58:57 UTC
2004.3 beta CD 1 fixes the problem with 7,3 hardware.
Comment 13 Tom Gall (RETIRED) gentoo-dev 2004-10-23 19:44:15 UTC
stick a fork in it! Thanks for testing this atom!