Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 651988 - www-client/chromium-66.0.3359.45 with media-video/ffmpeg[opencl]] Check failed: sandbox::ThreadHelpers::IsSingleThreaded()
Summary: www-client/chromium-66.0.3359.45 with media-video/ffmpeg[opencl] zygote_main_...
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Chromium Project
Depends on:
Reported: 2018-03-30 15:23 UTC by Patrick Lauer
Modified: 2018-07-13 12:38 UTC (History)
4 users (show)

See Also:
Package list:
Runtime testing required: ---


Note You need to log in before you can comment on or make changes to this bug.
Description Patrick Lauer gentoo-dev 2018-03-30 15:23:40 UTC
$ chromium
[1:1:0330/] Check failed: sandbox::ThreadHelpers::IsSingleThreaded().
#0 0x55bbcc68736c <unknown>
#1 0x55bbcc69ed7e <unknown>
#2 0x55bbcb1892a6 <unknown>
#3 0x55bbcc34fd38 <unknown>
#4 0x55bbcc350d81 <unknown>
#5 0x55bbcc35abb7 <unknown>
#6 0x55bbcc34fc84 <unknown>
#7 0x55bbca903ea5 ChromeMain
#8 0x7f1e1c0c8eec __libc_start_main
#9 0x55bbca903d5a _start

Received signal 6
#0 0x55bbcc68736c <unknown>
#1 0x55bbcc686ed1 <unknown>
#2 0x7f1e26f13ee0 <unknown>
#3 0x7f1e1c0dd940 gsignal
#4 0x7f1e1c0df476 abort
#5 0x55bbcc6856e5 <unknown>
#6 0x55bbcc69f06a <unknown>
#7 0x55bbcb1892a6 <unknown>
#8 0x55bbcc34fd38 <unknown>
#9 0x55bbcc350d81 <unknown>
#10 0x55bbcc35abb7 <unknown>
#11 0x55bbcc34fc84 <unknown>
#12 0x55bbca903ea5 ChromeMain
#13 0x7f1e1c0c8eec __libc_start_main
#14 0x55bbca903d5a _start
  r8: 0000000000000000  r9: 00007ffc4ec76bb0 r10: 0000000000000008 r11: 0000000000000246
 r12: 00007f1e1ca81cc0 r13: 00007ffc4ec77318 r14: 0000000000000073 r15: 00007ffc4ec77310
  di: 0000000000000002  si: 00007ffc4ec76bb0  bp: 00007ffc4ec76e00  bx: 0000000000000006
  dx: 0000000000000000  ax: 0000000000000000  cx: 00007f1e1c0dd940  sp: 00007ffc4ec76bb0
  ip: 00007f1e1c0dd940 efl: 0000000000000246 cgf: 002b000000000033 erf: 0000000000000000
 trp: 0000000000000000 msk: 0000000000000000 cr2: 0000000000000000
[end of stack trace]
Calling _exit(1). Core file will not be generated.
[24719:24719:0330/] Check failed: ReceiveFixedMessage(fds[0], kZygoteHelloMessage, sizeof(kZygoteHelloMessage), &real_pid).
#0 0x55abe017536c <unknown>
#1 0x55abe018cd7e <unknown>
#2 0x55abdf133dbe <unknown>
#3 0x55abded10808 <unknown>
#4 0x55abdf132ea7 <unknown>
#5 0x55abdf1ac7fd <unknown>
#6 0x55abded0b05a <unknown>
#7 0x55abded11422 <unknown>
#8 0x55abded0a6ef <unknown>
#9 0x55abdfe3ed81 <unknown>
#10 0x55abdfe48bb7 <unknown>
#11 0x55abdfe3dc84 <unknown>
#12 0x55abde3f1ea5 ChromeMain
#13 0x7f2a82be0eec __libc_start_main
#14 0x55abde3f1d5a _start

Received signal 6
#0 0x55abe017536c <unknown>
#1 0x55abe0174ed1 <unknown>
#2 0x7f2a8da2bee0 <unknown>
#3 0x7f2a82bf5940 gsignal
#4 0x7f2a82bf7476 abort
#5 0x55abe01736e5 <unknown>
#6 0x55abe018d06a <unknown>
#7 0x55abdf133dbe <unknown>
#8 0x55abded10808 <unknown>
#9 0x55abdf132ea7 <unknown>
#10 0x55abdf1ac7fd <unknown>
#11 0x55abded0b05a <unknown>
#12 0x55abded11422 <unknown>
#13 0x55abded0a6ef <unknown>
#14 0x55abdfe3ed81 <unknown>
#15 0x55abdfe48bb7 <unknown>
#16 0x55abdfe3dc84 <unknown>
#17 0x55abde3f1ea5 ChromeMain
#18 0x7f2a82be0eec __libc_start_main
#19 0x55abde3f1d5a _start
  r8: 0000000000000000  r9: 00007ffcf1f72bf0 r10: 0000000000000008 r11: 0000000000000246
 r12: 00007f2a83599cc0 r13: 00007ffcf1f733e0 r14: 00000000000000ae r15: 00007ffcf1f733d8
  di: 0000000000000002  si: 00007ffcf1f72bf0  bp: 00007ffcf1f72e40  bx: 0000000000000006
  dx: 0000000000000000  ax: 0000000000000000  cx: 00007f2a82bf5940  sp: 00007ffcf1f72bf0
  ip: 00007f2a82bf5940 efl: 0000000000000246 cgf: 002b000000000033 erf: 0000000000000000
 trp: 0000000000000000 msk: 0000000000000000 cr2: 0000000000000000
[end of stack trace]
Calling _exit(1). Core file will not be generated.
Comment 1 Patrick Lauer gentoo-dev 2018-03-30 15:24:23 UTC
Portage 2.3.27 (python 2.7.14-final-0, default/linux/amd64/17.0, gcc-7.3.0, glibc-2.26-r6, 4.15.13-gentoo x86_64)
System uname: Linux-4.15.13-gentoo-x86_64-AMD_FX-tm-8350_Eight-Core_Processor-with-gentoo-2.4.1
KiB Mem:    16439580 total,   3057668 free
KiB Swap:          0 total,         0 free
sh bash 4.4_p19
ld GNU ld (Gentoo 2.30 p1) 2.30.0
app-shells/bash:          4.4_p19::gentoo
dev-java/java-config:     2.2.0-r4::gentoo
dev-lang/perl:            5.26.1-r2::gentoo
dev-lang/python:          2.7.14-r1::gentoo, 3.5.4-r1::gentoo, 3.6.4::gentoo
dev-util/cmake:           3.10.3::gentoo
dev-util/pkgconfig:       0.29.2::gentoo
sys-apps/baselayout:      2.4.1-r2::gentoo
sys-apps/openrc:          0.35.5::gentoo
sys-apps/sandbox:         2.13::gentoo
sys-devel/autoconf:       2.13::gentoo, 2.69-r4::gentoo
sys-devel/automake:       1.15.1-r2::gentoo, 1.16.1-r1::gentoo
sys-devel/binutils:       2.30::gentoo
sys-devel/gcc:            7.3.0::gentoo
sys-devel/gcc-config:     1.9.1::gentoo
sys-devel/libtool:        2.4.6-r5::gentoo
sys-devel/make:           4.2.1-r3::gentoo
sys-kernel/linux-headers: 4.15::gentoo (virtual/os-headers)
sys-libs/glibc:           2.26-r6::gentoo

    location: /home/patrick/code/gentoo
    sync-type: rsync
    sync-uri: rsync://
    priority: -1000
    sync-rsync-verify-metamanifest: no
    sync-rsync-verify-max-age: 24

ACCEPT_KEYWORDS="amd64 ~amd64"
CFLAGS="-O2 -pipe -march=native"
CONFIG_PROTECT="/etc /usr/lib64/libreoffice/program/sofficerc /usr/share/config /usr/share/gnupg/qualified.txt"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/dconf /etc/env.d /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo"
CXXFLAGS="-O2 -pipe -march=native"
FCFLAGS="-O2 -pipe"
FEATURES="assume-digests binpkg-logs config-protect-if-modified distlocks ebuild-locks fixlafiles merge-sync multilib-strict news parallel-fetch preserve-libs protect-owned sandbox sfperms strict unknown-features-warn unmerge-logs unmerge-orphans userfetch userpriv usersandbox usersync xattr"
FFLAGS="-O2 -pipe"
INSTALL_MASK="/etc/X11/xinit/xinitrc.d/80-dbus /usr/bin/dbus-launch"
LDFLAGS="-Wl,-O1 -Wl,--as-needed"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --omit-dir-times --compress --force --whole-file --delete --stats --human-readable --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages --exclude=/.git"
USE="X acl alsa amd64 apng berkdb bzip2 cli crypt cups cxx dri ffmpeg fortran gdbm glamor gmp gpo iconv icu ipv6 lapack minizip modules multilib ncurses nls nptl opencl opengl openmp pam pcre readline seccomp sqlite ssl tcpd udev unicode vdpau xattr xvmc zlib" ABI_X86="64 32" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" APACHE2_MODULES="authn_core authz_core socache_shmcb unixd actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" CALLIGRA_FEATURES="kexi words flow plan sheets stage tables krita karbon braindump author" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" CPU_FLAGS_X86="aes avx f16c fma3 fma4 mmx mmxext popcnt sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 xop" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock isync itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf skytraq superstar2 timing tsip tripmate tnt ublox ubx" INPUT_DEVICES="libinput keyboard mouse" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LIBREOFFICE_EXTENSIONS="presenter-console presenter-minimizer" OFFICE_IMPLEMENTATION="libreoffice" PHP_TARGETS="php5-6 php7-0" POSTGRES_TARGETS="postgres9_5" PYTHON_SINGLE_TARGET="python3_5" PYTHON_TARGETS="python2_7 python3_5 python3_6" RUBY_TARGETS="ruby22" USERLAND="GNU" VIDEO_CARDS="radeon r600 radeonsi amdgpu" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"
Comment 2 Ilya Mochalov 2018-03-31 04:27:10 UTC
I had the same issue with chromium-65.0.3325.146 after upgrading to ffmpeg-3.4.2-r1. A workaround is to disable opencl use-flag for ffmpeg package.
Comment 3 Patrick Lauer gentoo-dev 2018-03-31 06:44:55 UTC
Indeed, it works with ffmpeg[-opencl]
Comment 4 Mike Gilbert gentoo-dev 2018-04-01 13:48:48 UTC
Perhaps the ffmpeg[opencl] code creates some threads on startup, and the chrome process doesn't like that?
Comment 5 Mike Gilbert gentoo-dev 2018-04-01 19:49:22 UTC
Patrick indicates that the Mesa OpenCL library is being used on his system.
Comment 6 Matthew Marchese Gentoo Infrastructure gentoo-dev 2018-04-15 00:36:50 UTC
The -opencl fix on ffmpeg worked for me too. Weird.
Comment 7 moehoeven 2018-04-19 14:55:41 UTC
This same error appeared to me two days ago on 65.0.3325.146. Upgrading to 66.0.3359.66 does not help. There's no difference in using ffmpeg-3.4.2-r1[opencl], ffmpeg-3.4.2-r1[-opencl], ffmpeg-3.4.2 or chromium[-system-ffmpeg].

Strangely, sometimes it will start fine. I currently use `while true; do chromium; done` as a very hacky workaround. Within 5-15 seconds, Chromium will usually launch.
Comment 8 Maciej S. Szmigiero 2018-04-29 22:34:48 UTC
I have also hit this bug with www-client/chromium-66.0.3359.117[system-ffmpeg],
media-libs/mesa-18.1.0_rc2 and media-video/ffmpeg-3.4.2-r1[opencl] on
"Thames [Radeon HD 7550M/7570M/7650M]".

It seems that chromium loading ffmpeg libraries causes them to load 
the OpenCL Mesa provider, which in turns creates a "radeon_cs:0" thread.

Recompiling media-video/ffmpeg without opencl USE flag works around
this issue and allows chromium to start successfully.
Comment 9 moehoeven 2018-05-06 18:06:55 UTC
Downgrading to =x11-drivers/nvidia-drivers-387.34 (I had =x11-drivers/nvidia-drivers-396.18-r1 before) completely removes the problem for me. I think, some new version of the nvidia-drivers causes this problem, as it also causes Metro Last Light to be unable to start. Not sure which version exactly introduced this, though. I skipped some versions.
Comment 10 Maciej S. Szmigiero 2018-05-06 20:14:00 UTC
In my case this has happened on AMD graphic card with Mesa
so it can't be related only to x11-drivers/nvidia-drivers.

Comment 5 also suggests that the original reporter hit this
on a Mesa OpenCL implementation.
Comment 11 muffindrake 2018-05-08 01:52:08 UTC
The suggested workaround of ffmpeg[-opencl], either system or bundled ffmpeg with edited ebuild, doesn't work for me (nvidia user).

I use nvidia-drivers-396.24, but I this issue occurred with driver versions at the time of the first incidence of this bug.

Through sheer luck I managed to find a workaround that lets me launch chromium 100% of the time, rather than the 

$ while true; do chromium >/dev/null 2>&1: done

which unlike some earlier reporters, manages to launch chromium for me only after several minutes, sometimes even an hour or more, all while stressing disk and CPU, since IsSingleThreaded is subject to a data race that needs luck to exploit.


I wouldn't suggest setting that to 0 globally, as that will affect performance of other programs, but lets you use chromium until this bug is resolved.