Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 651952 - sys-apps/portage-2.3.26: use current INSTALL_MASK configuration for binary packages
Summary: sys-apps/portage-2.3.26: use current INSTALL_MASK configuration for binary pa...
Status: RESOLVED FIXED
Alias: None
Product: Portage Development
Classification: Unclassified
Component: .tbz2 support (show other bugs)
Hardware: All All
: Normal normal (vote)
Assignee: Portage team
URL:
Whiteboard:
Keywords: InVCS, REGRESSION
Depends on:
Blocks: 651804
  Show dependency tree
 
Reported: 2018-03-29 21:26 UTC by Zac Medico
Modified: 2018-03-30 04:30 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Zac Medico gentoo-dev 2018-03-29 21:26:31 UTC
Since changes for bug 651214, the INSTALL_MASK configuration is frozen a build time, so any changes since then are ignored.
Comment 2 Larry the Git Cow gentoo-dev 2018-03-30 02:27:50 UTC
The bug has been referenced in the following commit(s):

https://gitweb.gentoo.org/proj/portage.git/commit/?id=cc0349c549b3024615fb8fb5c72c78b9509ee5bb

commit cc0349c549b3024615fb8fb5c72c78b9509ee5bb
Author:     Zac Medico <zmedico@gentoo.org>
AuthorDate: 2018-03-29 21:51:13 +0000
Commit:     Zac Medico <zmedico@gentoo.org>
CommitDate: 2018-03-29 22:33:42 +0000

    INSTALL_MASK: honor install time config for binary packages (bug 651952)
    
    For binary packages, honor the INSTALL_MASK configuration that
    exists at install time, since it might differ from the build time
    setting.
    
    Fixes: 3416876c0ee7 ("{,PKG_}INSTALL_MASK: python implementation")
    Bug: https://bugs.gentoo.org/651952

 bin/misc-functions.sh        | 23 +++++++++++++++++++++++
 bin/phase-functions.sh       | 10 +---------
 pym/portage/dbapi/vartree.py |  5 +++++
 3 files changed, 29 insertions(+), 9 deletions(-)}
Comment 3 Larry the Git Cow gentoo-dev 2018-03-30 04:30:13 UTC
The bug has been closed via the following commit(s):

https://gitweb.gentoo.org/repo/gentoo.git/commit/?id=cbe07d8ee1d2b5d3334706f6e9352a4d2bfd9297

commit cbe07d8ee1d2b5d3334706f6e9352a4d2bfd9297
Author:     Zac Medico <zmedico@gentoo.org>
AuthorDate: 2018-03-30 04:04:26 +0000
Commit:     Zac Medico <zmedico@gentoo.org>
CommitDate: 2018-03-30 04:30:05 +0000

    sys-apps/portage: version bump to 2.3.27
    
      #651952 - INSTALL_MASK: honor install time config for binary packages
    
    Closes: https://bugs.gentoo.org/651952
    Package-Manager: Portage-2.3.27_p1, Repoman-2.3.8

 sys-apps/portage/Manifest              |   1 +
 sys-apps/portage/portage-2.3.27.ebuild | 284 +++++++++++++++++++++++++++++++++
 2 files changed, 285 insertions(+)