Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 65179 - mol gives a warning (force_sig undefined) and the mol.ko modules does not load under 2.6.9
Summary: mol gives a warning (force_sig undefined) and the mol.ko modules does not loa...
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: New packages (show other bugs)
Hardware: PPC Linux
: High normal (vote)
Assignee: PPC Porters
Depends on:
Reported: 2004-09-24 02:41 UTC by Santiago Gala
Modified: 2005-01-09 01:43 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Note You need to log in before you can comment on or make changes to this bug.
Description Santiago Gala 2004-09-24 02:41:36 UTC
Since 2.6.9-rcXXX mol gives an error related to force_sig undefined and fails to load the module, and thus to run

Reproducible: Always
Steps to Reproduce:
1. rebuild mol (needed because of module incompatibility

Actual Results:  
mol refuses to load

Expected Results:  
built the module and load
Comment 1 Luca Barbato gentoo-dev 2004-09-24 12:50:03 UTC
I'm currently testing the 2.6.8.x kernels, once I can unmask them to ppc I'll move to the 2.6.9 serie.
Thanks for the notice, I'll try in the weekend to address the problem.
Comment 2 Joe Jezak (RETIRED) gentoo-dev 2004-10-18 04:33:35 UTC
I can't replicate this with 2.6.9-rc4, maybe it's kernel header related.  Which kernel headers are you using?  Or maybe it's been fixed in 2.6.9-rc4, does this still happen?
Comment 3 Santiago Gala 2004-10-18 11:46:41 UTC
with 2.6.8 it works well now (for me at least).

with 2.6.9-rc4 it built the mol.ko module but gave errors with tun.ko (I don't think it is currently needed one different from the kernel one) and sheep.ko. I could not save the errors, but it looked like code incompatibility. No problem for me, I don't use sheep, and tun from the system worked right.

with 2.6.9_rc4-mm1 I have not tried. This release seems to work reasonably with my machine, except if froze when I closed the lid. Some work missing with the mm patches, I think. I can't debug a deep freeze like this one.
Comment 4 Lars Weiler (RETIRED) gentoo-dev 2004-10-31 19:40:39 UTC
I have no problems with mol and 2.6.9.  But I'm using linux26-headers-
Comment 5 Joe Jezak (RETIRED) gentoo-dev 2004-11-26 05:20:04 UTC
I can't replicate this.  If it's still a problem, please reopen the bug with more information on the kernel headers that you've used.  Thanks!
Comment 6 Lars Weiler (RETIRED) gentoo-dev 2005-01-09 01:43:45 UTC
Just closing.