Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 651702 - app-office/libreoffice with =dev-libs/icu-61.1: unicode.cxx:753:21: error: ‘NumberFormat’ was not declared in this scope
Summary: app-office/libreoffice with =dev-libs/icu-61.1: unicode.cxx:753:21: error: ‘N...
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal with 1 vote (vote)
Assignee: Gentoo Office Team
URL:
Whiteboard: fixed in 6.1
Keywords:
: 653890 656366 (view as bug list)
Depends on:
Blocks: icu-61
  Show dependency tree
 
Reported: 2018-03-27 12:51 UTC by Lars Wendler (Polynomial-C)
Modified: 2018-07-12 06:50 UTC (History)
4 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
build.log (build.log,824.86 KB, text/plain)
2018-03-27 12:51 UTC, Lars Wendler (Polynomial-C)
Details
libreoffice-6.0.3.2-icu-61-compatibility.patch (file_651702.txt,4.58 KB, patch)
2018-05-16 13:10 UTC, Quentin Minster
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Lars Wendler (Polynomial-C) gentoo-dev 2018-03-27 12:51:55 UTC
Created attachment 525664 [details]
build.log

[build CXX] i18nutil/source/utility/unicode.cxx
S=/var/tmp/portage/app-office/libreoffice-6.0.2.1/work/libreoffice-6.0.2.1 && I=$S/instdir && W=$S/workdir &&  mkdir -p $W/CxxObject/i18nutil/source/utility/ $W/Dep/CxxObject/i18nutil/source/utility/ && cd /var/tmp/portage/app-office/lib
reoffice-6.0.2.1/work/libreoffice-6.0.2.1 &&    x86_64-pc-linux-gnu-g++ -DBOOST_ERROR_CODE_HEADER_ONLY -DBOOST_SYSTEM_NO_DEPRECATED -DCPPU_ENV=gcc3 -DLINUX -DNDEBUG -DOSL_DEBUG_LEVEL=0 -DUNIX -DUNX -DX86_64 -D_PTHREADS -D_REENTRANT   -DI
18NUTIL_DLLIMPLEMENTATION   -fvisibility=hidden    -Wall -Wno-missing-braces -Wnon-virtual-dtor -Wendif-labels -Wextra -Wundef -Wunreachable-code -Wunused-macros -finput-charset=UTF-8 -fmessage-length=0 -fno-common -pipe  -Wduplicated-co
nd -Wlogical-op -Wshift-overflow=2 -Wunused-const-variable=1 -fvisibility-inlines-hidden -fstack-protector-strong -fPIC -Wshadow -Woverloaded-virtual -std=gnu++14   -DEXCEPTIONS_ON -fexceptions -fno-enforce-eh-specs -march=native -mtune=
native -O2 -pipe   -DLIBO_INTERNAL_ONLY  -c $S/i18nutil/source/utility/unicode.cxx -o $W/CxxObject/i18nutil/source/utility/unicode.o  -I$S/include  -I/usr/lib64/icedtea8/include -I/usr/lib64/icedtea8/include/linux -I$S/config_host  -I/us
r/include  -I$W/CustomTarget/officecfg/registry -I$W/UnoApiHeadersTarget/udkapi/normal -I$W/Uno
ApiHeadersTarget/offapi/normal   
/var/tmp/portage/app-office/libreoffice-6.0.2.1/work/libreoffice-6.0.2.1/i18nutil/source/utility/unicode.cxx: In static member function ‘static rtl::OUString unicode::formatPercent(double, const LanguageTag&)’:
/var/tmp/portage/app-office/libreoffice-6.0.2.1/work/libreoffice-6.0.2.1/i18nutil/source/utility/unicode.cxx:753:21: error: ‘NumberFormat’ was not declared in this scope
     std::unique_ptr<NumberFormat> xF(
                     ^~~~~~~~~~~~
/var/tmp/portage/app-office/libreoffice-6.0.2.1/work/libreoffice-6.0.2.1/i18nutil/source/utility/unicode.cxx:753:21: note: suggested alternative:
In file included from /var/tmp/portage/app-office/libreoffice-6.0.2.1/work/libreoffice-6.0.2.1/i18nutil/source/utility/unicode.cxx:27:0:
/usr/include/unicode/numfmt.h:174:18: note:   ‘icu::NumberFormat’
 class U_I18N_API NumberFormat : public Format {
                  ^~~~~~~~~~~~
/var/tmp/portage/app-office/libreoffice-6.0.2.1/work/libreoffice-6.0.2.1/i18nutil/source/utility/unicode.cxx:753:33: error: template argument 1 is invalid
     std::unique_ptr<NumberFormat> xF(
                                 ^
/var/tmp/portage/app-office/libreoffice-6.0.2.1/work/libreoffice-6.0.2.1/i18nutil/source/utility/unicode.cxx:753:33: error: template argument 2 is invalid
/var/tmp/portage/app-office/libreoffice-6.0.2.1/work/libreoffice-6.0.2.1/i18nutil/source/utility/unicode.cxx:754:9: error: ‘NumberFormat’ is not a class, namespace, or enumeration
         NumberFormat::createPercentInstance(aLocale, errorCode));
         ^~~~~~~~~~~~
/var/tmp/portage/app-office/libreoffice-6.0.2.1/work/libreoffice-6.0.2.1/i18nutil/source/utility/unicode.cxx:761:5: error: ‘UnicodeString’ was not declared in this scope
     UnicodeString output;
     ^~~~~~~~~~~~~
/var/tmp/portage/app-office/libreoffice-6.0.2.1/work/libreoffice-6.0.2.1/i18nutil/source/utility/unicode.cxx:761:5: note: suggested alternative:
In file included from /usr/include/unicode/numfmt.h:36:0,
                 from /var/tmp/portage/app-office/libreoffice-6.0.2.1/work/libreoffice-6.0.2.1/i18nutil/source/utility/unicode.cxx:27:
/usr/include/unicode/unistr.h:286:20: note:   ‘icu::UnicodeString’
 class U_COMMON_API UnicodeString : public Replaceable
                    ^~~~~~~~~~~~~
/var/tmp/portage/app-office/libreoffice-6.0.2.1/work/libreoffice-6.0.2.1/i18nutil/source/utility/unicode.cxx:762:7: error: base operand of ‘->’ is not a pointer
     xF->format(dNumber/100, output);
       ^~
/var/tmp/portage/app-office/libreoffice-6.0.2.1/work/libreoffice-6.0.2.1/i18nutil/source/utility/unicode.cxx:762:29: error: ‘output’ was not declared in this scope
     xF->format(dNumber/100, output);
                             ^~~~~~
/var/tmp/portage/app-office/libreoffice-6.0.2.1/work/libreoffice-6.0.2.1/i18nutil/source/utility/unicode.cxx:762:29: note: suggested alternative: ‘getpt’
     xF->format(dNumber/100, output);
                             ^~~~~~
                             getpt
make[1]: *** [/var/tmp/portage/app-office/libreoffice-6.0.2.1/work/libreoffice-6.0.2.1/solenv/gbuild/LinkTarget.mk:293: /var/tmp/portage/app-office/libreoffice-6.0.2.1/work/libreoffice-6.0.2.1/workdir/CxxObject/i18nutil/source/utility/unicode.o] Error 1
make[1]: Leaving directory '/var/tmp/portage/app-office/libreoffice-6.0.2.1/work/libreoffice-6.0.2.1'
make: *** [Makefile:268: build] Error 2
Comment 1 Lars Wendler (Polynomial-C) gentoo-dev 2018-04-23 13:36:02 UTC
*** Bug 653890 has been marked as a duplicate of this bug. ***
Comment 2 Quentin Minster 2018-05-16 13:10:18 UTC
Created attachment 531692 [details, diff]
libreoffice-6.0.3.2-icu-61-compatibility.patch

Attached is a quick-n-dirty patch to make =app-office/libreoffice-6.0.3.2 build against =dev-libs/icu-61.1.

I haven't tested that the patch works neither for <app-office/libreoffice-6.0.3.2 nor for <dev-libs/icu-61.
Comment 3 Arfrever Frehtes Taifersar Arahesis 2018-05-26 05:18:19 UTC
*** Bug 656366 has been marked as a duplicate of this bug. ***
Comment 4 Jaren Stangret 2018-05-27 04:11:09 UTC
(In reply to Quentin Minster from comment #2)
> Created attachment 531692 [details, diff] [details, diff]
> libreoffice-6.0.3.2-icu-61-compatibility.patch
> 
> Attached is a quick-n-dirty patch to make =app-office/libreoffice-6.0.3.2
> build against =dev-libs/icu-61.1.
> 
> I haven't tested that the patch works neither for
> <app-office/libreoffice-6.0.3.2 nor for <dev-libs/icu-61.

Confirming this patch works for:
=app-office/libreoffice-6.0.4.2
and
=dev-libs/icu-61.1
Comment 5 tonemgub 2018-07-07 18:03:54 UTC
Confirming, patch also works in app-office/libreoffice-6.0.5.2 and dev-libs/icu-61.1
Comment 6 Larry the Git Cow gentoo-dev 2018-07-12 06:50:24 UTC
The bug has been closed via the following commit(s):

https://gitweb.gentoo.org/repo/gentoo.git/commit/?id=b6867e7d160cda9b0537d2006c385c6ec011457b

commit b6867e7d160cda9b0537d2006c385c6ec011457b
Author:     Andreas Sturmlechner <asturm@gentoo.org>
AuthorDate: 2018-07-11 21:31:39 +0000
Commit:     Andreas Sturmlechner <asturm@gentoo.org>
CommitDate: 2018-07-12 06:50:06 +0000

    app-office/libreoffice: Add upstream fix for ICU 61
    
    Closes: https://bugs.gentoo.org/651702
    Package-Manager: Portage-2.3.42, Repoman-2.3.9

 app-office/libreoffice/Manifest                   | 1 +
 app-office/libreoffice/libreoffice-6.0.5.2.ebuild | 2 +-
 2 files changed, 2 insertions(+), 1 deletion(-)