Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 65147 - emerge of lyx1.3.4 failed with "Access violation" from sandbox
Summary: emerge of lyx1.3.4 failed with "Access violation" from sandbox
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: x86 Linux
: Normal normal (vote)
Assignee: Text-Markup Team (OBSOLETE)
Depends on:
Reported: 2004-09-23 15:22 UTC by anonymus
Modified: 2004-11-15 20:05 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Note You need to log in before you can comment on or make changes to this bug.
Description anonymus 2004-09-23 15:22:06 UTC
i tried to emerge lyx and it stop with an error, see below.
In the meantime I could workaround by deactivating sandbox, but that's no prefereable way.

Reproducible: Always
Steps to Reproduce:
1.emerge lyx
Actual Results:  
after compiling some files (takes some time, i don't remember how long)
emerge stops with the following message:
--------------------------- ACCESS VIOLATION SUMMARY ---------------------------
LOG FILE = "/tmp/sandbox-app-office_-_lyx-1.3.4-27090.log"

unlink:    /usr/share/texmf/web2c/latex.log
rename:    /usr/share/texmf/web2c/latex.log

Portage 2.0.50-r11 (default-x86-2004.2, gcc-3.3.4, glibc-,
System uname: 2.6.7-gentoo-r12 i686 AMD Athlon(tm) XP 1700+
Gentoo Base System version 1.4.16
Autoconf: sys-devel/autoconf-2.59-r4
Automake: sys-devel/automake-1.8.5-r1
CFLAGS="-O3 -march=athlon-xp -fomit-frame-pointer -pipe"
CONFIG_PROTECT="/etc /usr/X11R6/lib/X11/xkb /usr/kde/2/share/config
/usr/kde/3.3/env /usr/kde/3.3/share/config /usr/kde/3.3/shutdown
/usr/kde/3/share/config /usr/lib/mozilla/defaults/pref /usr/share/config
/usr/share/texmf/dvipdfm/config/ /usr/share/texmf/dvips/config/
/usr/share/texmf/tex/generic/config/ /usr/share/texmf/tex/platex/config/
/usr/share/texmf/xdvi/ /var/qmail/control"
CONFIG_PROTECT_MASK="/etc/gconf /etc/terminfo /etc/env.d"
CXXFLAGS="-O3 -march=athlon-xp -fomit-frame-pointer -pipe"
FEATURES="autoaddcvs ccache sandbox"
USE="3dnow X Xaw3d acpi alsa apm avi berkdb bitmap-fonts canna crypt cups doc
dvd foomaticdb freewnn gdbm gif gnome gpm gtk2 hardened imlib ipv6 java joystick
jpeg junit ldap libg++ libwww mad mikmod mozilla mpeg ncurses nls oggvorbis
opengl oss pdflib perl png python quicktime readline sdl slang spell sse ssl
svga tcpd tetex truetype unicode x86 xml2 xmms xprint xv zlib"
Comment 1 Mamoru KOMACHI (RETIRED) gentoo-dev 2004-10-13 02:47:05 UTC
Please attach full emerge log here. Also, does lyx-1.3.5.ebuild fail with the same error?
Comment 2 Karl Ernst Brunk 2004-11-02 13:21:59 UTC
hy !
remember #54221 and #42478 an maybe others.
If my tip in #54479 does make sense, we should try to solve all errors with -j1.
A. Maybe it was not a real solution,
B. maybe all compile-runs who fail when using -j2 at different points are caused by parallel building no matter at which point they fail.
Is there anyone who did get lyx-1.3.4 compiled without errors when -j2 was used ?
On real SMP-machines, HT, or just of fun?
Comment 3 Mamoru KOMACHI (RETIRED) gentoo-dev 2004-11-14 21:40:22 UTC
It does build on my x86 and ppc machines with -j4, 
though they are not SMP or HT machines. If lyx
tries to modify /usr/share/texmf/web2c/latex.log
it is likely that you have something wrong in tetex
installation, and we need full compile log to determine
what's wrong on your system.
Comment 4 anonymus 2004-11-15 15:34:24 UTC
First, sorry for not keeping track of this thread so long. I couldn't reproduce the error because I completly reinstalled my system, but had other errors instead in lyx dependencies (t1lib, chktex). Now i have solved them by simply preventing portage from installing these "dependencies", and lyx(1.3.4) installs without problems now. So your propably right, with the presumption it could be a failure in the tetex installation.

It would help to put a hint at the "enter a bug"-page, also to test with the ~x86=testversions before submitting a bug, and to submit the complete compileroutput as attachment, and not only the error messages. I'm sure a lot of persons forget this, like me.
Another problem is that normaly only a little part of the output fits in the terminalbuffer. So if you haven't redirected the output before, you need to restart compilation process to get the hole output. This can be annoying if it tooks an hour... Is there any standartfile the output is saved to while being writen to the standartoutput?

@Karl Ernst
I already tested to compile lyx with -j 1 (before I changed my system) but it didn't helped.
The option -j n is an internal option for gcc to split into multiple threads an (possibly) run faster, perhaps using more memory. Its other behaviour mustn't change. So if some packages only compile with -j 1, it's shurely an issue to gcc or your system configuration, not to these packages.
By the way I use -j 2 on a single processor system and never experienced problems with it. For optimal speed you should use one thread more than you have cpus.
Comment 5 Mamoru KOMACHI (RETIRED) gentoo-dev 2004-11-15 20:05:17 UTC
No worries, that's okay. In this case, if you had
set PORT_LOGDIR in /etc/make.conf (sample
configuration is in /etc/make.conf, so all you
have to do is comment out PORT_LOGDIR line)
you would have compilation log automagically.