Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 65048 - eroaster-2.2.0_pre6 crashed
Summary: eroaster-2.2.0_pre6 crashed
Status: VERIFIED TEST-REQUEST
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: x86 Linux
: High critical (vote)
Assignee: optical media herd
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2004-09-23 01:19 UTC by Antonio
Modified: 2005-04-25 12:31 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Antonio 2004-09-23 01:19:53 UTC
I have burn many cd with this program but now i does not burn anything.

This is error:

Traceback (most recent call last):
  File "/usr/lib/eroaster/Application.py", line 756, in BurnWriterOptions
    self.BurnCDNow()
  File "/usr/lib/eroaster/Application.py", line 825, in BurnCDNow
    cdrecord = cdrtools.cdrecord(channel, id, lun, self.devWriter.get_text(), self.cat.get_loglevel())
  File "/usr/lib/eroaster/cdrtools.py", line 114, in __init__
    self.__cdrecord_read_version()
  File "/usr/lib/eroaster/cdrtools.py", line 239, in __cdrecord_read_version
    for i in range(len(version[1])):
IndexError: list index out of range

my iso file to burn is linux yoper-2.1.0

Reproducible: Always
Steps to Reproduce:
1.
2.
3.
Comment 1 Yogesh 2004-10-10 23:52:43 UTC
cdrtools.py

after thanging 
versionLine = output[0]
to
versionLine = output[3]

it started working.
Comment 2 Lars Weiler (RETIRED) gentoo-dev 2004-10-30 21:20:18 UTC
Sounds like python has been updated, but not eroaster.  Try to reemerge eroaster or update to eroaster-2.2.0_pre8.
Comment 3 Lars Weiler (RETIRED) gentoo-dev 2004-12-02 20:05:38 UTC
Anything tested?
Comment 4 Yogesh 2004-12-27 20:51:48 UTC
Sorry I was out of country for some and than got busy in office work.

I tried app-cdr/eroaster-2.2.0_pre8 but same error

I tried app-cdr/cdrtools-2.01.01_alpha01

It looks to me the cdrecord version string is changed.

Again sorry for delay in reply.
Comment 5 Yogesh 2005-01-01 19:01:08 UTC
Change line 233 to following:
output = cmdoutput("%s -version 2>/dev/null" % self.__cdrecord_command, strip = TRUE)

Fixes eroaster bug.
Comment 6 Lars Weiler (RETIRED) gentoo-dev 2005-04-05 05:02:43 UTC
I added a newer version of eroaster into portage.  This should resolve this bug.  Please test!
Comment 7 Lars Weiler (RETIRED) gentoo-dev 2005-04-25 12:31:48 UTC
Just closing the bug.