Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 650408 - dev-python/blosc-1.5.1 : [TEST] ImportError: No module named numpy
Summary: dev-python/blosc-1.5.1 : [TEST] ImportError: No module named numpy
Status: CONFIRMED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Gentoo Science Related Packages
URL:
Whiteboard:
Keywords: TESTFAILURE
Depends on:
Blocks:
 
Reported: 2018-03-13 17:26 UTC by Toralf Förster
Modified: 2018-03-13 17:26 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments
emerge-info.txt (emerge-info.txt,16.95 KB, text/plain)
2018-03-13 17:26 UTC, Toralf Förster
Details
dev-python:blosc-1.5.1:20180313-020354.log (dev-python:blosc-1.5.1:20180313-020354.log,9.49 KB, text/plain)
2018-03-13 17:26 UTC, Toralf Förster
Details
emerge-history.txt (emerge-history.txt,258.85 KB, text/plain)
2018-03-13 17:26 UTC, Toralf Förster
Details
environment (environment,105.40 KB, text/plain)
2018-03-13 17:26 UTC, Toralf Förster
Details
etc.portage.tbz2 (etc.portage.tbz2,15.48 KB, application/x-bzip)
2018-03-13 17:26 UTC, Toralf Förster
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Toralf Förster gentoo-dev 2018-03-13 17:26:04 UTC
  File "/var/tmp/portage/dev-python/blosc-1.5.1/work/blosc-1.5.1-python3_5/lib/blosc/test.py", line 71, in test_compress_input_types
    import numpy as np
ImportError: No module named 'numpy'

======================================================================
ERROR: test_decompress_input_types (blosc.test.TestCodec)

  -------------------------------------------------------------------

  This is an unstable amd64 chroot image at a tinderbox (==build bot)
  name: 17.0-systemd_libressl-test_20180304-100829

  -------------------------------------------------------------------

gcc-config -l:
 [1] x86_64-pc-linux-gnu-7.3.0 *

Available Python interpreters, in order of preference:
  [1]   python3.5
  [2]   python2.7 (fallback)

java-config:
The following VMs are available for generation-2:
*)	IcedTea JDK 3.7.0 [icedtea-bin-8]
Available Java Virtual Machines:
  [1]   icedtea-bin-8  system-vm

emerge -qpv dev-python/blosc
[ebuild  N    ] dev-python/blosc-1.5.1  USE="{test}" PYTHON_TARGETS="python2_7 python3_5 -python3_4 -python3_6" 

!!! The following installed packages are masked:
- x11-base/xorg-server-1.19.99.901-r1::gentoo (masked by: package.mask)
/usr/portage/profiles/package.mask:
# Sebastian Pipping <sping@gentoo.org> (11 Mar 2018)
# Breaks XFCE, 1.19.6 was fine (in that regard). Bug #650228

- app-i18n/libguess-1.2::gentoo (masked by: package.mask)
/usr/portage/profiles/package.mask:
# Andreas Sturmlechner <asturm@gentoo.org> (11 Mar 2018)
# Dead upstream, no revdeps left. Bug #639358

For more information, see the MASKED PACKAGES section in the emerge
man page or refer to the Gentoo Handbook.
Comment 1 Toralf Förster gentoo-dev 2018-03-13 17:26:07 UTC
Created attachment 523742 [details]
emerge-info.txt
Comment 2 Toralf Förster gentoo-dev 2018-03-13 17:26:10 UTC
Created attachment 523744 [details]
dev-python:blosc-1.5.1:20180313-020354.log
Comment 3 Toralf Förster gentoo-dev 2018-03-13 17:26:13 UTC
Created attachment 523746 [details]
emerge-history.txt
Comment 4 Toralf Förster gentoo-dev 2018-03-13 17:26:16 UTC
Created attachment 523748 [details]
environment
Comment 5 Toralf Förster gentoo-dev 2018-03-13 17:26:19 UTC
Created attachment 523750 [details]
etc.portage.tbz2