Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 649736 - x11-base/xorg-server- - GPU lockup with radeon RV710
Summary: x11-base/xorg-server- - GPU lockup with radeon RV710
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: AMD64 Linux
: Normal normal (vote)
Assignee: Gentoo X packagers
Depends on:
Reported: 2018-03-06 12:18 UTC by Daniel
Modified: 2018-06-08 13:06 UTC (History)
3 users (show)

See Also:
Package list:
Runtime testing required: ---

emerge --info (,5.85 KB, application/x-info)
2018-03-06 12:18 UTC, Daniel
/var/log/messages (messages,3.20 KB, text/plain)
2018-03-06 12:19 UTC, Daniel

Note You need to log in before you can comment on or make changes to this bug.
Description Daniel 2018-03-06 12:18:36 UTC
Created attachment 522506 [details]
emerge --info

After several GPU lockups, KDE Plasma starts, but without compositor. The framebuffer consoles aren't usable anymore after X started.

Downgrading to x11-base/xorg-server-1.19.5-r1 solves this.
Comment 1 Daniel 2018-03-06 12:19:40 UTC
Created attachment 522508 [details]
Comment 2 Matt Turner gentoo-dev 2018-03-06 19:19:25 UTC
I've just added xf86-video-ati-18.0.0 to the tree. Please give that a try. If it does not resolve the problem, please file a bug upstream at and link us to it here.
Comment 3 Daniel 2018-03-07 14:00:20 UTC
xf86-video-ati-18.0.0 did not solve the problem. No lockup anymore, but still no drm and framebuffers dead.

Filed a bug upstream:
Comment 4 Matt Turner gentoo-dev 2018-04-15 23:45:53 UTC
Please try version
Comment 5 Matt Turner gentoo-dev 2018-05-10 18:12:15 UTC
Please try 1.20.0. I'm going to have to unmask this version at some point...
Comment 6 Matt Turner gentoo-dev 2018-06-08 05:07:35 UTC
Reporter disappeared.
Comment 7 Daniel 2018-06-08 13:06:44 UTC
Sorry to disappear.

With xorg-server-1.20.0 it works now, DRI, framebuffers, all ok.