Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 649714 - x11-misc/synergy with >=dev-libs/openssl-1.1.0 - src/lib/net/SecureSocket.cpp:366:5: error: ‘SSL_library_init’ was not declared in this scope
Summary: x11-misc/synergy with >=dev-libs/openssl-1.1.0 - src/lib/net/SecureSocket.cpp...
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Desktop Misc. Team
URL:
Whiteboard:
Keywords: PATCH
Depends on:
Blocks: openssl-1.1_disable-deprecated
  Show dependency tree
 
Reported: 2018-03-06 06:44 UTC by Quentin Minster
Modified: 2019-04-28 18:29 UTC (History)
2 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
build.log (file_649714.txt,77.67 KB, text/plain)
2018-03-06 06:44 UTC, Quentin Minster
Details
synergy-2.0.0-openssl-1.1.0-compat.patch (synergy-2.0.0-openssl-1.1.0-compat.patch,2.45 KB, patch)
2018-03-06 06:47 UTC, Quentin Minster
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Quentin Minster 2018-03-06 06:44:38 UTC
Created attachment 522488 [details]
build.log

x11-misc/synergy fails to build with >=dev-libs/openssl-1.1.0. This is due to API changes (deprecated/removed functions) in OpenSSL 1.1.0.
Comment 1 Quentin Minster 2018-03-06 06:47:54 UTC
Created attachment 522490 [details, diff]
synergy-2.0.0-openssl-1.1.0-compat.patch

This patch should restore compatibility with OpenSSL 1.1.0.
I have not sent it upstream as they removed TLS support a few months ago: [0].

[0]: https://github.com/symless/synergy-core/issues/6224
Comment 2 Lars Wendler (Polynomial-C) gentoo-dev 2018-10-24 15:52:42 UTC
Since we decided to no longer build openssl without deprecated features, this
bug can now be considered as fixed (but will eventually reappear once openssl
upstream finally removed deprecated features from their code).