Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 649194 - package.mask >=sys-libs/db-6.1 because of test failure, but only because wrong tcl version?
Summary: package.mask >=sys-libs/db-6.1 because of test failure, but only because wron...
Status: UNCONFIRMED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Gentoo's Team for Core System packages
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2018-03-01 14:22 UTC by Ulenrich
Modified: 2018-06-22 08:58 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Ulenrich 2018-03-01 14:22:39 UTC
I am wondering why the package.mask sys-libs/db-6.2*
is so old from 2014. I noticed the Url of oracle says:
http://download.oracle.com/otndocs/products/berkeleydb/html/changelog_6_2.html
The test suite now requires Tcl 8.6 or greater
---
but our ebuild only requests:
DEPEND="tcl? ( >=dev-lang/tcl-8.5.15-r1:0=[${MULTILIB_USEDEP}] )
        test? ( >=dev-lang/tcl-8.5.15-r1:0=[${MULTILIB_USEDEP}] )
---
Also I see the files/db-6.0.20-test-link.patch may be too old ?
Comment 1 Lars Wendler (Polynomial-C) gentoo-dev 2018-03-01 14:38:54 UTC
AFAIK it's not only because of failing tests but also because Oracle moved the license of >=db-6.1 from Sleepycat to AGPL-3 which makes it incompatible with lots of other software.
Perhaps we should reflect that in the mask reason as well.
Comment 2 Ulenrich 2018-03-01 17:48:37 UTC
@Lars, I would rather like to have an additional  
USE agpl_accept
as a license warning
than an obscured package.mask for 
>sys-libs/db-6.1
Comment 3 Robin Johnson archtester Gentoo Infrastructure gentoo-dev Security 2018-03-01 18:45:06 UTC
No, it's ONLY masked for failing tests. It is not masked because of AGPL.
I will update the Tcl dep, but it does still fail here with Tcl-8.6.5.
Comment 4 Ulenrich 2018-03-02 20:45:52 UTC
@Robin thanx for explanation. 
And I just reported, because both: it is an old mask and this test dependency did not fit. Feel free to close the bug then.
Comment 5 Robin Johnson archtester Gentoo Infrastructure gentoo-dev Security 2018-03-02 21:35:03 UTC
I re-ran the tests w/ a newer system, and got only 2 failures now:
UNEXPECTED OUTPUT: FAIL: condition {[stat_field $env rep_stat "Startup complete"]} not achieved in 20 seconds.
UNEXPECTED OUTPUT: BDB0068 DB_LOCK_DEADLOCK: Locker killed to resolve a deadlock

took ~3 hours on an unloaded i7 X980 system on SSD.

Running it again for good measure.
Comment 6 Robin Johnson archtester Gentoo Infrastructure gentoo-dev Security 2018-03-05 19:33:29 UTC
Next run (again, -j12, 3 hour duration:
UNEXPECTED OUTPUT: db put:permission denied

So i'm wondering if the real bug is around concurrency.

Running again @ -j1:
UNEXPECTED OUTPUT: db put:permission denied