Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 648696 - dev-python/pycurl-7.43.0 with dev-libs/openssl-1.1.0g-r2 - src/threadsupport.c:96:16: error: ?CRYPTO_LOCK? undeclared (first use in this function); did you mean ?CRYPTO_RWLOCK??
Summary: dev-python/pycurl-7.43.0 with dev-libs/openssl-1.1.0g-r2 - src/threadsupport....
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Python Gentoo Team
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: openssl-1.1 openssl-1.1_disable-deprecated
  Show dependency tree
 
Reported: 2018-02-24 12:51 UTC by bug2017
Modified: 2018-10-24 16:27 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments
emerge output (build.log,15.82 KB, text/plain)
2018-02-24 12:51 UTC, bug2017
Details

Note You need to log in before you can comment on or make changes to this bug.
Description bug2017 2018-02-24 12:51:20 UTC
Created attachment 520880 [details]
emerge output

dev-python/pycurl is indirectly pulled in by kde-apps/print-manager[gtk]

src/threadsupport.c: In function ‘pycurl_ssl_lock’:
src/threadsupport.c:96:16: error: ‘CRYPTO_LOCK’ undeclared (first use in this function); did you mean ‘CRYPTO_RWLOCK’?
Comment 1 bug2017 2018-03-21 13:24:50 UTC
After updating to dev-libs/openssl-1.1.0g-r3 dev-python/pycurl-7.43.0::gentoo insatlls fine. Ther is one QA warning left:

 * QA Notice: Package triggers severe warnings which indicate that it
 *            may exhibit random runtime failures.
 * src/threadsupport.c:133:5: warning: implicit declaration of function ‘CRYPTO_set_id_callback’; did you mean ‘CRYPTO_set_locking_callback’? [-Wimplicit-function-declaration]

If that is not caused by a gentoo specific patch, this bug might be resolved.
Comment 2 Lars Wendler (Polynomial-C) gentoo-dev 2018-10-24 15:37:15 UTC
Since we decided to no longer build openssl without deprecated features, this
bug can now be considered as fixed (but will eventually reappear once openssl
upstream finally removed deprecated features from their code).