Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 648648 - www-client/elinks-0.12_pre6-r1:0/0 blocks guile from updating to dev-scheme/guile-2.0.14-r3:12/22
Summary: www-client/elinks-0.12_pre6-r1:0/0 blocks guile from updating to dev-scheme/g...
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: AMD64 Linux
: Normal normal (vote)
Assignee: Felix Janda
URL:
Whiteboard:
Keywords:
Depends on: 739914
Blocks: EAPI4Removal
  Show dependency tree
 
Reported: 2018-02-24 02:00 UTC by David Fellows
Modified: 2020-09-13 18:39 UTC (History)
2 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
emerge --info output (emerge.info,5.61 KB, text/plain)
2018-02-24 02:01 UTC, David Fellows
Details

Note You need to log in before you can comment on or make changes to this bug.
Description David Fellows 2018-02-24 02:00:12 UTC
Since guile-2.0.14-r3 was marked stable my regular @world updates always include
a warning that updating guile is being skipped due to dependency conflicts.

The conflict is elinks-0.12_pre6-r1 contains the dependency guile? ( >=dev-scheme/guile-1.6.4-r1[deprecated,discouraged] ) and guile-2.0.14-r3 no longer has the "discouraged USE flag.

Reproducible: Always

Steps to Reproduce:
1.have dev-scheme/guile-1.8.8-r3:12/8 and  www-client/elinks-0.12_pre6-r1:0 installed on a (mostly) stable system
2.emerge --sync
3.emerge -uD @world
Actual Results:  
WARNING: One or more updates/rebuilds have been skipped due to a dependency conflict:

dev-scheme/guile:12

  (dev-scheme/guile-2.0.14-r3:12/22::gentoo, ebuild scheduled for merge) conflicts with
    >=dev-scheme/guile-1.6.4-r1[deprecated,discouraged] required by (www-client/elinks-0.12_pre6-r1:0/0::gentoo, installed)
                                           ^^^^^^^^^^^ 
    >=dev-scheme/guile-1.8:12/8= required by (sys-devel/make-4.2.1:0/0::gentoo, installed)
                          ^^^^^^
    >=dev-scheme/guile-1.8:12/8=[networking] required by (net-libs/gnutls-3.5.15:0/30::gentoo, installed)
                          ^^^^^^            


Expected Results:  
guile-2.0.14-r3 installed in place of guile-1.8.8-r3
Possibly elinks rebuilt.

I looked at the related ebuilds. It appears that for guile-1.8.8-r3 the "discouraged" USE flag is a no-op wrt elinks since elinks requires both "deprecated" and "discouraged".  It appears to me that the elinks ebuild(s) should be updated to remove "discouraged" as a requirement for >=guile-1.8.8-r3.

I have not tested this.
Comment 1 David Fellows 2018-02-24 02:01:47 UTC
Created attachment 520818 [details]
emerge --info output
Comment 2 Felix Janda 2018-02-24 03:53:15 UTC
Could you test whether elinks builds at all with guile2:

- re-emerge elinks with USE=-guile
- upgrade guile2
- try to manually emerge elinks: USE=guile emerge /path/to/elinks-0.12_pre6-r1.ebuild install

Thanks.
Comment 3 David Fellows 2018-02-24 17:51:04 UTC
(In reply to Felix Janda from comment #2)
> Could you test whether elinks builds at all with guile2:
> 
> - re-emerge elinks with USE=-guile
> - upgrade guile2
> - try to manually emerge elinks: USE=guile emerge
> /path/to/elinks-0.12_pre6-r1.ebuild install
> 
> Thanks.

re emerged elinks with USe=-guile 
It seems to behave the same way as before with my couple of test websites.
upgraded guile to 2.0.14-r3 
This forced rebuilds of boehm-gc, make, gnutls, and graphviz

Assuming you meant ebuild and not emerge in your last step
yes, elinks built without obvious complaint. I verified that it was  built with --with-guile.

I then copied elinks directory to my local overlay, copied the -r1 ebuild to -r98. Edited that to delete the offending ",discouraged" and did emerge -u elinks.

This picked up my -r98 version and built and installed it without complaint (with USE=guile*).
This version seems to run the same as the earlier ones.

To be truthful, I am not sure exactly what the guile support is or how to force it to be used.

For the record here is the diff between the two ebuilds
diff *r1* *r98*
30c30
< 	guile? ( >=dev-scheme/guile-1.6.4-r1[deprecated,discouraged] )
---
> 	guile? ( >=dev-scheme/guile-1.6.4-r1[deprecated] )

DF
Comment 4 Felix Janda 2018-02-24 18:40:18 UTC
Thanks for reporting back! So it still works with guile-2.0.

guile is GNU's variant of the Scheme language and is often used for
extensions. It is one of the languages that can be used to script
elinks (others are lua, javascript, ruby, ...). So unless you plan
to write hook scripts in guile you can safely disable the guile use
flag. See

http://elinks.or.cz/documentation/html/manual.html-chunked/ch14.html

for some description on what can be scripted in elinks.


While elinks still works with guile-2.0, it is broken with guile-2.2.
I will look into fixing that. For now, as a workaround, just disable
the guile use flag.
Comment 5 David Fellows 2018-02-25 02:12:00 UTC
(In reply to Felix Janda from comment #4)
> Thanks for reporting back! So it still works with guile-2.0.
> 
> guile is GNU's variant of the Scheme language and is often used for
> extensions. It is one of the languages that can be used to script
> elinks (others are lua, javascript, ruby, ...). So unless you plan
> to write hook scripts in guile you can safely disable the guile use
> flag. See
> 
> http://elinks.or.cz/documentation/html/manual.html-chunked/ch14.html
> 
> for some description on what can be scripted in elinks.
> 
> 
> While elinks still works with guile-2.0, it is broken with guile-2.2.
> I will look into fixing that. For now, as a workaround, just disable
> the guile use flag.

Since I will not be writing hooks, I will do exactly that.

Presumably guile-2.2 removes some or all the deprecated features - good luck.

DF
Comment 6 Sam James archtester gentoo-dev Security 2020-08-31 22:10:59 UTC
Any update?
Comment 7 Felix Janda 2020-09-01 00:05:30 UTC
By now, this bug only applies to the stable version www-client/elinks-0.12_pre6-r1 . All newer versions do not required the "discouraged" use flag for dev-scheme/guile.
Comment 8 Sam James archtester gentoo-dev Security 2020-09-01 01:14:55 UTC
(In reply to Felix Janda from comment #7)
> By now, this bug only applies to the stable version
> www-client/elinks-0.12_pre6-r1 . All newer versions do not required the
> "discouraged" use flag for dev-scheme/guile.

Thanks. If it's ready for stabilisation (it should be?), we can file a bug a few days early and just CC arches when it's time).
Comment 9 Larry the Git Cow gentoo-dev 2020-09-13 18:39:57 UTC
The bug has been closed via the following commit(s):

https://gitweb.gentoo.org/repo/gentoo.git/commit/?id=0e591ad37835503bffc0e506f0921616c471da5d

commit 0e591ad37835503bffc0e506f0921616c471da5d
Author:     Sam James <sam@gentoo.org>
AuthorDate: 2020-09-13 18:39:51 +0000
Commit:     Sam James <sam@gentoo.org>
CommitDate: 2020-09-13 18:39:51 +0000

    www-client/elinks: cleanup old (inc. EAPI 4)
    
    Closes: https://bugs.gentoo.org/648648
    Closes: https://bugs.gentoo.org/730658
    Closes: https://bugs.gentoo.org/739914
    Package-Manager: Portage-3.0.4, Repoman-3.0.1
    Signed-off-by: Sam James <sam@gentoo.org>

 www-client/elinks/Manifest                         |   3 -
 www-client/elinks/elinks-0.12_pre6-r4.ebuild       | 155 -----------------
 .../elinks/elinks-0.13_pre_pre20180225.ebuild      | 142 ----------------
 .../elinks/files/elinks-0.11.2-lua-5.1.patch       |  16 --
 .../files/elinks-0.12_pre5-compilation-fix.patch   |  12 --
 .../elinks/files/elinks-0.12_pre5-libressl.patch   |  29 ----
 .../elinks/files/elinks-0.12_pre5-rand-egd.patch   |  20 ---
 .../elinks/files/elinks-0.12_pre5-ruby-1.9.patch   | 187 ---------------------
 .../files/elinks-0.12_pre5-sm185-jsval-fixes.patch | 124 --------------
 www-client/elinks/files/elinks-0.13-ruby.patch     | 183 --------------------
 www-client/elinks/metadata.xml                     |   1 -
 11 files changed, 872 deletions(-)