Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 648624 - net-mail/dovecot-2.3.0-r3 : rquota.h:9:10: fatal error: rpc/rpc.h: No such file or directory
Summary: net-mail/dovecot-2.3.0-r3 : rquota.h:9:10: fatal error: rpc/rpc.h: No such fi...
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Eray Aslan
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: glibc-rpc glibc-2.26-stable
  Show dependency tree
 
Reported: 2018-02-23 17:52 UTC by Toralf Förster
Modified: 2018-05-01 13:43 UTC (History)
3 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
emerge-info.txt (emerge-info.txt,16.62 KB, text/plain)
2018-02-23 17:52 UTC, Toralf Förster
Details
emerge-history.txt (emerge-history.txt,173.40 KB, text/plain)
2018-02-23 17:52 UTC, Toralf Förster
Details
environment (environment,86.16 KB, text/plain)
2018-02-23 17:52 UTC, Toralf Förster
Details
etc.portage.tbz2 (etc.portage.tbz2,13.33 KB, application/x-bzip)
2018-02-23 17:52 UTC, Toralf Förster
Details
logs.tbz2 (logs.tbz2,23.89 KB, application/x-bzip)
2018-02-23 17:52 UTC, Toralf Förster
Details
net-mail:dovecot-2.3.0-r3:20180223-125849.log.bz2 (net-mail:dovecot-2.3.0-r3:20180223-125849.log.bz2,36.68 KB, application/x-bzip)
2018-02-23 17:53 UTC, Toralf Förster
Details
temp.tbz2 (temp.tbz2,57.98 KB, application/x-bzip)
2018-02-23 17:53 UTC, Toralf Förster
Details
dovecot-quota-glibc-missing-rpc.patch (dovecot-quota-glibc-missing-rpc.patch,10.12 KB, patch)
2018-04-03 10:22 UTC, Attila Tóth
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Toralf Förster gentoo-dev 2018-02-23 17:52:42 UTC
libtool: compile:  x86_64-pc-linux-gnu-gcc -DHAVE_CONFIG_H -I. -I../../.. -I../../../src/lib -I../../../src/lib-test -I../../../src/lib-master -I../../../src/lib-dict -I../../../src/lib-index -I../../../src/lib-mail -I../../../src/lib-smtp -I../../../src/lib-imap -I../../../src/lib-imap-client -I../../../src/lib-settings -I../../../src/lib-storage -I../../../src/lib-storage/index -I../../../src/lib-storage/index/imapc -I../../../src/lib-storage/index/maildir -I../../../src/lib-program-client -I../../../src/doveadm -std=gnu99 -O2 -pipe -march=native -fstack-protector-strong -U_FORTIFY_SOURCE -D_FORTIFY_SOURCE=2 -Wall -W -Wmissing-prototypes -Wmissing-declarations -Wpointer-arith -Wchar-subscripts -Wformat=2 -Wbad-function-cast -fno-builtin-strftime -Wstrict-aliasing=2 -c quota-fs.c  -fPIC -DPIC -o .libs/quota-fs.o
In file included from quota-fs.c:28:0:
rquota.h:9:10: fatal error: rpc/rpc.h: No such file or directory
 #include <rpc/rpc.h>
          ^~~~~~~~~~~
compilation terminated.

  -------------------------------------------------------------------

  This is an unstable amd64 chroot image at a tinderbox (==build bot)
  name: 17.0-developer_20180218-175752

  -------------------------------------------------------------------

gcc-config -l:
 [1] x86_64-pc-linux-gnu-7.3.0 *

Available Python interpreters, in order of preference:
  [1]   python3.5
  [2]   python2.7 (fallback)

java-config:
The following VMs are available for generation-2:
*)	IcedTea JDK 3.6.0 [icedtea-bin-8]
Available Java Virtual Machines:
  [1]   icedtea-bin-8  system-vm

emerge -qpv net-mail/dovecot
[ebuild  N    ] net-mail/dovecot-2.3.0-r3  USE="bzip2 ipv6 ldap pam tcpd zlib -argon2 -caps -doc -kerberos -libressl -lua -lucene -lz4 -lzma -managesieve -mysql -postgres (-selinux) -sieve -solr -sqlite -static-libs -suid -textcat -vpopmail"
Comment 1 Toralf Förster gentoo-dev 2018-02-23 17:52:45 UTC
Created attachment 520748 [details]
emerge-info.txt
Comment 2 Toralf Förster gentoo-dev 2018-02-23 17:52:48 UTC
Created attachment 520750 [details]
emerge-history.txt
Comment 3 Toralf Förster gentoo-dev 2018-02-23 17:52:51 UTC
Created attachment 520752 [details]
environment
Comment 4 Toralf Förster gentoo-dev 2018-02-23 17:52:54 UTC
Created attachment 520754 [details]
etc.portage.tbz2
Comment 5 Toralf Förster gentoo-dev 2018-02-23 17:52:57 UTC
Created attachment 520756 [details]
logs.tbz2
Comment 6 Toralf Förster gentoo-dev 2018-02-23 17:53:00 UTC
Created attachment 520758 [details]
net-mail:dovecot-2.3.0-r3:20180223-125849.log.bz2
Comment 7 Toralf Förster gentoo-dev 2018-02-23 17:53:03 UTC
Created attachment 520760 [details]
temp.tbz2
Comment 8 Attila Tóth 2018-04-03 10:22:00 UTC
Created attachment 526428 [details, diff]
dovecot-quota-glibc-missing-rpc.patch

Primitive workaround for this problem. Dirty, but works for me.
Comment 9 Andreas K. Hüttel gentoo-dev 2018-05-01 13:43:21 UTC
I can't reproduce this (with both stable and ~arch), and the listed version is gone. So I assume it's fixed...