Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 647020 - dev-ruby/pygments_rb-1.2.1 : /.../popen.rb:163:in lexers! : undefined method inject for nil:NilClass (NoMethodError)
Summary: dev-ruby/pygments_rb-1.2.1 : /.../popen.rb:163:in lexers! : undefined method ...
Status: CONFIRMED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Gentoo Ruby Team
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2018-02-08 16:48 UTC by Toralf Förster
Modified: 2019-08-24 15:29 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
emerge-info.txt (emerge-info.txt,16.40 KB, text/plain)
2018-02-08 16:48 UTC, Toralf Förster
Details
dev-ruby:pygments_rb-1.2.1:20180208-092626.log (dev-ruby:pygments_rb-1.2.1:20180208-092626.log,2.84 KB, text/plain)
2018-02-08 16:48 UTC, Toralf Förster
Details
emerge-history.txt (emerge-history.txt,271.73 KB, text/plain)
2018-02-08 16:48 UTC, Toralf Förster
Details
environment (environment,198.58 KB, text/plain)
2018-02-08 16:48 UTC, Toralf Förster
Details
etc.portage.tbz2 (etc.portage.tbz2,12.51 KB, application/x-bzip)
2018-02-08 16:48 UTC, Toralf Förster
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Toralf Förster gentoo-dev 2018-02-08 16:48:34 UTC
>>> Compiling source in /var/tmp/portage/dev-ruby/pygments_rb-1.2.1/work ...
 * Running compile phase for ruby22 ...
/var/tmp/portage/dev-ruby/pygments_rb-1.2.1/work/ruby22/pygments.rb-1.2.1/lib/pygments/popen.rb:163:in `lexers!': undefined method `inject' for nil:NilClass (NoMethodError)
	from /usr/lib64/ruby/2.2.0/forwardable.rb:204:in `lexers!'
	from cache-lexers.rb:4:in `<main>'
 * ERROR: dev-ruby/pygments_rb-1.2.1::gentoo failed (compile phase):

  -------------------------------------------------------------------

  This is an unstable amd64 chroot image at a tinderbox (==build bot)
  name: 17.0-no-multilib_20180202-195308

  -------------------------------------------------------------------

gcc-config -l:
 [1] x86_64-pc-linux-gnu-7.3.0 *

Available Python interpreters, in order of preference:
  [1]   python3.5
  [2]   python2.7 (fallback)
  [3]   pypy (fallback)
  [4]   jython2.7 (fallback)
Available Ruby profiles:
  [1]   ruby22 (with Rubygems)
  [2]   ruby23 (with Rubygems) *
java-config:
The following VMs are available for generation-2:
*)	IcedTea JDK 3.6.0 [icedtea-bin-8]
Available Java Virtual Machines:
  [1]   icedtea-bin-8  system-vm

emerge -qpv dev-ruby/pygments_rb
[ebuild  N    ] dev-ruby/pygments_rb-1.1.2  USE="{-test}" PYTHON_TARGETS="python2_7" RUBY_TARGETS="ruby22 ruby23 -ruby24"
Comment 1 Toralf Förster gentoo-dev 2018-02-08 16:48:37 UTC
Created attachment 518602 [details]
emerge-info.txt
Comment 2 Toralf Förster gentoo-dev 2018-02-08 16:48:40 UTC
Created attachment 518604 [details]
dev-ruby:pygments_rb-1.2.1:20180208-092626.log
Comment 3 Toralf Förster gentoo-dev 2018-02-08 16:48:43 UTC
Created attachment 518606 [details]
emerge-history.txt
Comment 4 Toralf Förster gentoo-dev 2018-02-08 16:48:46 UTC
Created attachment 518608 [details]
environment
Comment 5 Toralf Förster gentoo-dev 2018-02-08 16:48:49 UTC
Created attachment 518610 [details]
etc.portage.tbz2
Comment 6 Hans de Graaff gentoo-dev 2018-02-16 14:02:22 UTC
This may be related to different python interpreters. If your python interpreter is python3.5 and pygments or simplejson is not installed for it then this might happen.
Comment 7 Jonathan Lovelace 2019-08-24 15:29:40 UTC
I'm seeing this when my eselected Python is 3.6, but not when I switch to 2.7 (the only version in pygments_rb PYTHON_COMPAT). Both pygments and simplejson are installed for both Python versions.