Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 6466 - Grub 0.9 is very out of date
Summary: Grub 0.9 is very out of date
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: x86 Linux
: High normal (vote)
Assignee: Gentoo Linux bug wranglers
Depends on:
Reported: 2002-08-14 11:15 UTC by Chris Paulson-Ellis
Modified: 2003-05-09 12:32 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Note You need to log in before you can comment on or make changes to this bug.
Description Chris Paulson-Ellis 2002-08-14 11:15:10 UTC
I had a problem with Grub which I solved with the help of the grub maintainers 
by using the latest CVS version. In the course of the discussion, they 
mentioned that the 0.9 release is very out of date. I see that Gentoo uses a 
heavily patched 0.9. Would a recent CVS version be better, or cause other 

You can see my (solved) problem on their bug server...

[ Bug #565 ] kernel command returns error 18 when grub loads from ntldr.

Comment 1 SpanKY gentoo-dev 2002-08-14 13:01:11 UTC
if you read /usr/portage/profiles/package.mask you will see that 0.92 is in
gentoo, it just doesnt work with XFS atm ... which is why it hasnt been released

if you dont use xfs and want to use 0.92, then delete the grub entry in that file
and run `emerge grub -u`
Comment 2 Chris Paulson-Ellis 2002-08-14 14:39:34 UTC
My appologies. I encountered this problem a while ago and I forgot to check the 
portage tree before submitting the bug.

As I don't use xfs, I'll try 0.92 and let you know if it fixed my problem (it 
should do as 0.92 post-dates my CVS snapshot).

Comment 3 Chris Paulson-Ellis 2002-08-16 17:37:50 UTC
I emerged the 0.92 ebuild explicitly and it works. 
Thanks, Chris. 
Comment 4 Chris Paulson-Ellis 2002-08-16 17:47:49 UTC
 Verified. 0.92 worked fine for me when explicitly emerged. 
Comment 5 John Davis (zhen) (RETIRED) gentoo-dev 2003-04-04 01:23:03 UTC
db fix
Comment 6 John Davis (zhen) (RETIRED) gentoo-dev 2003-04-04 01:27:56 UTC
db fix
Comment 7 Martin Holzer (RETIRED) gentoo-dev 2003-05-09 12:32:59 UTC
0.9.2 is in cvs