Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 646374 - app-editors/neovim-0.2.2-r1 missing dependency on dev-python/six
Summary: app-editors/neovim-0.2.2-r1 missing dependency on dev-python/six
Status: CONFIRMED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Vim Maintainers
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2018-02-02 00:48 UTC by Koz Ross
Modified: 2018-02-03 01:22 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
emerge --info app-editors/neovim (emerge-info.txt,5.27 KB, text/plain)
2018-02-02 00:48 UTC, Koz Ross
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Koz Ross 2018-02-02 00:48:32 UTC
Created attachment 517520 [details]
emerge --info app-editors/neovim

This is a bug for app-editors/neovim-0.2.2-r1. When I try to open a document that would be linted by Neomake (which is pure Vimscript), I received the following error message:

"src/Data/Bitvector.hs" 6L, 124C                                                                                                                  
function ghci#process#start[5]..ghci#process#initialize[13]..provider#python#Call[9]..remote#host#Require[10]..provider#pythonx#Require, line 15
Vim(if):ch 1 was closed by the client                                                                                                           
Traceback (most recent call last):   
  File "<string>", line 1, in <module>
  File "/usr/lib64/python2.7/site-packages/neovim/__init__.py", line 11, in <module>
    from .msgpack_rpc import (ErrorResponse, child_session, socket_session,
  File "/usr/lib64/python2.7/site-packages/neovim/msgpack_rpc/__init__.py", line 8, in <module>
    from .event_loop import EventLoop
  File "/usr/lib64/python2.7/site-packages/neovim/msgpack_rpc/event_loop/__init__.py", line 12, in <module>
    from .asyncio import AsyncioEventLoop
  File "/usr/lib64/python2.7/site-packages/neovim/msgpack_rpc/event_loop/asyncio.py", line 22, in <module>
    import trollius as asyncio
  File "/usr/lib64/python2.7/site-packages/trollius/__init__.py", line 11, in <module>
    import selectors  # Will also be exported.
  File "/usr/lib64/python2.7/site-packages/trollius/selectors.py", line 14, in <module>
    from .py33_exceptions import wrap_error, InterruptedError
  File "/usr/lib64/python2.7/site-packages/trollius/py33_exceptions.py", line 16, in <module>                                                     
    from .compat import PY33                                                                                                                      
  File "/usr/lib64/python2.7/site-packages/trollius/compat.py", line 3, in <module>                                                               
    import six                                                                                                                                    
ImportError: No module named six

Installing ``dev-python/six`` of course fixes this issue, but as Neomake is pure Vimscript, it means that ``dev-python/six`` is a dependency of Neovim rather than Neomake specifically. Indeed, Neomake does not specify that Six is a dependency anywhere, and I have not encountered this issue on any other distro except Gentoo with Neovim, even of this specific version.
Comment 1 Patrice Clement gentoo-dev 2018-02-03 01:22:35 UTC
Thanks for the heads up. We'll look into it ASAP.