Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 646152 - net-ftp/ftp-0.17.23.0.2.1 error:1408F10B:SSL routines:SSL3_GET_RECORD:wrong version number
Summary: net-ftp/ftp-0.17.23.0.2.1 error:1408F10B:SSL routines:SSL3_GET_RECORD:wrong v...
Status: UNCONFIRMED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Gentoo's Team for Core System packages
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: 643866
  Show dependency tree
 
Reported: 2018-01-30 19:32 UTC by Walter Dnes
Modified: 2018-02-27 21:23 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments
emerge --info output (info.txt.gz,2.65 KB, application/gzip)
2018-01-30 19:32 UTC, Walter Dnes
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Walter Dnes 2018-01-30 19:32:12 UTC
Created attachment 517164 [details]
emerge --info output

I upload a tarball to an open source project weekly, via ftp. As per https://bugs.gentoo.org/643866 my ftp client updated to net-ftp/ftp-0.17.23.0.2.1 a few days ago. I log on with userid/password in ~/.netrc. Yesterday, I ran into issues first time I used the upgraded client. Here is the session, slightly redacted...

[d531][waltdnes][/dev/shm] ftp -p ****************
Connected to ****************.
220-Welcome to the ******************* FTP server!
220-Note: all sessions and IP addresses are logged.
220 No anonymous access accepted on this server.
234 Using authentication type TLS
[SSL Cipher ECDHE-RSA-AES256-GCM-SHA384]
331 Password required for **********
230 Logged on
Remote system type is UNIX.
ftp> dir
227 Entering Passive Mode (**,***,*,***,79,123)
150 Opening data channel for directory listing of "/"
ftp: SSL_connect DATA error -1 - error:1408F10B:SSL routines:SSL3_GET_RECORD:wrong version number
226 Successfully transferred "/"
421 Service not available, remote server has closed connection
ftp>

According to the ftp server admin, the server logs don't show any errors. I.e. it shows my client logging in and then logging off. Downgrading to net-ftp/ftp-0.17-r7 solved the problem, i.e. I was able to do the upload successfully. "emerge --info" output is attached.
Comment 1 Dimitrios Semitsoglou-Tsiapos 2018-02-27 21:23:37 UTC
I just ran into this and it turns out that the server (vsftpd) was causing the error you're getting because of a completely unrelated permissions problem. Temporarily disabling ssl completely on the server side allowed the real problem to be printed upon connection.