Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 646066 - media-tv/plex-media-server-1.10.1 - revdep-rebuild keeps wanting to rebuild
Summary: media-tv/plex-media-server-1.10.1 - revdep-rebuild keeps wanting to rebuild
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Jonathan Vasquez (RETIRED)
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2018-01-29 18:54 UTC by Dudu Edri
Modified: 2018-01-31 05:08 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments
emerge --info output (emerge_info,5.25 KB, text/plain)
2018-01-29 18:54 UTC, Dudu Edri
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Dudu Edri 2018-01-29 18:54:30 UTC
Created attachment 517080 [details]
emerge --info output

plex-media-server-1.10.1 upstream comes with pre-compiled libraries for its internal use. Some of them have missing library dependencies, and so revdep-rebuild wants to rebuild the package over and over again. Rebuilding the package doesn't cause revdep-rebuild to stop asking for a rebuild, because the libraries aren't compiled locally but are provided with the package and just extracted to /usr/lib64/plexmediaserver.

I'm sure that making plex to work natively is complicated, but a simple workaround is possible: just add "SEARCH_DIRS_MASK=/usr/lib64/plexmediaserver" to /etc/revdep-rebuild/* to prevent revdep-rebuild from searching plex internal libraries.
Comment 1 Jeroen Roovers gentoo-dev 2018-01-29 18:59:33 UTC
Looks like it is related to bug #644694.
Comment 2 Jonathan Vasquez (RETIRED) gentoo-dev 2018-01-29 20:44:57 UTC
Thanks Dudu. I tested your fix and it worked fine. Fixed in:

https://gitweb.gentoo.org/repo/gentoo.git/commit/?id=b7b5b2617c1a25af25fa51f50bbd853ba55caea3

1.10.1-r1.
Comment 3 Jeroen Roovers gentoo-dev 2018-01-31 05:05:54 UTC
*** Bug 646162 has been marked as a duplicate of this bug. ***