Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bugzilla DB migration completed. Please report issues to Infra team via email via infra@gentoo.org or IRC
Bug 645756 - >=media-libs/mesa-18.0.0_rc2[radeon]: plasmashell and other KDE binaries start to segfault after update
Summary: >=media-libs/mesa-18.0.0_rc2[radeon]: plasmashell and other KDE binaries star...
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Gentoo X packagers
URL: https://bugs.freedesktop.org/show_bug...
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2018-01-25 18:56 UTC by Pavel Volkov
Modified: 2018-02-10 17:52 UTC (History)
9 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Pavel Volkov 2018-01-25 18:56:08 UTC
'plasmashell', 'ksplashqml' and 'kmail' binaries segfault right after logging in into Plasma sessions if I upgrade Mesa.
Everything works with Mesa 17.3.3.

This is backtrace from /usr/bin/kmail coredump.
r600 is my video card.

Core was generated by `/usr/bin/kmail -session 10dcd7cfcb000147846248200000156710141_1483955504_762746'.
Program terminated with signal SIGSEGV, Segmentation fault.
#0  0x00007f37f999af50 in raise () from /lib64/libc.so.6
[Current thread is 1 (Thread 0x7f37fc86ea40 (LWP 892))]
(gdb) bt
#0  0x00007f37f999af50 in raise () from /lib64/libc.so.6
#1  0x00007f37fbb9f727 in KCrash::defaultCrashHandler(int) () from /usr/lib64/libKF5Crash.so.5
#2  <signal handler called>
#3  0x00007f37f9a0d4f3 in ?? () from /lib64/libc.so.6
#4  0x00007f37bb154094 in ?? () from /usr/lib64/dri/r600_dri.so
#5  0x000055c4ec9e5de0 in ?? ()
#6  0x000055c4ec9d7fe0 in ?? ()
#7  0x000055c4ec9e5de0 in ?? ()
#8  0x00007f37bb254e2b in ?? () from /usr/lib64/dri/r600_dri.so
#9  0x0000000000000003 in ?? ()
#10 0x00007fff107efa90 in ?? ()
#11 0x0000000000000000 in ?? ()

Portage 2.3.20 (python 3.6.4-final-0, default/linux/amd64/17.0/desktop/plasma/systemd, gcc-7.2.0, glibc-2.26-r5, 4.14.12-gentoomelf x86_64)
=================================================================
System uname: Linux-4.14.12-gentoomelf-x86_64-Intel-R-_Core-TM-_i5-2400_CPU_@_3.10GHz-with-gentoo-2.4.1
KiB Mem:    16372580 total,  10096312 free
KiB Swap:   17825788 total,  17825788 free
Timestamp of repository gentoo: Thu, 25 Jan 2018 17:15:01 +0000
Head commit of repository gentoo: 97f6f10a1e5604036f9343a2ea6077059600c2d5
sh bash 4.4_p12-r1
ld GNU ld (Gentoo 2.29.1 p3) 2.29.1
app-shells/bash:          4.4_p12-r1::gentoo
dev-lang/perl:            5.26.1-r1::gentoo
dev-lang/python:          2.7.14-r1::gentoo, 3.6.4::gentoo
dev-util/cmake:           3.10.2::gentoo
dev-util/pkgconfig:       0.29.2::gentoo
sys-apps/baselayout:      2.4.1-r2::gentoo
sys-apps/sandbox:         2.12::gentoo
sys-devel/autoconf:       2.13::gentoo, 2.69-r4::gentoo
sys-devel/automake:       1.11.6-r2::gentoo, 1.15.1-r1::gentoo
sys-devel/binutils:       2.29.1-r1::gentoo
sys-devel/gcc:            7.2.0-r1::gentoo
sys-devel/gcc-config:     1.9.1::gentoo
sys-devel/libtool:        2.4.6-r4::gentoo
sys-devel/make:           4.2.1-r1::gentoo
sys-kernel/linux-headers: 4.14::gentoo (virtual/os-headers)
sys-libs/glibc:           2.26-r5::gentoo
Repositories:

gentoo
    location: /usr/portage
    sync-type: rsync
    sync-uri: rsync://rsync2.ru.gentoo.org/gentoo-portage
    priority: -1000
    sync-rsync-extra-opts: -4

jorgicio
    location: /var/lib/layman/jorgicio
    sync-type: laymansync
    sync-uri: https://github.com/jorgicio/jorgicio-gentoo.git
    masters: gentoo
    priority: 50

custom
    location: /usr/local/portage
    masters: gentoo
    priority: 70

Installed sets: @development, @fonts, @kdeapps, @python-extra
ACCEPT_KEYWORDS="amd64 ~amd64"
ACCEPT_LICENSE="@FREE freedist linux-firmware no-source-code MPEG-4 unRAR CC-BY-NC-ND-3.0 intel-ucode BitstreamCyberbit MSttfEULA grass-ipafonts free-noncomm bh-luxi"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-O2 -pipe -march=native -mtune=native"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/lib64/libreoffice/program/sofficerc /usr/share/config /usr/share/easy-rsa /usr/share/gnupg/qualified.txt /usr/share/ibus/component/simple.xml /var/lib/i2pd/certificates /var/spool/munin-async/.ssh"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/dconf /etc/env.d /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/openvpn/update-systemd-resolved /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo"
CXXFLAGS="-O2 -pipe -march=native -mtune=native"
DISTDIR="/usr/portage/distfiles"
EMERGE_DEFAULT_OPTS="--keep-going --quiet-build"
FCFLAGS="-O2 -pipe"
FEATURES="assume-digests binpkg-logs config-protect-if-modified distlocks ebuild-locks fixlafiles merge-sync multilib-strict news parallel-fetch preserve-libs protect-owned sandbox sfperms strict unknown-features-warn unmerge-logs unmerge-orphans userfetch userpriv usersandbox usersync xattr"
FFLAGS="-O2 -pipe"
GENTOO_MIRRORS="http://gentoo.bloodhost.ru/ http://mirror.yandex.ru/gentoo-distfiles/ http://mirror.leaseweb.com/gentoo/"
INSTALL_MASK="/etc/init.d/ /etc/xinetd.d/ /etc/hosts /etc/networks"
LANG="en_GB.utf8"
LDFLAGS="-Wl,-O1 -Wl,--as-needed"
LINGUAS="en en_GB ru ja"
MAKEOPTS="-j5"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_EXTRA_OPTS="-4"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --omit-dir-times --compress --force --whole-file --delete --stats --human-readable --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages --exclude=/.git"
PORTAGE_TMPDIR="/var/tmp"
USE="X a52 aac acl acpi activities alsa amd64 anthy berkdb bluetooth branding btrfs bzip2 cacert cairo cdda cdr cjk cli crypt cryptsetup cups cxx dbus declarative djvu dri dts dvd dvdr egl emboss encode exif fam ffmpeg firefox flac fortran gdbm gif git glamor gpg gpm gstreamer gtk ibus iconv icu idn ipv6 jpeg kde kipi kwallet lcms libnotify lm_sensors mad mng modules mp3 mp4 mpeg multilib ncurses nls nptl ogg opengl openmp opus pam pango pcre pdf phonon plasma png policykit ppds pulseaudio python qml qt3support qt5 raw readline samba scanner sdl seccomp spell ssl startup-notification subversion svg systemd tcpd telepathy tiff truetype udev udisks unicode upower usb v4l vorbis wayland widgets wxwidgets x264 x265 xattr xcb xcomposite xml xv xvid zlib" ABI_X86="64" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" APACHE2_MODULES="authn_core authz_core socache_shmcb unixd actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" CALLIGRA_FEATURES="kexi words flow plan sheets stage tables krita karbon braindump author" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" CPU_FLAGS_X86="aes avx mmx mmxext popcnt sse sse2 sse3 sse4_1 sse4_2 ssse3" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock isync itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf skytraq superstar2 timing tsip tripmate tnt ublox ubx" INPUT_DEVICES="evdev" KERNEL="linux" L10N="en en-GB ru ja" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LIBREOFFICE_EXTENSIONS="presenter-console presenter-minimizer" OFFICE_IMPLEMENTATION="libreoffice" PHP_TARGETS="php5-6 php7-0" POSTGRES_TARGETS="postgres9_5" PYTHON_SINGLE_TARGET="python3_6" PYTHON_TARGETS="python2_7 python3_6" RUBY_TARGETS="ruby25" SANE_BACKENDS="genesys" USERLAND="GNU" VIDEO_CARDS="radeon r600" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"
Unset:  CC, CPPFLAGS, CTARGET, CXX, LC_ALL, PORTAGE_BUNZIP2_COMMAND, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS
Comment 1 Matt Turner gentoo-dev 2018-01-27 03:03:18 UTC
Have you filed a bug upstream? If not, please do so here [1] and add it to the URL field here.

[1] https://bugs.freedesktop.org/enter_bug.cgi?product=Mesa&component=Drivers/Gallium/radeonsi
Comment 2 Steffen Hau 2018-01-27 19:23:59 UTC
I can cofirm this with media-libs/mesa-18.0.0_rc2[video_cards_i965]. Instead of segfaults I'm seeing sigabrt:

Jan 27 13:28:41 schlepptop plasmashell[17210]: QSGSimpleMaterialShader does not implement 'uniform highp mat4 qt_Matrix;' in its vertex shader
Jan 27 13:28:47 schlepptop systemd[1]: Started Process Core Dump (PID 17360/UID 0).
Jan 27 13:28:53 schlepptop systemd-coredump[17340]: Core file was truncated to 2147483648 bytes.
Jan 27 13:28:55 schlepptop systemd-coredump[17340]: Process 17210 (plasmashell) of user 1000 dumped core.

coredumpctl info:
           PID: 17210 (plasmashell)
           UID: 1000 (steffen)
           GID: 100 (users)
        Signal: 6 (ABRT)
     Timestamp: Sat 2018-01-27 13:28:42 CET (6h ago)
  Command Line: /usr/bin/plasmashell
    Executable: /usr/bin/plasmashell
 Control Group: /user.slice/user-1000.slice/session-7.scope
          Unit: session-7.scope
         Slice: user-1000.slice
       Session: 7
     Owner UID: 1000 (steffen)
       Boot ID: 13b476fd39b9460f8b42af7307f6020a
    Machine ID: 6e7417103a8d6b4bcfe9252757850ee9
      Hostname: schlepptop.hauihau.home
       Storage: /var/lib/systemd/coredump/core.plasmashell.1000.13b476fd39b9460f8b42af7307f6020a.17210.1517056122000000.lz4 (truncated)
       Message: Process 17210 (plasmashell) of user 1000 dumped core.


Downgrading mesa to 17.3.3 solves this issue. That also solved issue with sddm no longer showing login screen.
Comment 3 Egor Y. Egorov 2018-01-30 04:01:19 UTC
Same in my case.
mesa-9999 work fine
Comment 4 Robert Crawford 2018-01-30 15:46:46 UTC
What about mesa-18.0.0_rc3, which just showed up in the tree?  Are these issues resolved?
Comment 5 Pavel Volkov 2018-01-30 16:04:08 UTC
It seems that commit
041b18cf23a0acf7b0eddf63cd7a2a10192432a1
fixes this.
Comment 6 Dennis Schridde 2018-01-31 01:16:33 UTC
See-Also: https://bugs.freedesktop.org/show_bug.cgi?id=104762

Fixed by: https://cgit.freedesktop.org/mesa/mesa/commit/?id=041b18cf23a0acf7b0eddf63cd7a2a10192432a1
(patch applies cleanly to 18.0.0_rc3)
Comment 7 Francesco Riosa 2018-02-01 23:03:32 UTC
(In reply to Dennis Schridde from comment #6)
> See-Also: https://bugs.freedesktop.org/show_bug.cgi?id=104762
> 
> Fixed by:
> https://cgit.freedesktop.org/mesa/mesa/commit/
> ?id=041b18cf23a0acf7b0eddf63cd7a2a10192432a1
> (patch applies cleanly to 18.0.0_rc3)

not here, that patch alone does not suffice, plasma does not crash, but windows are still black
Comment 8 Chí-Thanh Christopher Nguyễn gentoo-dev 2018-02-01 23:58:38 UTC
(In reply to Francesco Riosa from comment #7)
> plasma does not crash, but windows are still black

That is possibly a separate unrelated issue, better open a new bug.
Comment 9 Dennis Schridde 2018-02-02 00:03:10 UTC
(In reply to Francesco Riosa from comment #7)
> (In reply to Dennis Schridde from comment #6)
> > See-Also: https://bugs.freedesktop.org/show_bug.cgi?id=104762
> > 
> > Fixed by:
> > https://cgit.freedesktop.org/mesa/mesa/commit/
> > ?id=041b18cf23a0acf7b0eddf63cd7a2a10192432a1
> > (patch applies cleanly to 18.0.0_rc3)
> 
> not here, that patch alone does not suffice, plasma does not crash, but
> windows are still black

I had the same and needed to delete the shader cache.  Everything was fine afterwards.
Comment 10 Lars Wendler (Polynomial-C) gentoo-dev 2018-02-02 07:39:09 UTC
(In reply to Dennis Schridde from comment #9)
> (In reply to Francesco Riosa from comment #7)
> > (In reply to Dennis Schridde from comment #6)
> > > See-Also: https://bugs.freedesktop.org/show_bug.cgi?id=104762
> > > 
> > > Fixed by:
> > > https://cgit.freedesktop.org/mesa/mesa/commit/
> > > ?id=041b18cf23a0acf7b0eddf63cd7a2a10192432a1
> > > (patch applies cleanly to 18.0.0_rc3)
> > 
> > not here, that patch alone does not suffice, plasma does not crash, but
> > windows are still black
> 
> I had the same and needed to delete the shader cache.  Everything was fine
> afterwards.

Didn't wok here. Added the patch, deleted the shader cache and windows are still black and all text looks completely garbled. Perhaps I should mention that this is on an amdgpu system.
Comment 11 Lars Wendler (Polynomial-C) gentoo-dev 2018-02-02 07:54:33 UTC
And now I just found out that on my radeon system everything is indeed fine with the patched mesa-18.0.0_rc3. So this might really be a (perhaps similar but still) different issue with the amdgpu driver.
Comment 12 Dennis Schridde 2018-02-02 08:15:09 UTC
(In reply to Lars Wendler (Polynomial-C) from comment #10)
> Didn't wok here. Added the patch, deleted the shader cache and windows are
> still black and all text looks completely garbled. Perhaps I should mention
> that this is on an amdgpu system.

In that case it might indeed be another bug.

(In reply to Lars Wendler (Polynomial-C) from comment #11)
> And now I just found out that on my radeon system everything is indeed fine
> with the patched mesa-18.0.0_rc3. So this might really be a (perhaps similar
> but still) different issue with the amdgpu driver.

I also have an AMDGPU system with KAVERI (primary GPU) and POLARIS11.  I use AMDGPU for both GPUs and have DC enabled.  Just so you can search in the right direction for the other bug you are experiencing.
Comment 13 Pavel Volkov 2018-02-02 08:27:22 UTC
Cool, I will try the new ebuild later today on my radeon.
Comment 14 Pavel Volkov 2018-02-03 08:30:33 UTC
Updating to media-libs/mesa-18.0.0_rc3 and deleting caches helped me.
These are the dirs that I deleted in ~/.cache:

qtshadercache
mesa_shader_cache
plasmashell/qmlcache/
ksycoca5_en_*
plasma-svgelements-*
plasma_theme_*
icon-cache.kcache
Comment 15 Pavel Volkov 2018-02-03 21:49:23 UTC
Also had to delete cache files in /root/.cache and /var/lib/sddm/.cache for screenlock / logout screen binaries to not crash.
Comment 16 Pavel Volkov 2018-02-05 13:04:40 UTC
Sorry, it looks like proper fix didn't make it yet into a release.
I will try later with this patch:
https://cgit.freedesktop.org/mesa/mesa/patch/?id=041b18cf23a0acf7b0eddf63cd7a2a10192432a1
Comment 17 Andrei Slavoiu 2018-02-10 16:13:39 UTC
Just upgraded to mesa 18.0.0-rc4 and it looks like the problem is solved.
Comment 18 Pavel Volkov 2018-02-10 17:52:26 UTC
I agree.