Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 645368 - dev-ruby/rack-1.5.5: please add RUBY_TARGETS="ruby23"
Summary: dev-ruby/rack-1.5.5: please add RUBY_TARGETS="ruby23"
Status: RESOLVED CANTFIX
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Gentoo Ruby Team
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2018-01-22 15:01 UTC by Tomáš Mózes
Modified: 2018-01-24 09:49 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Tomáš Mózes 2018-01-22 15:01:28 UTC
Sinatra needs rack 1.5, please add ruby23 to RUBY_TARGETS.
Comment 1 Hans de Graaff gentoo-dev 2018-01-22 16:41:30 UTC
Unfortunately rack 1.5 is not compatible with ruby23. rack 1.6 is, and that can be used by both current sinatra versions.
Comment 2 Tomáš Mózes 2018-01-24 09:49:38 UTC
For some reason I had anything above rack 1.5 masked, but you are right, 1.6 works just fine. Maybe something changed during that time.

Thanks!