Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bugzilla DB migration completed. Please report issues to Infra team via email via infra@gentoo.org or IRC
Bug 645256 - media-sound/sndfile-tools-1.04 : file collision with media-libs/libsamplerate-0.1.9
Summary: media-sound/sndfile-tools-1.04 : file collision with media-libs/libsamplerate...
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal with 1 vote (vote)
Assignee: Gentoo Sound Team
URL: https://github.com/erikd/libsamplerat...
Whiteboard:
Keywords:
: 645258 712392 (view as bug list)
Depends on:
Blocks:
 
Reported: 2018-01-21 15:23 UTC by Toralf Förster
Modified: 2020-09-04 16:34 UTC (History)
3 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
emerge-info.txt (emerge-info.txt,15.93 KB, text/plain)
2018-01-21 15:23 UTC, Toralf Förster
Details
emerge-history.txt (emerge-history.txt,161.04 KB, text/plain)
2018-01-21 15:23 UTC, Toralf Förster
Details
etc.portage.tbz2 (etc.portage.tbz2,15.30 KB, application/x-bzip)
2018-01-21 15:23 UTC, Toralf Förster
Details
logs.tbz2 (logs.tbz2,9.46 KB, application/x-bzip)
2018-01-21 15:23 UTC, Toralf Förster
Details
media-sound:sndfile-tools-1.04:20180121-131344.log (media-sound:sndfile-tools-1.04:20180121-131344.log,24.93 KB, text/plain)
2018-01-21 15:24 UTC, Toralf Förster
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Toralf Förster gentoo-dev 2018-01-21 15:23:46 UTC
 * Detected file collision(s):
 * 
 * 	/usr/bin/sndfile-resample
 * 
 * Searching all installed packages for file collisions...
 * 
 * Press Ctrl-C to Stop
 * 
 * media-libs/libsamplerate-0.1.9:0::gentoo
 * 	/usr/bin/sndfile-resample
 * 
 * Package 'media-sound/sndfile-tools-1.04' NOT merged due to file

  -------------------------------------------------------------------

  This is an unstable amd64 chroot image at a tinderbox (==build bot)
  name: 17.0-systemd_libressl-test_20180117-213341

  -------------------------------------------------------------------

gcc-config -l:
 [1] x86_64-pc-linux-gnu-7.2.0 *

Available Python interpreters, in order of preference:
  [1]   python3.5
  [2]   python2.7 (fallback)

java-config:
The following VMs are available for generation-2:
*)	IcedTea JDK 3.6.0 [icedtea-bin-8]
Available Java Virtual Machines:
  [1]   icedtea-bin-8  system-vm

emerge -qpv media-sound/sndfile-tools
[ebuild  N    ] media-sound/sndfile-tools-1.03-r1
Comment 1 Toralf Förster gentoo-dev 2018-01-21 15:23:49 UTC
Created attachment 515680 [details]
emerge-info.txt
Comment 2 Toralf Förster gentoo-dev 2018-01-21 15:23:52 UTC
Created attachment 515682 [details]
emerge-history.txt
Comment 3 Toralf Förster gentoo-dev 2018-01-21 15:23:55 UTC
Created attachment 515684 [details]
etc.portage.tbz2
Comment 4 Toralf Förster gentoo-dev 2018-01-21 15:23:58 UTC
Created attachment 515686 [details]
logs.tbz2
Comment 5 Toralf Förster gentoo-dev 2018-01-21 15:24:01 UTC
Created attachment 515688 [details]
media-sound:sndfile-tools-1.04:20180121-131344.log
Comment 6 Pacho Ramos gentoo-dev 2018-06-22 09:32:08 UTC
*** Bug 645258 has been marked as a duplicate of this bug. ***
Comment 7 Toralf Förster gentoo-dev 2020-03-13 19:55:59 UTC
*** Bug 712392 has been marked as a duplicate of this bug. ***
Comment 8 Andreas Sturmlechner gentoo-dev 2020-08-08 23:58:39 UTC
Both packages seem to actually build different versions of the same source.

media-sound/sndfile-tools-1.04 has:
src/resample.c, GPL-2+
* Copyright (C) 2002-2012 Erik de Castro Lopo

media-libs/libsamplerate-0.1.9 has:
examples/sndfile-resample.c, BSD
* Copyright (c) 2002-2016, Erik de Castro Lopo
Comment 9 Andreas Sturmlechner gentoo-dev 2020-08-09 00:14:44 UTC
Our copy of the tarball seems to be just wrong.


!!! Fetched file: sndfile-tools-1.04.tar.bz2 VERIFY FAILED!
!!! Reason: Filesize does not match recorded size
!!! Got:      715692
!!! Expected: 714880
Refetching... File renamed to '/var/lib/portage/distfiles/sndfile-tools-1.04.tar.bz2._checksum_failure_.yuowl1fs'

!!! Couldn't download 'sndfile-tools-1.04.tar.bz2'. Aborting.
Comment 10 Andreas Sturmlechner gentoo-dev 2020-09-04 15:07:13 UTC
Oh well...
Comment 11 Larry the Git Cow gentoo-dev 2020-09-04 16:34:58 UTC
The bug has been closed via the following commit(s):

https://gitweb.gentoo.org/repo/gentoo.git/commit/?id=91bd1ac96387cbd0e738a5673e7b665e4df5d518

commit 91bd1ac96387cbd0e738a5673e7b665e4df5d518
Author:     Andreas Sturmlechner <asturm@gentoo.org>
AuthorDate: 2020-09-04 15:06:02 +0000
Commit:     Andreas Sturmlechner <asturm@gentoo.org>
CommitDate: 2020-09-04 16:34:04 +0000

    media-sound/sndfile-tools: Tarball respun, EAPI-7 bump
    
    Drop bogus slot ops.
    Block colliding media-libs/libsamplerate versions.
    
    Closes: https://bugs.gentoo.org/645256
    Closes: https://bugs.gentoo.org/736459
    Package-Manager: Portage-3.0.5, Repoman-3.0.1
    Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>

 media-sound/sndfile-tools/Manifest                 |  1 +
 .../sndfile-tools/sndfile-tools-1.04-r1.ebuild     | 40 ++++++++++++++++++++++
 .../sndfile-tools/sndfile-tools-9999.ebuild        | 24 +++++++------
 3 files changed, 54 insertions(+), 11 deletions(-)

Additionally, it has been referenced in the following commit(s):

https://gitweb.gentoo.org/repo/gentoo.git/commit/?id=74842883030c94f2c2f53ac0c2056cbd03777dbb

commit 74842883030c94f2c2f53ac0c2056cbd03777dbb
Author:     Andreas Sturmlechner <asturm@gentoo.org>
AuthorDate: 2020-09-04 16:17:58 +0000
Commit:     Andreas Sturmlechner <asturm@gentoo.org>
CommitDate: 2020-09-04 16:34:04 +0000

    media-libs/libsamplerate: Fix file collision with media-sound/sndfile-tools
    
    Bug: https://bugs.gentoo.org/645256
    Closes: https://bugs.gentoo.org/408849
    Package-Manager: Portage-3.0.5, Repoman-3.0.1
    Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>

 .../files/libsamplerate-0.1.9-htmldocdir.patch     | 53 ++++++++++++++++++++++
 .../libsamplerate-0.1.9-no-sndfile-resample.patch  | 34 ++++++++++++++
 .../libsamplerate/libsamplerate-0.1.9-r1.ebuild    | 42 +++++++++++++++++
 3 files changed, 129 insertions(+)