Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 6452 - lftp-2.6.1 wont compile
Summary: lftp-2.6.1 wont compile
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: New packages (show other bugs)
Hardware: x86 Linux
: High normal (vote)
Assignee: Nick Hadaway
Depends on:
Reported: 2002-08-14 06:57 UTC by Mauro Sciaccaluga
Modified: 2003-02-04 19:42 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Note You need to log in before you can comment on or make changes to this bug.
Description Mauro Sciaccaluga 2002-08-14 06:57:34 UTC
It gives me a strange error, wut it didnt the former version:

I use gcc 3.2pre. thanks


first in configure i noticed this:

checking for i686-pc-linux-gnu-gcc option to accept ANSI C... none needed

I dunno if it is important...

i686-pc-linux-gnu-gcc -DHAVE_CONFIG_H -I. -I. -I../include -I../include    
-fno-exceptions -fno-rtti -march=athlon-tbird -mmmx -m3dnow -fomit-frame-pointer
-ffast-math -foptimize-sibling-calls -O3 -pipe -Wall -Wwrite-strings
-Woverloaded-virtual -fno-exceptions -fno-rtti -fno-implement-inlines -Winline
-c -o lftp.o `test -f '' || echo './'` In function `int main(int, char**)': `LC_ALL' undeclared (first use this function) (Each undeclared identifier is reported only once for each 
   function it appears in.) `setlocale' undeclared (first use this function) `LC_NUMERIC' undeclared (first use this function) warning: statement with no effect warning: statement with no effect
make[1]: *** [lftp.o] Error 1
make[1]: *** Waiting for unfinished jobs....
make[1]: Leaving directory `/var/tmp/portage/lftp-2.6.1/work/lftp-2.6.1/src'
make: *** [all-recursive] Error 1

!!! ERROR: The ebuild did not complete successfully.
!!! Function src_compile, Line 35, Exitcode 2
!!! compile problem

!!! emerge aborting on  /usr/portage/net-ftp/lftp/lftp-2.6.1.ebuild .

Comment 1 Nick Hadaway 2002-08-14 14:44:40 UTC
I have updated the lftp ebuild to do a "make" instead of an "emake".  This 
should fix your compile problem.  The updated ebuild should be available in 
portage within 24 hours.

emerge rsync
emerge lftp

Please let me know if everything is working after the update.
Comment 2 Mauro Sciaccaluga 2002-08-14 15:38:33 UTC
:( it doesnt work, im sorry.

Comment 3 Mauro Sciaccaluga 2002-08-14 15:39:59 UTC
i checked also the ebuild to see if it is the most updated! i think it is...

from the ebuild:

src_compile() {

        local myconf
        use nls || myconf="--disable-nls"
        use ssl || myconf="${myconf} --without-ssl"

        export CFLAGS="-fno-exceptions -fno-rtti ${CFLAGS}"
        export CXXFLAGS="-fno-exceptions -fno-rtti ${CXXFLAGS}"

        ./configure \
                --prefix=/usr \
                --sysconfdir=/etc/lftp \
                --without-modules \
                --mandir=/usr/share/man \
                --host=${CHOST} ${myconf} || die "bad ./configure"

        make || die "compile problem"
Comment 4 Nick Hadaway 2002-08-15 15:20:22 UTC
I have further updated USE flags for nls which might help your compile 
problem.  LC_ALL is an internationalization reference.  Is nls set in your use 

I have also added a socks5 USE variable which should be unrelated to your 
problem but an added feature nonetheless.

Please let me know if the updated ebuild works for you.  If not, please send 
compile logs as an attachment to this bug report.
Comment 5 Mauro Sciaccaluga 2002-08-15 16:08:49 UTC
Ok. I got it!! I tried again with your new ebuild but it didnt work. So I tried
to add "nls" into my USE variable. Then now i works!! it is weird anyway...



Comment 6 Nick Hadaway 2002-08-15 17:00:13 UTC
This ebuild seems to only work with --enable-nls as a configure option.  I will 
be playing with it to see if I can find out where the problem is over the next 
couple of days.  For now I have forced nls in the ebuild until I can find a 
Comment 7 Mauro Sciaccaluga 2002-08-15 17:48:52 UTC
ok. thanks for your efforts :_)
Comment 8 Antti Sykäri 2002-08-16 03:53:52 UTC
I have a similar error with lftp but not the same, this time with

I have gcc 3.2 and nls in my USE, however:

source='' object='FileSetOutput.o' libtool=no \
depfile='.deps/FileSetOutput.Po' tmpdepfile='.deps/FileSetOutput.TPo' \
depmode=gcc /bin/sh ../depcomp \
i686-pc-linux-gnu-gcc -DHAVE_CONFIG_H -I. -I. -I../include -I../include 
-I/usr/include    -fno-exceptions -fno-rtti  -Wall -Wwrite-strings 
-Woverloaded-virtual -fno-exceptions -fno-rtti -fno-implement-inlines 
-Winline -c -o FileSetOutput.o `test -f '' || echo 
cc1plus: warning: changing search order for system directory "/usr/include"
cc1plus: warning:   as it has already been specified as a non-system 
directory In member function `void FileSetOutput::print(FileSet&, 
   OutputJob*) const': `LC_TIME' undeclared (first use this function) (Each undeclared identifier is reported only once for 
   each function it appears in.)
make[1]: *** [FileSetOutput.o] Error 1
make[1]: Leaving directory `/var/tmp/portage/lftp-2.6.1/work/lftp-2.6.1/src'
make: *** [all-recursive] Error 1

!!! ERROR: The ebuild did not complete successfully.
!!! Function src_compile, Line 1, Exitcode 2
!!! compile problem

USE="-apm -arts -cups dga doc guile icc icc-pgo imap mozilla perl \
ruby samba sse tcltk tetex tiff nls"

my ebuild is:
# $Header: /home/cvsroot/gentoo-x86/net-ftp/lftp/lftp-2.6.1.ebuild,v 1.4 
2002/08/15 22:02:14 raker Exp $

The last time I tried to compile was, I think, with gcc3.2pre, (the 0812 
version perhaps?) and it was something like one or two days ago. (Have been 
recompiling like hell lately). But could've been 3.1.1 as well.

cs178057:~$ ls -l /usr/bin/lftp
-rwxr-xr-x    1 root     root       731736 Aug 15 16:57 /usr/bin/lftp*
cs178057:~$ lftp -v
Lftp | Version 2.6.1 | Copyright (c) 1996-2002 Alexander V. Lukyanov

Comment 9 Mauro Sciaccaluga 2002-08-17 09:59:23 UTC
Anti, do you use "DEBUG=true" in your make.conf? tell me. bye
Comment 10 Nick Hadaway 2002-08-25 11:43:32 UTC
I have added sys-devel/gettext to DEPEND instead of just RDEPEND so all LC 
variables are set during compile time.  If anyone is still having trouble 
emerging lftp, please post on this report.  If there are no other errors I will 
close the report in a couple of days.
Comment 11 Bob Koutsky 2002-08-29 03:49:22 UTC
I have another problem with lpftp-2.6.1:

checking stack direction for C alloca... -1
checking whether vsnprintf is declared... yes
checking whether unsetenv is declared... yes
checking for an implementation of va_copy()... no
checking for an implementation of __va_copy()... no
checking whether va_lists can be copied by value... no
checking whether va_lists can be copied by pointer... no
configure: error: Can't find a way to va_copy.

!!! ERROR: The ebuild did not complete successfully.
!!! Function src_compile, Line 16, Exitcode 1
!!! bad ./configure

!!! emerge aborting on  /usr/portage/net-ftp/lftp/lftp-2.6.1.ebuild .

I'm running gcc 2.95.3-r7 and glibc 2.2.5-r5.
Comment 12 Nick Hadaway 2002-08-29 23:36:32 UTC
This looks like a gcc installation problem.  Are you having trouble compiling 
any other programs?

I have tested the compile on a known working system based on gcc-2.95.3-r7 and 
there are no problems.

try this
emerge clean (to clean up old gcc cruft)
emerge lftp

There have been many changes in gcc recently and this compile error looks like 
a problem due to gcc updates.  Let me know if things start working for you.
Comment 13 Nick Hadaway 2002-09-11 11:54:45 UTC
lftp-2.6.2 has been added to portage and should be available within 24 hours.
Here are the comments from the ChangeLog.

  Version bump.  readline history is now stored in a file.
  handle full-disk condition as fatal if the file is removed.
  recursive deletion (rm -r) fixed. It used DELE instead of RMD.
  fixed a rare core dump, usually happening on completion.
  fixed compilation with modules. nls use variable appears to work
  with this version as well.  Undoing temporary forcing of nls.
  Patched configure so adding ssl support doesn't add the dreaded
  -I/usr/include flag.  gcc3 is much happier now. :)

Please test and report back on this bug with your experience.
Comment 14 Bob Koutsky 2002-09-13 18:33:21 UTC
Nick, regarding my "configure: error: Can't find a way to va_copy." problem -
emerge clean did not help. I've even reinstalled gcc, and it is still the same...
Also, lftp-2.6.2 does the same thing.
Comment 15 Nick Hadaway 2002-09-17 17:50:38 UTC
See bug #8013.

Updated configure options so proper socks5 code is linked against (socksdante 
instead of socks5)

The updated ebuild should be available within 24 hours.