Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 645118 - net-nds/openldap should inherit preserve-libs.eclass directly
Summary: net-nds/openldap should inherit preserve-libs.eclass directly
Status: CONFIRMED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: LDAP Herd
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: 645108
  Show dependency tree
 
Reported: 2018-01-20 13:05 UTC by Ulrich Müller
Modified: 2018-01-20 13:05 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Ulrich Müller gentoo-dev 2018-01-20 13:05:20 UTC
The following ebuilds inherit eutils for preserve_old_lib{,_notify}. Since these functions have been split off to preserve-libs.eclass, the following ebuilds should be updated to inherit preserve-libs directly.

   net-nds/openldap-2.4.44
   net-nds/openldap-2.4.44-r1
   net-nds/openldap-2.4.45

Please also check if preserve_old_lib{,_notify} were the only functions for which eutils was needed, in which case it can be dropped.