Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 644296 - net-im/skypeforlinux- list no microphone or speakers
Summary: net-im/skypeforlinux- list no microphone or speakers
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Gino McCarty
Depends on:
Reported: 2018-01-12 10:29 UTC by Andrew Waters
Modified: 2018-10-19 20:33 UTC (History)
2 users (show)

See Also:
Package list:
Runtime testing required: ---


Note You need to log in before you can comment on or make changes to this bug.
Description Andrew Waters 2018-01-12 10:29:39 UTC
Upgrading from which worked to broke skypeforlinux.

I now get no audio devices. The video devices still work. I am using ALSA not pulseaudio.

# emerge -pv skypeforlinux

These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild     U ~] net-im/skypeforlinux- [] USE="-pax_kernel" ABI_X86="(64)" 0 KiB
Comment 1 Andrew Waters 2018-01-12 10:29:54 UTC
# emerge --info
Portage 2.3.13 (python 3.5.4-final-0, default/linux/amd64/17.0/desktop, gcc-7.2.0, glibc-2.26-r5, 4.14.12-gentoo x86_64)
System uname: Linux-4.14.12-gentoo-x86_64-Intel-R-_Core-TM-_i7-3720QM_CPU_@_2.60GHz-with-gentoo-2.4.1
KiB Mem:    16306380 total,    396028 free
KiB Swap:   16777212 total,  16777212 free
Timestamp of repository gentoo: Fri, 12 Jan 2018 05:45:01 +0000
Head commit of repository gentoo: 7593221abf949d6e093b986a2d596e9ddf1a504c
sh bash 4.4_p12
ld GNU ld (Gentoo 2.29.1 p3) 2.29.1
ccache version 3.2.4 [disabled]
app-shells/bash:          4.4_p12::gentoo
dev-java/java-config:     2.2.0-r3::gentoo
dev-lang/perl:            5.24.3::gentoo
dev-lang/python:          2.7.14-r1::gentoo, 3.5.4-r1::gentoo
dev-util/ccache:          3.2.4::gentoo
dev-util/cmake:           3.9.6::gentoo
dev-util/pkgconfig:       0.29.2::gentoo
sys-apps/baselayout:      2.4.1-r2::gentoo
sys-apps/openrc:          0.34.11::gentoo
sys-apps/sandbox:         2.10-r4::gentoo
sys-devel/autoconf:       2.13::gentoo, 2.69-r4::gentoo
sys-devel/automake:       1.11.6-r2::gentoo, 1.15.1-r1::gentoo
sys-devel/binutils:       2.29.1-r1::gentoo
sys-devel/gcc:            6.4.0::gentoo, 7.2.0-r1::gentoo
sys-devel/gcc-config:     1.8-r1::gentoo
sys-devel/libtool:        2.4.6-r3::gentoo
sys-devel/make:           4.2.1::gentoo
sys-kernel/linux-headers: 4.14::gentoo (virtual/os-headers)
sys-libs/glibc:           2.26-r5::gentoo

    location: /usr/portage
    sync-type: rsync
    sync-uri: rsync://
    priority: -1000

CFLAGS="-O2 -pipe -march=native"
CONFIG_PROTECT="/etc /usr/lib64/libreoffice/program/sofficerc /usr/share/gnupg/qualified.txt /usr/share/maven-bin-2.2/conf"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/dconf /etc/env.d /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo"
CXXFLAGS="-O2 -pipe -march=native"
FCFLAGS="-O2 -pipe"
FEATURES="assume-digests binpkg-logs config-protect-if-modified distlocks ebuild-locks fixlafiles merge-sync multilib-strict news parallel-fetch preserve-libs protect-owned sandbox sfperms strict unknown-features-warn unmerge-logs unmerge-orphans userfetch userpriv usersandbox usersync xattr"
FFLAGS="-O2 -pipe"
LDFLAGS="-Wl,-O1 -Wl,--as-needed"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --omit-dir-times --compress --force --whole-file --delete --stats --human-readable --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages --exclude=/.git"
USE="X a52 aac acl acpi aes alsa amd64 apache2 avx berkdb bluetooth branding bzip2 cairo cdda cdr cli consolekit crypt cups cxx dbus dri dts dvd dvdr encode evo exif fam ffmpeg filecaps firefox flac gdbm gif gimp glamor glut gnutls gpm gstreamer gtk iconv icu idn imagemagick ios ipv6 java jpeg jpeg2k lcms ldap libnotify mad mmap mmx mmxext mng modules mp3 mp4 mpeg mtp multilib ncurses nls nptl nsplugin ogg opengl openmp opus pam pango pcre pdf png policykit popcnt posix postscript ppds qt5 quicktime raw rdesktop readline samba sasl sdl seccomp smp spell sqlite sse sse2 sse3 sse4 sse4_1 sse4_2 ssl ssse3 startup-notification subversion svg tcpd theora threads tiff truetype udev udisks unicode upower usb vim-syntax vorbis wavpack win32codecs wmf wxwidgets x264 x265 xattr xcb xcomposite xine xml xpm xscreensaver xv xvid zeroconf zlib zsh-completionix" ABI_X86="64" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" APACHE2_MODULES="authn_core authz_core socache_shmcb unixd actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" CALLIGRA_FEATURES="kexi words flow plan sheets stage tables krita karbon braindump author" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" CPU_FLAGS_X86="aes avx mmx mmxext popcnt sse sse2 sse3 sse4_1 sse4_2 ssse3" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock isync itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf skytraq superstar2 timing tsip tripmate tnt ublox ubx" INPUT_DEVICES="evdev synaptics" KERNEL="linux" L10N="en-GB" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LIBREOFFICE_EXTENSIONS="presenter-console presenter-minimizer" OFFICE_IMPLEMENTATION="libreoffice" PHP_TARGETS="php5-6 php7-0" POSTGRES_TARGETS="postgres9_5" PYTHON_SINGLE_TARGET="python3_5" PYTHON_TARGETS="python2_7 python3_5" RUBY_TARGETS="ruby21 ruby22" USERLAND="GNU" VIDEO_CARDS="nouveau intel" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"
Comment 2 pogosyan 2018-01-15 20:54:55 UTC
(In reply to Andrew Waters from comment #0)
> Upgrading from which worked to broke skypeforlinux.
> I now get no audio devices. The video devices still work. I am using ALSA
> not pulseaudio.

Same here. Pure ALSA system, no pulseaudio.  In no audio devices detected (including USB microphone attached to video camera).  Video devices still work. works OK.
Comment 3 Harris Landgarten 2018-01-16 20:59:16 UTC
I am using pulseaudio.

new version sees speaker and video but microphones do not work. I can list them but they do not work and nothing shows up on the recording tab of pulse volume control. Old version worked fine.
Comment 4 Karol Grudziński 2018-01-30 14:04:16 UTC
Skype without Pulseaudio isn't officially supported since version 4.3, so there is nothing I can do. I don't know either why microphone doesn't work for people using pulseaudio. The truth is SkypeForLinux is a crappy wrapper around SkypeForWeb and I personally don't recommend using it.
You have only two possible solutions:
- Use SkypeForWeb which surprisingly works as expected
- Try new SkypeForLinux version:
Comment 5 Pablo Yanez Trujillo 2018-02-25 00:57:53 UTC
I can confirm that. I installed =net-im/skypeforlinux- after my last uvDN world update. The settings window shows me a "no device found" message, but the funny thing is that I was still able to hear the other person. So skypeforlinux must still be using ALSA.

So I tested SkypeForWeb and I was surprised as how well it functioned. So thanks for the tip.
Comment 6 Andrew Waters 2018-02-26 17:17:35 UTC
The currently released version lists devices.
Comment 7 Gino McCarty 2018-10-19 20:33:56 UTC
99% sure this is a problem with your system and not skypeforlinux in general. Have you had any success with the latest release of skype?
Also ALSA is not supported
lastly, please field this with gentoo support IRC chat, they might help you figure out any lower level video v4l/camera issues your having