Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 643406 - sys-apps/keyutils-1.5.9-r4 stable request
Summary: sys-apps/keyutils-1.5.9-r4 stable request
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Stabilization (show other bugs)
Hardware: All Linux
: High blocker with 1 vote (vote)
Assignee: Robin Johnson
URL:
Whiteboard:
Keywords:
Depends on: 636252
Blocks:
  Show dependency tree
 
Reported: 2018-01-04 12:47 UTC by Pacho Ramos
Modified: 2018-04-18 10:30 UTC (History)
5 users (show)

See Also:
Package list:
sys-apps/keyutils-1.5.9-r4
Runtime testing required: ---
stable-bot: sanity-check+


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Pacho Ramos gentoo-dev 2018-01-04 12:47:32 UTC
This must be done as, currently, stable man-pages ebuild collides with current stable version
Comment 1 Larry the Git Cow gentoo-dev 2018-01-04 15:25:07 UTC
The bug has been referenced in the following commit(s):

https://gitweb.gentoo.org/repo/gentoo.git/commit/?id=e5cb9461345dfc34a1035e7db25822ed9a241e75

commit e5cb9461345dfc34a1035e7db25822ed9a241e75
Author:     Lars Wendler <polynomial-c@gentoo.org>
AuthorDate: 2018-01-04 15:24:41 +0000
Commit:     Lars Wendler <polynomial-c@gentoo.org>
CommitDate: 2018-01-04 15:25:01 +0000

    sys-apps/keyutils: Version 1.5.9-r4 stable for amd64.
    
    Bug: https://bugs.gentoo.org/643406
    Package-Manager: Portage-2.3.19, Repoman-2.3.6

 sys-apps/keyutils/keyutils-1.5.9-r4.ebuild | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)}
Comment 2 Larry the Git Cow gentoo-dev 2018-01-04 15:42:51 UTC
The bug has been referenced in the following commit(s):

https://gitweb.gentoo.org/repo/gentoo.git/commit/?id=7c0e16a86b1c66c927a46f80a1c2e87a64a96e80

commit 7c0e16a86b1c66c927a46f80a1c2e87a64a96e80
Author:     Lars Wendler <polynomial-c@gentoo.org>
AuthorDate: 2018-01-04 15:42:30 +0000
Commit:     Lars Wendler <polynomial-c@gentoo.org>
CommitDate: 2018-01-04 15:42:46 +0000

    sys-apps/keyutils: Version 1.5.9-r4 stable for x86.
    
    Bug: https://bugs.gentoo.org/643406
    Package-Manager: Portage-2.3.19, Repoman-2.3.6

 sys-apps/keyutils/keyutils-1.5.9-r4.ebuild | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)}
Comment 3 Rolf Eike Beer 2018-01-06 11:57:24 UTC
This is worse than before (running on sparc):

[...]
#### It is recommended that this be run as root.
Running with session keyring RHTS/keyctl/11304
Joined session keyring: 1004602825
=== /var/tmp/portage/sys-apps/keyutils-1.5.9-r4/work/keyutils-1.5.9-.sparc32/tests/keyctl/clear/bad-args/test.out ===
+++ Can't Determine Endianness

This works in -r1.
Comment 4 Larry the Git Cow gentoo-dev 2018-01-06 22:21:00 UTC
The bug has been referenced in the following commit(s):

https://gitweb.gentoo.org/repo/gentoo.git/commit/?id=00d57eb00bc359140fa3b2e9bfddab9c89d401a8

commit 00d57eb00bc359140fa3b2e9bfddab9c89d401a8
Author:     Sergei Trofimovich <slyfox@gentoo.org>
AuthorDate: 2018-01-06 22:20:36 +0000
Commit:     Sergei Trofimovich <slyfox@gentoo.org>
CommitDate: 2018-01-06 22:20:54 +0000

    sys-apps/keyutils: tweak endianness check on BE systems, bug #643406
    
    Seen on powerpc and sparc to fail as:
        +++ Can't Determine Endianness
    
    It's caused by missing trailing escape of closing ')' for MSB case.
    
    Reported-by: Rolf Eike Beer
    Bug: https://bugs.gentoo.org/643406
    Package-Manager: Portage-2.3.19, Repoman-2.3.6

 sys-apps/keyutils/files/keyutils-1.5.9-endian-check-2.patch | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)}
Comment 5 Sergei Trofimovich gentoo-dev 2018-01-09 08:10:50 UTC
ppc/ppc64 stable
Comment 6 Sergei Trofimovich gentoo-dev 2018-01-13 12:11:39 UTC
commit 4afefbc65b5ef08c4b5c6a0657e69f921de67d38
Author: Mike Frysinger <vapier@gentoo.org>
Date:   Thu Jan 11 22:31:14 2018 -0500

    sys-apps/keyutils: mark 1.5.9-r4 arm/arm64/ia64/m68k/s390/sh stable
Comment 7 Sergei Trofimovich gentoo-dev 2018-01-28 12:54:11 UTC
commit 5c6d3d5c98e9c0b449afecbf06ffecb76a6ddc2a
Author: Rolf Eike Beer <eike@sf-mail.de>
Date:   Wed Jan 24 21:02:16 2018 +0100

    sys-apps/keyutils: stable 1.5.9-r4 for sparc, bug #643406
Comment 8 Tobias Klausmann gentoo-dev 2018-02-18 12:29:31 UTC
Stable on alpha.
Comment 9 Matt Turner gentoo-dev 2018-03-11 01:13:04 UTC
hppa stable