Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 64337 - linux kernel 2.6.7 and up do not detect the ATI IXP150 chipset even though it's module is loaded
Summary: linux kernel 2.6.7 and up do not detect the ATI IXP150 chipset even though it...
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] Core system (show other bugs)
Hardware: x86 Linux
: High major (vote)
Assignee: Gentoo Kernel Bug Wranglers and Kernel Maintainers
Depends on:
Reported: 2004-09-16 18:47 UTC by ozstriker78
Modified: 2004-09-29 15:01 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Note You need to log in before you can comment on or make changes to this bug.
Description ozstriker78 2004-09-16 18:47:15 UTC
When I boot the 2.6.7 linux kernel with atiixp module, the module does not detect the audio device, however with the same module compiled into the 2.6.5 kernel, everything works fine.  Something broke with this driver sometime between the 2.6.5 kernel and the 2.6.7 kernel.

Reproducible: Always
Steps to Reproduce:
1. emerge to the latest gentoo-dev-sources kernel
2. select the atiixp option under the pci sound card section for ALSA and compile the kernel
3. load the module...the card does not get detected.

Actual Results:  
Advanced Linux Sound Architecture Driver Version 1.0.4 (Mon May 17 14:31:44 2004
atiixp: codec reset timeout
ohci_hcd 0000:00:13.0: suspend root hub
ohci_hcd 0000:00:13.1: suspend root hub
ATI IXP AC97 controller: probe of 0000:00:14.5 failed with error -13
usbcore: registered new driver snd-usb-audio
ALSA device list:
  No soundcards found.

Expected Results:  
I expect to see the sound card listed.
Comment 1 Tim Yamin (RETIRED) gentoo-dev 2004-09-17 08:23:25 UTC
Can you reproduce this with development-sources?
Comment 2 ozstriker78 2004-09-17 10:52:52 UTC
I've recently upgraded my gentoo-dev-sources package to version 2.6.8-gentoo-r4 and I still get the same output.  Did something change in ALSA to break the sound card support for the ATI IXP150?
Comment 3 ozstriker78 2004-09-17 11:00:09 UTC
when I insert the snd_atiixp module I get this output:

atiixp: codec reset timeout
ATI IXP AC97 controller: probe of 0000:00:14.5 failed with error -13

Does that help?
Comment 4 Daniel Drake (RETIRED) gentoo-dev 2004-09-27 14:19:43 UTC
That looks like the problem.
I'd suggest you test with clean 2.6.9-rc2, and if the problem still exists, file a bug at as this appears to be an upstream issue.
Comment 5 ozstriker78 2004-09-29 14:35:05 UTC
it works now....when is the gentoo-dev-sources going to use this version of the kernel?
Comment 6 Daniel Drake (RETIRED) gentoo-dev 2004-09-29 15:01:35 UTC
Shortly after 2.6.9 is officially released.