Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bugzilla DB migration completed. Please report issues to Infra team via email via infra@gentoo.org or IRC
Bug 64289 - mythtv-0.16 ebuild does not recognize Qt built with mysql support or mysql USE variable
Summary: mythtv-0.16 ebuild does not recognize Qt built with mysql support or mysql US...
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] Unspecified (show other bugs)
Hardware: x86 Linux
: High normal (vote)
Assignee: Television related Applications in Gentoo's Portage
URL:
Whiteboard:
Keywords:
Depends on: 2272
Blocks:
  Show dependency tree
 
Reported: 2004-09-16 09:45 UTC by Brett Dikeman
Modified: 2004-09-18 03:20 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Brett Dikeman 2004-09-16 09:45:02 UTC
emerging mythtv-0.16:

# emerge mythtv
Calculating dependencies ...done!
>>> emerge (1 of 1) media-tv/mythtv-0.16 to /
>>> md5 src_uri ;-) mythtv-0.16.tar.bz2
/usr/portage/media-tv/mythtv/mythtv-0.16.ebuild: line 36: /var/db/pkg//USE: No such file or directory
 * Qt is missing MySQL support. Please add
 * 'mysql' to your USE flags, and re-emerge Qt.

!!! ERROR: media-tv/mythtv-0.16 failed.
!!! Function pkg_setup, Line 40, Exitcode 0
!!! Qt needs MySQL support


MySQL is installed, USE contains "mysql" and is uncommented, and Qt built with mysql support (watched the script test for and configure for mysql).  Rebuilt Qt(3.3.3) as well.  No change.

Reproducible: Always
Steps to Reproduce:
1.include mysql in USE
2.build Qt
3.emerge mythtv (note- large # of interdependencies)



System is almost entirely up to date with 86x unstable as of today, though not using release candidate 
of portage (using 2.0.50-r11 instead for the moment).  db4 masked since it hosed another system and 
required an hour of work by revdep-rebuild.  prelink and gcc 3.4.1-r2 in use.
Comment 1 Doug Goldstein gentoo-dev 2004-09-16 17:58:03 UTC
please run emerge info and post that info here. Also run qpkg --dups -v and post any qt output here.
Comment 2 Doug Goldstein gentoo-dev 2004-09-17 22:54:40 UTC
Can't duplicate this error on my end at all. Please provide the requested info above.
Comment 3 Daniel Ahlberg (RETIRED) gentoo-dev 2004-09-18 03:20:27 UTC
Fixed in CVS, thanks!