Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 642568 - net-vpn/miredo doesn't work when default/linux/amd64/17.1/systemd profile is used
Summary: net-vpn/miredo doesn't work when default/linux/amd64/17.1/systemd profile is ...
Status: RESOLVED OBSOLETE
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Michael Weber (RETIRED)
URL:
Whiteboard: Pending removal: 2018-07-17
Keywords: PMASKED
Depends on:
Blocks: no-symlink-lib
  Show dependency tree
 
Reported: 2017-12-28 20:37 UTC by Viktor Levin
Modified: 2019-04-13 02:04 UTC (History)
10 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Viktor Levin 2017-12-28 20:37:20 UTC
net-vpn/miredo doesn't work when default/linux/amd64/17.1/systemd profile is used

Because it installs unit file miredo.service into /usr/lib64/systemd/system/
I think it should be installed to /lib/systemd/system/ instead.

Related bug: https://bugs.gentoo.org/506276
Comment 1 Viktor Levin 2017-12-29 18:00:03 UTC
Probably in miredo-1.2.6/misc/Makefile.in this line

systemddir = $(libdir)/systemd/system

should be replaced with this line

systemddir = /lib/systemd/system
Comment 2 Viktor Levin 2017-12-29 18:55:38 UTC
Temporary fix:

pre_src_install() {
	sed --in-place 's/^systemddir = $(libdir)/systemddir = \/lib/g' \
			"${S}"/misc/Makefile.in
}
Comment 3 V. Talin 2018-01-23 14:25:21 UTC
Please confirm.
Comment 4 Michał Górny archtester Gentoo Infrastructure gentoo-dev Security 2018-06-17 06:28:49 UTC
The correct solution is to use the standard snippet in configure.ac that uses pkg-config to grab that directory and provides option overrides.

That said, the package hasn't seen a release since 2013, upstream activity since 2014, and Gentoo maintainer activity since 2013.  No revdeps.  This bug is open for 6 months already without the maintainer even caring to reply.  Looks like it's time to treeclean it.
Comment 5 Pavel Kozlov 2018-06-17 21:11:50 UTC
This fork https://gitlab.com/rindeal-forks/miredo doesn't look to as dead.
Comment 6 Maciej S. Szmigiero 2018-06-17 21:29:05 UTC
Miredo is nice as a poor man's VPN between two hosts where each one is behind
a separate NAT, without possibility to setup a port forwarding anywhere.

If the only thing that is needed to close this bug is
the four-line fix from comment 2 then it would be a shame
to lose the package over it.

AFAIK even WireGuard (which still requires an out-of-tree kernel module
and has a "You should not rely on this code" note on its webpage) does
not offer such mode of operation.
Comment 7 Jan Chren (rindeal) 2018-06-29 22:22:15 UTC
Fixed it in [1], released as v1.3.1, bumped and updated ebuild in my repository accordingly [2].

[1]: https://gitlab.com/rindeal-forks/miredo/commit/7c651180502ff06649c16e2496d61aaf300f4435
[2]: https://github.com/rindeal/rindeal-ebuild-repo/tree/master/net-vpn/miredo
Comment 8 Viktor Levin 2018-07-10 18:01:13 UTC
(In reply to Maciej S. Szmigiero from comment #6)
> If the only thing that is needed to close this bug is
> the four-line fix from comment 2 then it would be a shame
> to lose the package over it.

Yes, comment #2 fixes net-vpn/miredo-1.2.6 ebuild successfully. It works for me now. Tested in my local overlay.

miredo is a must-have soultion. It is the only zero-cost (free) solution to get IPV6 working for people which have NAT Internet provider with dynamic IPv4.
Comment 9 Eugene Bright 2018-08-07 19:50:16 UTC
+1 for keeping miredo alive.
Voting for fork.

We can use epatch as a temporary solution.
Comment 10 Eugene Bright 2018-08-07 20:35:23 UTC
Victor, your email is dead.
I've tried to CC you in the conversation with remi@remlab.net.

<viklevin2@mail.ru>: host mxs.mail.ru[94.100.180.31] said: 550 Message was not
    accepted -- invalid mailbox.  Local mailbox viklevin2@mail.ru is
    unavailable: account is disabled (in reply to end of DATA command)
Comment 11 Larry the Git Cow gentoo-dev 2018-09-13 16:22:33 UTC
The bug has been referenced in the following commit(s):

https://gitweb.gentoo.org/repo/gentoo.git/commit/?id=528ab771abdd0d7d44ce80f970bb601ae3f927a8

commit 528ab771abdd0d7d44ce80f970bb601ae3f927a8
Author:     Michał Górny <mgorny@gentoo.org>
AuthorDate: 2018-09-13 16:21:46 +0000
Commit:     Michał Górny <mgorny@gentoo.org>
CommitDate: 2018-09-13 16:22:10 +0000

    net-vpn/miredo: Remove last-rited pkg
    
    Bug: https://bugs.gentoo.org/642568

 net-vpn/miredo/Manifest                            |  2 -
 .../files/miredo-1.2.5-configure-libcap.diff       | 33 ------------
 net-vpn/miredo/files/miredo-1.2.5-ip-path.patch    | 28 ----------
 net-vpn/miredo/files/miredo.conf.2                 |  2 -
 net-vpn/miredo/files/miredo.rc.2                   | 13 -----
 net-vpn/miredo/metadata.xml                        | 14 -----
 net-vpn/miredo/miredo-1.2.5-r2.ebuild              | 60 ----------------------
 net-vpn/miredo/miredo-1.2.6.ebuild                 | 60 ----------------------
 profiles/package.mask                              |  5 --
 profiles/updates/1Q-2017                           |  1 -
 10 files changed, 218 deletions(-)