Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 641934 - sys-apps/dbus depends on autoconf-archive and xmlto
Summary: sys-apps/dbus depends on autoconf-archive and xmlto
Status: RESOLVED CANTFIX
Alias: None
Product: Gentoo/Alt
Classification: Unclassified
Component: Other (show other bugs)
Hardware: All Linux
: Normal minor (vote)
Assignee: Freedesktop bugs
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2017-12-21 14:17 UTC by Emmanuel Lepage Vallee
Modified: 2017-12-22 04:27 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Emmanuel Lepage Vallee 2017-12-21 14:17:58 UTC
I found this while bootstrapping a new system using corssdev. It's not related to cross compilation, it's really a missing dependency (see the freedesktop thread)

***** autoconf *****
***** PWD: /usr/armv7a-hardfloat-linux-gnueabi/tmp/portage/sys-apps/dbus-1.12.2/work/dbus-1.12.2
***** autoconf --force -I /usr/armv7a-hardfloat-linux-gnueabi/usr/share/aclocal

configure.ac:95: error: Unexpanded AX_ macro found. Please install GNU autoconf-archive
      If this token and others are legitimate, please use m4_pattern_allow.
      See the Autoconf documentation.
configure.ac:375: error: Unexpanded AX_ macro found. Please install GNU autoconf-archive
configure.ac:1291: error: Unexpanded AX_ macro found. Please install GNU autoconf-archive
configure.ac:1296: error: Unexpanded AX_ macro found. Please install GNU autoconf-archive
configure.ac:1305: error: Unexpanded AX_ macro found. Please install GNU autoconf-archive
configure.ac:1311: error: Unexpanded AX_ macro found. Please install GNU autoconf-archive

Reference: https://bugs.freedesktop.org/show_bug.cgi?id=98093

Note that adding `--root-deps` does solve the problem, but doc do depend on `xmlto` and all of dbus directly depend on autoconf-archive so they should be added to the ebuild
Comment 1 Lars Wendler (Polynomial-C) gentoo-dev 2017-12-21 15:12:21 UTC
$ grep -HE "(autoconf-archive|xmlto)" dbus*.ebuild
dbus-1.10.18.ebuild:    app-text/xmlto
dbus-1.10.24.ebuild:    app-text/xmlto
dbus-1.12.0.ebuild:     app-text/xmlto
dbus-1.12.0.ebuild:     sys-devel/autoconf-archive
dbus-1.12.2.ebuild:     app-text/xmlto
dbus-1.12.2.ebuild:     sys-devel/autoconf-archive

I'm not sure I understand your bug report. dbus-1.10.x have xmlto in DEPEND and dbus-1.12.x also have autoconf-archive in DEPEND.
Comment 2 Emmanuel Lepage Vallee 2017-12-22 03:52:19 UTC
Umm, seems like you are right, this is due to crossdev emerge itself, `xmlto` have to be installed in both the host and the target for dbus to be installed.

As for autoconf-archive, crossdev emerge does not install it unless --root-deps is specified, I am not sure in which component the issue is.

Changing product to gentoo/alt
Comment 3 Mike Gilbert gentoo-dev 2017-12-22 04:27:34 UTC
It's not a "Gentoo/Alt" issue; it's a consequence of the half-baked cross-compile support in portage. It might be fixed in some future EAPI.