Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 641848 - sys-process/htop-2.0.2 - configure: error: The pkg-config script could not be found or is too old.
Summary: sys-process/htop-2.0.2 - configure: error: The pkg-config script could not be...
Status: RESOLVED NEEDINFO
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Christian Ruppert (idl0r)
URL:
Whiteboard:
Keywords:
: 631104 (view as bug list)
Depends on:
Blocks:
 
Reported: 2017-12-20 21:16 UTC by cryptopsy
Modified: 2021-10-15 04:15 UTC (History)
3 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
sys-process:htop-2.0.2:20171220-230647.log (sys-process:htop-2.0.2:20171220-230647.log,8.53 KB, text/plain)
2017-12-20 21:16 UTC, cryptopsy
Details
emerge --info (info,3.23 KB, text/plain)
2017-12-20 21:17 UTC, cryptopsy
Details
sys-process:htop-2.0.2:20171221-003243.log without -flto (sys-process:htop-2.0.2:20171221-003243.log,8.53 KB, text/plain)
2017-12-21 09:40 UTC, cryptopsy
Details
config.log (config.log,40.02 KB, text/plain)
2017-12-23 14:06 UTC, cryptopsy
Details

Note You need to log in before you can comment on or make changes to this bug.
Description cryptopsy 2017-12-20 21:16:26 UTC
Created attachment 511254 [details]
sys-process:htop-2.0.2:20171220-230647.log

configure: error: in `/tmp/.portage/portage/sys-process/htop-2.0.2/work/htop-2.0.2':
configure: error: The pkg-config script could not be found or is too old.  Make sure it
is in your PATH or set the PKG_CONFIG environment variable to the full
Comment 1 cryptopsy 2017-12-20 21:17:53 UTC
Created attachment 511256 [details]
emerge --info
Comment 2 cryptopsy 2017-12-21 09:40:04 UTC
Created attachment 511356 [details]
sys-process:htop-2.0.2:20171221-003243.log without -flto

Fails when -flto is removed too.
Comment 3 Jeroen Roovers (RETIRED) gentoo-dev 2017-12-22 17:05:31 UTC
Comment on attachment 511254 [details]
sys-process:htop-2.0.2:20171220-230647.log

!!! Please attach the following file when seeking support:
!!! /tmp/.portage/portage/sys-process/htop-2.0.2/work/htop-2.0.2/config.log

Where is it?
Comment 4 cryptopsy 2017-12-23 14:06:36 UTC
Created attachment 511544 [details]
config.log
Comment 5 Ben Kohler gentoo-dev 2018-03-01 14:36:34 UTC
*** Bug 631104 has been marked as a duplicate of this bug. ***
Comment 6 Lars Wendler (Polynomial-C) gentoo-dev 2019-04-29 15:43:48 UTC
Still an issue with latest htop release?