Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 641832 - sys-kernel/gentoo-sources-4.14.8-r1 stabilization request
Summary: sys-kernel/gentoo-sources-4.14.8-r1 stabilization request
Status: RESOLVED INVALID
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Stabilization (show other bugs)
Hardware: All Linux
: Normal critical (vote)
Assignee: Gentoo Kernel Bug Wranglers and Kernel Maintainers
URL:
Whiteboard:
Keywords: STABLEREQ
Depends on: 642022
Blocks: 641818
  Show dependency tree
 
Reported: 2017-12-20 18:09 UTC by Alice Ferrazzi
Modified: 2018-07-28 17:35 UTC (History)
3 users (show)

See Also:
Package list:
=sys-kernel/gentoo-sources-4.14.8-r1
Runtime testing required: ---
stable-bot: sanity-check+


Attachments
The boot screen of gentoo-sources-4.14.8-gentoo-r1 (gentoo-sources-4.14.8-gentoo-r1.jpg,598.35 KB, image/jpeg)
2017-12-24 05:17 UTC, crocket
no flags Details
My kernel .config (config-4.14.8-gentoo-r1,97.00 KB, text/plain)
2017-12-24 05:19 UTC, crocket
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Alice Ferrazzi Gentoo Infrastructure gentoo-dev 2017-12-20 18:09:46 UTC
Arches, please stabilize gentoo-sources-4.14.8-r1.

This revision is fixing a critical bug on e1000e https://bugs.gentoo.org/641818 

Reproducible: Always
Comment 1 Alice Ferrazzi Gentoo Infrastructure gentoo-dev 2017-12-20 18:43:54 UTC
amd64 stable
Comment 2 Mike Pagano gentoo-dev 2017-12-20 20:51:45 UTC
x86 stable
Comment 3 Jeroen Roovers gentoo-dev 2017-12-21 14:58:23 UTC
(In reply to Alice Ferrazzi from comment #0)
> Arches, please stabilize gentoo-sources-4.14.8-r1.
> 
> This revision is fixing a critical bug on e1000e
> https://bugs.gentoo.org/641818 

Over there you said "removed 4.14.{4,5,6,7,8} affected by the regression".
Comment 4 Alice Ferrazzi Gentoo Infrastructure gentoo-dev 2017-12-22 08:03:25 UTC
this is 4.14.8-r1 not 4.14.8

4.14.8-r1 is not affected by the regression.
Comment 5 Sergei Trofimovich gentoo-dev 2017-12-23 20:52:39 UTC
ia64 stable
ppc64 stable (thanks to ernsteiswuerfel)
Comment 6 Sergei Trofimovich gentoo-dev 2017-12-23 21:52:21 UTC
sparc stable (thanks to Rolf Eike Beer)
Comment 7 crocket 2017-12-24 04:56:43 UTC
After upgrading gentoo-sources to 4.14.8-gentoo-r1, the booting screen became a color similar to white. How can I fix this?
Comment 8 crocket 2017-12-24 05:17:06 UTC
Created attachment 511560 [details]
The boot screen of gentoo-sources-4.14.8-gentoo-r1
Comment 9 crocket 2017-12-24 05:19:47 UTC
Created attachment 511562 [details]
My kernel .config

The graphics card is Radeon HD 6450.
Comment 10 crocket 2017-12-26 06:43:00 UTC
I reported my issue to https://bugzilla.kernel.org/show_bug.cgi?id=198273
Comment 11 Sébastien P. 2017-12-30 09:33:02 UTC
Hmm! What is the matter with this kernel?

https://gitweb.gentoo.org/repo/gentoo.git/commit/sys-kernel/gentoo-sources/gentoo-sources-4.14.8-r1.ebuild?id=1abd5ecf4d885f6607a413c59d374d6f088d9727
=> I do not find any bug about that… and the keywords have been removed.
Comment 13 Alice Ferrazzi Gentoo Infrastructure gentoo-dev 2017-12-30 10:13:09 UTC
https://archives.gentoo.org/gentoo-dev/message/9c22a5fa560d77fb7cd58e09d046924d
Since there are problems related to 4.14.x kernel we are dropping stable keywords :

- IPSec is broken [2]

- Change in 4.14.9 broke nVIDIA driver [3]

- Colors on console are broken with some Radeon HD cards [4]

- BUG report on boot [5]

- Unbootable system with CONFIG_MCORE2 [6]

- ...more bugs [7]

[1] https://bugs.gentoo.org/641818

[2] https://bugs.gentoo.org/642454

[3] http://lkml.iu.edu/hypermail/linux/kernel/1712.3/00099.html

[4] https://bugzilla.kernel.org/show_bug.cgi?id=198273

[5] https://lkml.org/lkml/2017/12/25/177

[6] https://bugs.gentoo.org/642268

[7] https://bugzilla.kernel.org/buglist.cgi?bug_status=NEW&bug_status=ASSIGNED&bug_status=REOPENED&f1=cf_kernel_version&o1=equals&query_format=advanced&v1=4.14.8