Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 641774 - sys-kernel/genkernel-3.5.3.3 Stable Request
Summary: sys-kernel/genkernel-3.5.3.3 Stable Request
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Stabilization (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Gentoo Genkernel Maintainers
URL:
Whiteboard:
Keywords: STABLEREQ
: 658252 (view as bug list)
Depends on: 631368 635768 639034
Blocks: 658032
  Show dependency tree
 
Reported: 2017-12-19 23:32 UTC by Brian Evans
Modified: 2019-07-17 08:27 UTC (History)
5 users (show)

See Also:
Package list:
sys-kernel/genkernel-3.5.3.3
Runtime testing required: Yes
stable-bot: sanity-check+


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Brian Evans Gentoo Infrastructure gentoo-dev 2017-12-19 23:32:28 UTC
Due to the stable of gentoo-sources-4.14.7, having the kernel setting CONFIG_FIRMWARE_IN_KERNEL unset will break genkernel since the operation is no longer available.

Please stable sys-kernel/genkernel 3.5.2.4 (or later at your option) when ready.
Comment 1 Ben Kohler gentoo-dev 2018-04-15 13:36:01 UTC
With 3.5.3.2 fixing the regression from bug 505810 (not completely resolved but no worse than current 3.4), can we target this for stable?
Comment 2 Pacho Ramos gentoo-dev 2018-05-28 13:54:37 UTC
we can then try latest, right?
Comment 3 Aaron Bauman Gentoo Infrastructure gentoo-dev Security 2018-06-13 12:20:33 UTC
@arches, please stabilize.
Comment 4 Larry the Git Cow gentoo-dev 2018-06-15 09:35:15 UTC
The bug has been referenced in the following commit(s):

https://gitweb.gentoo.org/repo/gentoo.git/commit/?id=35fd5f9ee70521a8480ec9be50db4e25b45d2f5a

commit 35fd5f9ee70521a8480ec9be50db4e25b45d2f5a
Author:     Sergei Trofimovich <slyfox@gentoo.org>
AuthorDate: 2018-06-15 09:34:25 +0000
Commit:     Sergei Trofimovich <slyfox@gentoo.org>
CommitDate: 2018-06-15 09:34:25 +0000

    sys-kernel/genkernel: stable 3.5.3.3 for ia64, bug #641774
    
    Bug: https://bugs.gentoo.org/641774
    Package-Manager: Portage-2.3.40, Repoman-2.3.9
    RepoMan-Options: --include-arches="ia64"

 sys-kernel/genkernel/genkernel-3.5.3.3.ebuild | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)
Comment 5 Mikle Kolyada archtester Gentoo Infrastructure gentoo-dev Security 2018-06-16 15:02:00 UTC
amd64 stable
Comment 6 Ben Kohler gentoo-dev 2018-06-16 23:38:00 UTC
*** Bug 658252 has been marked as a duplicate of this bug. ***
Comment 7 Thomas Deutschmann gentoo-dev 2018-06-17 23:30:28 UTC
x86 stable
Comment 8 Larry the Git Cow gentoo-dev 2018-06-19 19:13:08 UTC
The bug has been referenced in the following commit(s):

https://gitweb.gentoo.org/repo/gentoo.git/commit/?id=3af5daf6399fa19c41fe403037b5cd818933eada

commit 3af5daf6399fa19c41fe403037b5cd818933eada
Author:     Rolf Eike Beer <eike@sf-mail.de>
AuthorDate: 2018-06-19 15:10:08 +0000
Commit:     Sergei Trofimovich <slyfox@gentoo.org>
CommitDate: 2018-06-19 19:12:43 +0000

    sys-kernel/genkernel: stable 3.5.3.3 for sparc
    
    Bug: https://bugs.gentoo.org/641774
    Package-Manager: Portage-2.3.40, Repoman-2.3.9
    RepoMan-Options: --include-arches="sparc"

 sys-kernel/genkernel/genkernel-3.5.3.3.ebuild | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)
Comment 9 Tobias Klausmann (RETIRED) gentoo-dev 2018-06-21 07:28:17 UTC
Stable on alpha.
Comment 10 Mikle Kolyada archtester Gentoo Infrastructure gentoo-dev Security 2018-06-26 15:53:57 UTC
arm stable
Comment 11 Mikle Kolyada archtester Gentoo Infrastructure gentoo-dev Security 2018-06-30 20:36:36 UTC
s390 stable
Comment 12 Sergei Trofimovich (RETIRED) gentoo-dev 2018-07-29 16:26:57 UTC
ppc64 stable
Comment 13 Sergei Trofimovich (RETIRED) gentoo-dev 2018-08-18 22:50:50 UTC
ppc stable
Comment 14 Mikle Kolyada archtester Gentoo Infrastructure gentoo-dev Security 2018-09-16 18:13:47 UTC
sh stable