Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bugzilla DB migration completed. Please report issues to Infra team via email via infra@gentoo.org or IRC
Bug 641428 - dev-cpp/pficommon-1.3.1.0: statement.cpp:51:33: error: expected constructor, destruct or, or type conversion before ‘(’ token
Summary: dev-cpp/pficommon-1.3.1.0: statement.cpp:51:33: error: expected constructor, ...
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Naohiro Aota
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2017-12-17 03:24 UTC by OKUMURA N. Shin-ya
Modified: 2018-01-26 23:31 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
A tentative patch for C++11's std::shared_ptr compliance (pficommon-1.3.1.0-cpp11.patch,1.78 KB, patch)
2017-12-17 03:27 UTC, OKUMURA N. Shin-ya
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description OKUMURA N. Shin-ya 2017-12-17 03:24:53 UTC
dev-cpp/pficommon-1.3.1.0 (with database and g++-6.4.0) fails to build.
It seems to be caused by default option of g++-6.4.0, "-std=gnu++14", and the collisions between std::shared_ptr and pfi::lang::shared_ptr.

Reproducible: Always

Steps to Reproduce:
1. USE=postgres emerge =dev-cpp/pficommon-1.3.1.0

(I've not tested yet but "USE=mysql" probably fails also.)
Actual Results:  
Build fails as follows;

../src/database/mysql/statement.cpp:51:33: error: expected constructor, destruct
or, or type conversion before ‘(’ token
... (snip) ...
../src/database/mysql/statement.cpp:210:1: error: expected ‘}’ at end of input
 } // pfi


Expected Results:  
Build success. ;-p

A tentative is explicit declaration of pfi::lang::shared_ptr.
I've tested it, successfully build, but not perfectly confirmed to work fine.
Comment 1 OKUMURA N. Shin-ya 2017-12-17 03:27:46 UTC
Created attachment 510410 [details, diff]
A tentative patch for C++11's std::shared_ptr compliance
Comment 2 Larry the Git Cow gentoo-dev 2018-01-26 23:31:47 UTC
The bug has been closed via the following commit(s):

https://gitweb.gentoo.org/repo/gentoo.git/commit/?id=ebc2e81a53bd9d7af6da1a9abdd067f6e847b71d

commit ebc2e81a53bd9d7af6da1a9abdd067f6e847b71d
Author:     Mikle Kolyada <zlogene@gentoo.org>
AuthorDate: 2018-01-26 23:26:45 +0000
Commit:     Mikle Kolyada <zlogene@gentoo.org>
CommitDate: 2018-01-26 23:31:31 +0000

    dev-cpp/pficommon: remove last rited package
    
    Closes: https://bugs.gentoo.org/514400
    Closes: https://bugs.gentoo.org/596078
    Closes: https://bugs.gentoo.org/598609
    Closes: https://bugs.gentoo.org/640096
    Closes: https://bugs.gentoo.org/641428

 dev-cpp/pficommon/Manifest                         |   1 -
 .../files/pficommon-1.3.1.0-gcc-4.7.patch          |  50 ---
 .../pficommon/files/pficommon-1.3.1.0-gcc6.patch   | 350 ---------------------
 .../pficommon/files/pficommon-1.3.1.0-libdir.patch |  49 ---
 .../files/pficommon-1.3.1.0-postgresql.patch       |  13 -
 .../pficommon/files/pficommon-1.3.1.0-soname.patch | 200 ------------
 dev-cpp/pficommon/metadata.xml                     |  14 -
 dev-cpp/pficommon/pficommon-1.3.1.0.ebuild         |  58 ----
 8 files changed, 735 deletions(-)