Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 641108 - dev-db/sqlite-3.21.0 stabilization
Summary: dev-db/sqlite-3.21.0 stabilization
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Stabilization (show other bugs)
Hardware: All All
: Normal normal (vote)
Assignee: Arfrever Frehtes Taifersar Arahesis
URL:
Whiteboard:
Keywords: STABLEREQ
Depends on: 648346
Blocks:
  Show dependency tree
 
Reported: 2017-12-15 09:00 UTC by charles17
Modified: 2018-03-08 23:44 UTC (History)
1 user (show)

See Also:
Package list:
dev-db/sqlite-3.21.0
Runtime testing required: ---
stable-bot: sanity-check+


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description charles17 2017-12-15 09:00:11 UTC
Please stabilize dev-db/sqlite-3.21.0
Comment 1 Pacho Ramos gentoo-dev 2018-02-12 13:12:13 UTC
any problem with CCing arches finally on this?
Comment 2 Sergei Trofimovich gentoo-dev 2018-02-18 08:36:35 UTC
ia64 stable
Comment 3 George L. Emigh 2018-02-22 21:26:40 UTC
DBD-SQLite won't have it...


WARNING: One or more updates/rebuilds have been skipped due to a dependency conflict:

dev-db/sqlite:3

  (dev-db/sqlite-3.21.0:3/3::gentoo, ebuild scheduled for merge) conflicts with
    <dev-db/sqlite-3.21.0 required by (dev-perl/DBD-SQLite-1.540.0-r1:0/0::gentoo, installed)
Comment 4 Mart Raudsepp gentoo-dev 2018-03-02 21:56:43 UTC
arm64 stable (fts3expr5 and all other tests passed fine, no idea what fts3expr5-1.5 with the -1.5 ending is)
Comment 5 Larry the Git Cow gentoo-dev 2018-03-03 01:58:50 UTC
The bug has been referenced in the following commit(s):

https://gitweb.gentoo.org/repo/gentoo.git/commit/?id=1e3aadf18792bd10d5577b971994641467258458

commit 1e3aadf18792bd10d5577b971994641467258458
Author:     Kent Fredric <kentnl@gentoo.org>
AuthorDate: 2018-03-03 01:53:25 +0000
Commit:     Kent Fredric <kentnl@gentoo.org>
CommitDate: 2018-03-03 01:57:33 +0000

    profiles: package.use.stable.mask dev-perl/DBD-SQLite[system-sqlite]
    
    - Using versions of system sqlite other than the one DBD-SQLite ships
     with causes regular issues that challenge the ability for tis package
     to have a meaning stability status
    - Restricting system sqlite versions to solve the above problem causes
     significant impediments to stabilizing sqlite. ( DBD-SQLites release
     cycle is somewhat behind that of SQLites )
    
    Bug: https://bugs.gentoo.org/641108
    Bug: https://bugs.gentoo.org/649408
    Bug: https://bugs.gentoo.org/640724

 profiles/base/package.use.stable.mask | 6 ++++++
 1 file changed, 6 insertions(+)}
Comment 6 Arfrever Frehtes Taifersar Arahesis 2018-03-08 20:01:12 UTC
dev-db/sqlite-3.22.0 will be stabilized in bug #649954.