Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 640258 - dev-util/valkyrie depends on deprecated Qt4
Summary: dev-util/valkyrie depends on deprecated Qt4
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Michael Weber (RETIRED)
URL:
Whiteboard: removal on 2018-06-09
Keywords: PMASKED
Depends on:
Blocks: qt4-removal qt4-r2-removal
  Show dependency tree
 
Reported: 2017-12-08 13:45 UTC by Harri Nieminen (Moiman)
Modified: 2018-06-08 20:55 UTC (History)
1 user (show)

See Also:
Package list:
dev-util/valkyrie-2.0.0-r1
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Harri Nieminen (Moiman) 2017-12-08 13:45:57 UTC
Last release is from 21 October 2010 and last upstream commit is from 2011-07-03.
Depends on Qt4 and uses EAPI3.
Comment 1 Michael Weber (RETIRED) gentoo-dev 2017-12-08 17:29:17 UTC
Bumped to EAPI=5.
Comment 2 Michael Weber (RETIRED) gentoo-dev 2017-12-08 17:31:57 UTC
@arches: please stabilize dev-util/valkyrie-2.0.0-r1
Comment 3 Thomas Deutschmann gentoo-dev Security 2017-12-08 21:59:58 UTC
x86 stable
Comment 4 Andreas Sturmlechner gentoo-dev 2017-12-09 18:18:33 UTC
Still depends on Qt4, right?
Comment 5 Andreas Sturmlechner gentoo-dev 2017-12-09 18:25:21 UTC
You could have bumped to EAPI 5 without revision. Only EAPI-6 would have been worth another stabilisation...
Comment 6 Michael Weber (RETIRED) gentoo-dev 2017-12-10 15:24:46 UTC
(In reply to Andreas Sturmlechner from comment #5)
> You could have bumped to EAPI 5 without revision. Only EAPI-6 would have
> been worth another stabilisation...

I don't change stable ebuild.
Comment 7 Mikle Kolyada archtester Gentoo Infrastructure gentoo-dev Security 2017-12-17 16:06:58 UTC
amd64 stable and old  revision is gone.
Comment 8 Harri Nieminen (Moiman) 2017-12-17 16:10:38 UTC
It still depends on Qt4
Comment 9 Andreas Sturmlechner gentoo-dev 2018-02-27 23:14:08 UTC
@Michael: ping, what about the new tarball that is available?
Comment 10 Andreas Sturmlechner gentoo-dev 2018-05-01 08:06:52 UTC
ping...
Comment 11 Mikle Kolyada archtester Gentoo Infrastructure gentoo-dev Security 2018-05-07 22:40:08 UTC
(In reply to Andreas Sturmlechner from comment #10)
> ping...

no matter, the latest releas is from 2010, nobody gonna port it to 5 it seems.
Comment 12 Larry the Git Cow gentoo-dev 2018-05-10 09:06:07 UTC
The bug has been referenced in the following commit(s):

https://gitweb.gentoo.org/repo/gentoo.git/commit/?id=dfc602282e6f097a9b46996658d0004f9f6802da

commit dfc602282e6f097a9b46996658d0004f9f6802da
Author:     Andreas Sturmlechner <asturm@gentoo.org>
AuthorDate: 2018-05-10 09:01:12 +0000
Commit:     Andreas Sturmlechner <asturm@gentoo.org>
CommitDate: 2018-05-10 09:05:24 +0000

    profiles: Mask dev-util/valkyrie for removal
    
    Bug: https://bugs.gentoo.org/640258

 profiles/package.mask | 5 +++++
 1 file changed, 5 insertions(+)
Comment 13 Larry the Git Cow gentoo-dev 2018-06-08 20:55:38 UTC
The bug has been closed via the following commit(s):

https://gitweb.gentoo.org/repo/gentoo.git/commit/?id=bb18cb8cc3b74d2916d5bf5aaaf7d76916e64e2f

commit bb18cb8cc3b74d2916d5bf5aaaf7d76916e64e2f
Author:     Andreas Sturmlechner <asturm@gentoo.org>
AuthorDate: 2018-06-02 11:30:08 +0000
Commit:     Andreas Sturmlechner <asturm@gentoo.org>
CommitDate: 2018-06-08 20:55:10 +0000

    dev-util/valkyrie: Remove last-rited package
    
    Closes: https://bugs.gentoo.org/640258

 dev-util/valkyrie/Manifest                         |  1 -
 dev-util/valkyrie/files/valkyrie-2.0.0-gcc47.patch | 37 ----------------------
 .../valkyrie/files/valkyrie-2.0.0-prefix.patch     | 11 -------
 dev-util/valkyrie/metadata.xml                     |  8 -----
 dev-util/valkyrie/valkyrie-2.0.0-r1.ebuild         | 26 ---------------
 profiles/package.mask                              |  5 ---
 6 files changed, 88 deletions(-)