Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 639276 - dev-python/matplotlib with dev-lang/python-3.5 - Fatal Error: Mismatch between the program and library build versions detected. The library used 3.0 (wchar_t,compiler with C++ ABI 1010,wx containers,compatible with 2.8), and wxPython used 3.0 (wchar_t,com
Summary: dev-python/matplotlib with dev-lang/python-3.5 - Fatal Error: Mismatch betwee...
Status: UNCONFIRMED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal with 1 vote (vote)
Assignee: Gentoo wxWidgets Herd
URL:
Whiteboard:
Keywords:
: 648688 663358 664142 666118 675080 676218 (view as bug list)
Depends on: 691936
Blocks:
  Show dependency tree
 
Reported: 2017-11-30 10:38 UTC by Till Schäfer
Modified: 2019-08-11 14:11 UTC (History)
17 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
build.log (build.log,6.59 KB, text/plain)
2017-11-30 10:38 UTC, Till Schäfer
Details
build.log version 2.1.0-r1 (build.log,6.05 KB, text/plain)
2017-11-30 13:43 UTC, Till Schäfer
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Till Schäfer 2017-11-30 10:38:06 UTC
Created attachment 507262 [details]
build.log

* ERROR: dev-python/matplotlib-1.5.3-r2::gentoo failed (compile phase):
 *   (no error message)
 * 
 * Call stack:
 *     ebuild.sh, line  124:  Called src_compile
 *   environment, line 4306:  Called distutils-r1_src_compile
 *   environment, line 1250:  Called _distutils-r1_run_foreach_impl 'python_compile'
 *   environment, line  447:  Called python_foreach_impl 'distutils-r1_run_phase' 'python_compile'
 *   environment, line 3740:  Called multibuild_foreach_variant '_python_multibuild_wrapper' 'distutils-r1_run_phase' 'python_compile'
 *   environment, line 2758:  Called _multibuild_run '_python_multibuild_wrapper' 'distutils-r1_run_phase' 'python_compile'
 *   environment, line 2756:  Called _python_multibuild_wrapper 'distutils-r1_run_phase' 'python_compile'
 *   environment, line  813:  Called distutils-r1_run_phase 'python_compile'
 *   environment, line 1243:  Called python_compile
 *   environment, line 3269:  Called wrap_setup 'distutils-r1_python_compile'
 *   environment, line 5168:  Called distutils-r1_python_compile 'build' '--build-lib=/var/tmp/portage/dev-python/matplotlib-1.5.3-r2/work/matplotlib-1.5.3-python2_7/build/build/lib'
 *   environment, line 1118:  Called esetup.py 'build' 'build' '--build-lib=/var/tmp/portage/dev-python/matplotlib-1.5.3-r2/work/matplotlib-1.5.3-python2_7/build/build/lib'
 *   environment, line 1803:  Called die
 * The specific snippet of code:
 *       "${@}" || die "${die_args[@]}";




# emerge --info =dev-python/matplotlib-1.5.3-r2::gentoo                                                                                                                   
Portage 2.3.13 (python 2.7.14-final-0, default/linux/amd64/13.0/desktop/plasma, gcc-6.4.0, glibc-2.25-r9, 4.12.12-gentoo x86_64)                                                   
=================================================================                                                                                                                  
                         System Settings                                                                                                                                           
=================================================================                                                                                                                  
System uname: Linux-4.12.12-gentoo-x86_64-Intel-R-_Core-TM-_i7-3770_CPU_@_3.40GHz-with-gentoo-2.4.1                                                                                
KiB Mem:    15954708 total,   3308252 free                                                                                                                                         
KiB Swap:   16801788 total,  16801788 free                                                                                                                                         
Timestamp of repository gentoo: Wed, 29 Nov 2017 11:02:46 +0000                                                                                                                    
Head commit of repository gentoo: 207be22ebada2cdd5ea9db14f49bc7f46625561a                                                                                                         
                                                                                                                                                                                   
sh bash 4.3_p48-r1                                                                                                                                                                 
ld GNU ld (Gentoo 2.28.1 p1.0) 2.28.1                                                                                                                                              
app-shells/bash:          4.3_p48-r1::gentoo                                                                                                                                       
dev-java/java-config:     2.2.0-r3::gentoo                                                                                                                                         
dev-lang/perl:            5.24.3::gentoo                                                                                                                                           
dev-lang/python:          2.7.14::gentoo, 3.4.5::gentoo, 3.5.4::gentoo                                                                                                             
dev-util/cmake:           3.8.2::gentoo                                                                                                                                            
dev-util/pkgconfig:       0.29.2::gentoo                                                                                                                                           
sys-apps/baselayout:      2.4.1-r2::gentoo                                                                                                                                         
sys-apps/openrc:          0.34.10::gentoo                                                                                                                                          
sys-apps/sandbox:         2.10-r4::gentoo                                                                                                                                          
sys-devel/autoconf:       2.13::gentoo, 2.69::gentoo                                                                                                                               
sys-devel/automake:       1.11.6-r2::gentoo, 1.15.1-r1::gentoo
sys-devel/binutils:       2.28.1::gentoo, 2.29.1-r1::gentoo
sys-devel/gcc:            5.4.0-r3::gentoo, 6.4.0::gentoo
sys-devel/gcc-config:     1.8-r1::gentoo
sys-devel/libtool:        2.4.6-r3::gentoo
sys-devel/make:           4.2.1::gentoo
sys-kernel/linux-headers: 4.4::gentoo (virtual/os-headers)
sys-libs/glibc:           2.25-r9::gentoo
Repositories:

gentoo
    location: /usr/portage
    sync-type: git
    sync-uri: https://github.com/gentoo-mirror/gentoo.git
    priority: -1000

local
    location: /usr/local/portage
    masters: gentoo
    priority: 1000

Installed sets: @system
ACCEPT_KEYWORDS="amd64"
ACCEPT_LICENSE="*"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-march=native -O2 -pipe -ggdb"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/lib64/libreoffice/program/sofficerc /usr/share/config /usr/share/gnupg/qualified.txt /usr/share/maven-bin-3.3/conf"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/dconf /etc/env.d /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/portage/package.accept_keywords/zz_autounmask /etc/portage/package.unmask/zz_autounmask /etc/portage/package.use/zz_autounmask /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo /etc/texmf/language.dat.d /etc/texmf/language.def.d /etc/texmf/updmap.d /etc/texmf/web2c"
CXXFLAGS="-march=native -O2 -pipe -ggdb"
DISTDIR="/usr/portage/distfiles"
EMERGE_DEFAULT_OPTS="--with-bdeps=y --autounmask-write --autounmask-continue --jobs=5 --load-average=2.0"
FCFLAGS="-O2 -pipe"
FEATURES="assume-digests binpkg-logs compressdebug config-protect-if-modified distlocks ebuild-locks fixlafiles merge-sync multilib-strict news parallel-fetch parallel-install preserve-libs protect-owned sandbox sfperms splitdebug strict unknown-features-warn unmerge-logs unmerge-orphans userfetch userpriv usersandbox usersync xattr"
FFLAGS="-O2 -pipe"
GENTOO_MIRRORS="http://distfiles.gentoo.org"
LANG="en_US.utf8"
LDFLAGS="-Wl,-O1 -Wl,--as-needed"
MAKEOPTS="-j8"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --omit-dir-times --compress --force --whole-file --delete --stats --human-readable --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages --exclude=/.git"
PORTAGE_TMPDIR="/var/tmp"
USE="64bit X a52 aac acl acpi activities aes alsa amd64 avx bash-completion berkdb bluetooth branding bzip2 cairo cdaudio cdda cddb cdio cdr cli consolekit cracklib crypt css cups cxx dbus declarative dri dts dvd dvdr emboss encode exif fam firefox flac fortran gdbm gif glamor glib glibc gpg gpm gtk haskell iconv icu id3tag ieee1394 imagemagick inotify ipv4 ipv6 irc java jpeg jpeg2k kde kipi kwallet lame latex lcms ldap libnotify libsamplerate lzma mad mmx mmxext mng modules mp3 mp4 mpeg mplayer multilib musicbrainz ncurses nls nptl ntp ogg okteta opengl openmp otr pam pango pcre pdf phonon plasma pm-utils png policykit popcnt ppds pulseaudio qemu qml qt3support qt4 qt5 quicktime rar readline real rss sdl seccomp semantic-desktop session spell spice sse sse2 sse3 sse4_1 sse4_2 ssl ssse3 startup-notification svg syslog taglib tcpd threads tiff truetype udev udisks uefi unicode upower usb v41 v412 v4l vaapi vcd vim-syntax visualization vorbis wavpack widgets wma wmf wxwidgets x264 xattr xcb xcomposite xine xinerama xml xscreensaver xv xvid xvmc zlib" ABI_X86="64" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" APACHE2_MODULES="authn_core authz_core socache_shmcb unixd actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" CALLIGRA_FEATURES="kexi words flow plan sheets stage tables krita karbon braindump author" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" CPU_FLAGS_X86="aes avx mmx mmxext popcnt sse sse2 sse3 sse4_1 sse4_2 ssse3" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock isync itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf skytraq superstar2 timing tsip tripmate tnt ublox ubx" GRUB_PLATFORMS="efi-64" INPUT_DEVICES="keyboard mouse evdev" KERNEL="linux" L10N="de en-US en-GB en" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LIBREOFFICE_EXTENSIONS="presenter-console presenter-minimizer" LINGUAS="de en_US en_GB en" OFFICE_IMPLEMENTATION="libreoffice" PHP_TARGETS="php5-6 php7-0" POSTGRES_TARGETS="postgres9_5" PYTHON_SINGLE_TARGET="python3_5" PYTHON_TARGETS="python2_7 python3_5" QEMU_SOFTMMU_TARGETS="i386 x86_64" QEMU_USER_TARGETS="i386 x86_64" RUBY_TARGETS="ruby22" USERLAND="GNU" VIDEO_CARDS="intel" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"
Unset:  CC, CPPFLAGS, CTARGET, CXX, INSTALL_MASK, LC_ALL, PORTAGE_BUNZIP2_COMMAND, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS

=================================================================
                        Package Settings
=================================================================

dev-python/matplotlib-1.5.3-r2::gentoo was built with the following:
USE="cairo latex qt4 qt5 wxwidgets -doc -examples -excel -fltk -gtk2 -gtk3 -pyside -test -tk" ABI_X86="(64)" PYTHON_TARGETS="python2_7 python3_4 -python3_5 -python3_6"
CFLAGS="-march=native -O2 -pipe -ggdb -fno-strict-aliasing"
CXXFLAGS="-march=native -O2 -pipe -ggdb -fno-strict-aliasing"
Comment 1 Till Schäfer 2017-11-30 13:43:04 UTC
Created attachment 507268 [details]
build.log version 2.1.0-r1

dev-python/matplotlib-2.1.0-r1 also fails with the same error.
Comment 2 Jan C Peters 2017-12-04 21:41:45 UTC
I encountered the exact same bug today. Can confirm that it happens both with matplotlib versions 1.4.3 and 2.1.0-r1.

Since the bug message seems to report a (potential) ABI incompatibility with wxpython, I tried to re-emerge that (emerge -1 dev-python/wxpython). And indeed, that fixed it; mpl built fine after that. Though I am still not quite sure what caused it. Maybe it is related to the recent gcc update to 6.4?
Comment 3 Pacho Ramos gentoo-dev 2017-12-06 09:47:08 UTC
(In reply to Jan C Peters from comment #2)
> I encountered the exact same bug today. Can confirm that it happens both
> with matplotlib versions 1.4.3 and 2.1.0-r1.

if it is happening with 1.4.3 it's not a regression... hence, likely it shouldn't block stabilizations of new versions
Comment 4 Till Schäfer 2017-12-06 13:55:54 UTC
I can confirm that rebuilding dev-python/wxpython fixes the problem
Comment 5 Yury Gavrilovich 2018-01-03 20:39:27 UTC
Had the same error, fixed with reemerging wxpython. But 2.1.0 has a clue in error message "Fatal Error: Mismatch between the program and library build versions detected.
The library used 3.0 (wchar_t,compiler with C++ ABI 1010,wx containers,compatible with 2.8),
and wxPython used 3.0 (wchar_t,compiler with C++ ABI 1009,wx containers,compatible with 2.8)", while 1.4.3 hasn't any messages.
Comment 6 Pacho Ramos gentoo-dev 2018-06-24 12:25:28 UTC
just reproduced with 2.2.2
Comment 7 Pacho Ramos gentoo-dev 2018-06-24 12:30:16 UTC
               gtk3agg: yes [installing, version 3.30.22]
Fatal Error: Mismatch between the program and library build versions detected.
The library used 3.0 (wchar_t,compiler with C++ ABI 1010,wx containers,compatible with 2.8),
and wxPython used 3.0 (wchar_t,compiler with C++ ABI 1011,wx containers,compatible with 2.8).
             gtk3cairo: yes [installing, version 3.30.22]
                gtkagg: no  [skipping due to configuration]
                 tkagg: yes [installing; run-time loading from Python Tcl /
Comment 8 Marian Kyral 2018-08-09 11:55:24 UTC
I got the same issue after last python update. And I can confirm that rebuild of dev-python/wxpython package fixed it.
Comment 9 Pacho Ramos gentoo-dev 2018-09-14 21:54:33 UTC
*** Bug 663358 has been marked as a duplicate of this bug. ***
Comment 10 Pacho Ramos gentoo-dev 2018-09-14 21:56:22 UTC
this affects other consumers, it seems wxpython needs to be rebuilt after wxGTK changes :/
Comment 11 Mart Raudsepp gentoo-dev 2018-09-15 10:00:44 UTC
Nothing that wx can do here, other than going against upstream and patching out the safety C++ ABI check.
And no, subslot operators would not be appropriate here - just rebuild of wxGTK or wxpython, but not the other, after a GCC upgrade will break things, not related to a version bump of wxGTK directly.
Comment 12 Pacho Ramos gentoo-dev 2018-09-15 11:09:08 UTC
We would need to add a not to https://wiki.gentoo.org/wiki/Upgrading_GCC#Which_packages_are_known_to_need_a_rebuild.3F then, to try to suggest people to rebuild them together after gcc upgrade
Comment 13 Pacho Ramos gentoo-dev 2018-09-15 11:11:41 UTC
*** Bug 648688 has been marked as a duplicate of this bug. ***
Comment 14 Pacho Ramos gentoo-dev 2018-09-15 11:11:50 UTC
*** Bug 664142 has been marked as a duplicate of this bug. ***
Comment 15 Pacho Ramos gentoo-dev 2018-09-15 11:12:01 UTC
*** Bug 666118 has been marked as a duplicate of this bug. ***
Comment 16 Pacho Ramos gentoo-dev 2019-02-07 10:18:48 UTC
*** Bug 676218 has been marked as a duplicate of this bug. ***
Comment 17 Pacho Ramos gentoo-dev 2019-02-07 10:19:01 UTC
*** Bug 675080 has been marked as a duplicate of this bug. ***
Comment 18 Aaron W. Swenson gentoo-dev 2019-04-09 00:01:29 UTC
I had this same issue.

In my case, I had to rebuild wxGTK for it to work. I did wxpython, but it wan't until I did wxGTK (not followed by wxpython) that matplotlib was happy.