Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 639248 - <media-gfx/engauge-10.6 depends on deprecated Qt3Support/Qt4
Summary: <media-gfx/engauge-10.6 depends on deprecated Qt3Support/Qt4
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Denis Dupeyron
URL: http://markummitchell.github.io/engau...
Whiteboard:
Keywords:
Depends on: 616518
Blocks: qt4-removal
  Show dependency tree
 
Reported: 2017-11-30 00:43 UTC by Andreas Sturmlechner
Modified: 2018-06-10 21:39 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Andreas Sturmlechner gentoo-dev 2017-11-30 00:43:08 UTC
Qt4 is dead and going away and our existing ebuild for engauge very outdated. See also new homepage @ $URL.

engauge is Qt5 based since 6.0 while current release is 10.3, it seems to be an actively developed project. Please bump to a newer version since the time of Qt4 is very limited.
Comment 1 Denis Dupeyron gentoo-dev 2017-11-30 03:22:37 UTC
Thanks for the heads up. I'll look into it.
Comment 2 Andreas Sturmlechner gentoo-dev 2018-01-16 22:45:54 UTC
Any progress here?
Comment 3 Andreas Sturmlechner gentoo-dev 2018-03-05 15:09:54 UTC
ping
Comment 4 Denis Dupeyron gentoo-dev 2018-05-09 18:40:27 UTC
I pushed 10.6 today which uses Qt5. As soon as we can stabilize it (don't waste time asking me, just do it when you're ready) we can close this bug.
Comment 5 Andreas Sturmlechner gentoo-dev 2018-06-02 08:53:48 UTC
(In reply to Denis Dupeyron from comment #4)
> I pushed 10.6 today which uses Qt5. As soon as we can stabilize it (don't
> waste time asking me, just do it when you're ready) we can close this bug.

5.2 ain't stable either so we don't really have to wait for that.
Comment 6 Larry the Git Cow gentoo-dev 2018-06-10 21:39:09 UTC
The bug has been closed via the following commit(s):

https://gitweb.gentoo.org/repo/gentoo.git/commit/?id=2eb9a4b49cd4946f4a95019293dafbb1fe88d2a0

commit 2eb9a4b49cd4946f4a95019293dafbb1fe88d2a0
Author:     Andreas Sturmlechner <asturm@gentoo.org>
AuthorDate: 2018-06-10 21:38:36 +0000
Commit:     Andreas Sturmlechner <asturm@gentoo.org>
CommitDate: 2018-06-10 21:38:56 +0000

    media-gfx/engauge: Drop old, Qt4-based
    
    Closes: https://bugs.gentoo.org/639248
    Closes: https://bugs.gentoo.org/655214
    Package-Manager: Portage-2.3.40, Repoman-2.3.9

 media-gfx/engauge/Manifest           |  1 -
 media-gfx/engauge/engauge-5.2.ebuild | 48 ------------------------------------
 2 files changed, 49 deletions(-)