emerge -v libgpg-error produces the output seen in the attached file and fails to complete.
(Actually I stumbled across this,when trying to emerge kde, since it's a dependency of kde-pim)
Steps to Reproduce:
1. emerge -v libgpg-error
Information from emerge info:
Portage 2.0.50-r11 (default-x86-1.4, gcc-3.3.4, glibc-22.214.171.12440420-r1, 2.6.6)
System uname: 2.6.6 i686 AMD Athlon(tm) XP 2400+
Gentoo Base System version 1.4.16
CONFIG_PROTECT="/etc /usr/X11R6/lib/X11/xkb /usr/kde/2/share/config
/usr/kde/3.2/share/config /usr/kde/3.3/env /usr/kde/3.3/share/config
/usr/kde/3.3/shutdown /usr/kde/3/share/config /usr/lib/mozilla/defaults/pref
/usr/share/texmf/tex/platex/config/ /usr/share/texmf/xdvi/ /var/qmail/control"
CONFIG_PROTECT_MASK="/etc/gconf /etc/terminfo /etc/env.d"
FEATURES="autoaddcvs ccache sandbox"
USE="3dnow X aalib acpi alsa apm avi berkdb bitmap-fonts bonobo canna cdr
cryptcups dga directfb dnd dvd dvdr emacs encode esd esk fbcon flash foomaticdb
freetype gdbm gif gnome gpm gtk gtk2 guile icq imlib jabber jack java joystick
jpeg kde leim libg++ libwww mad mikmod mmx motif mozilla mpeg mule ncurses nls
oggvorbis opengl oscar oss pam pdflib perl png python qt quicktime readline sdl
slang spell ssl svga tcltk tcpd tetex truetype unicode videos x86 xml2 xmms
xprint xv zlib"
Created attachment 39523 [details]
Output from "emerge -v libgpg-error"
I had exactly the same problem. I then emerged libgpg-error with NLS support off:
USE="-nls" emerge libgpg-error
Worked here as well. Thanks a lot!
I have exactly the same problem. I work around works for me too.
Confirmed here aswell, USE=-nls works for me too.
solutions welcome peoples.
Created attachment 39745 [details]
Removed nls USE flag from libgpg-error-1.0 until the cause this can be found.
Copied libgpg-error-1.0 to libgpg-error-1.0-r1 to continue debugging effort.
Attached is my config.log. Please compare/and or attach yours for comparison
along with your emerge info.
bash-2.05b# emerge info
Portage 2.0.51_rc1 (default-x86-2004.2, gcc-3.3.4, glibc-126.96.36.19940420-r1,
System uname: 2.6.8-gentoo-r1 i686 AMD Athlon(tm) XP 1900+
Gentoo Base System version 1.4.16
distcc 2.16 i686-pc-linux-gnu (protocols 1 and 2) (default port 3632) [enabled]
ccache version 2.3 [enabled]
CFLAGS="-march=athlon-xp -O2 -pipe"
Created attachment 40050 [details]
config.log for libgpg-error-1.0; my system's "emerge info" output
I am seeing this problem with the new version of the 1.0 ebuild. The compile results are the same; it complains about LC_ALL not being defined, shortly before the compile aborts. Needless to say, disabling the nls USE flag no longer works around this problem. See the above attachments for my config.log and "emerge info" output.
Kris - I mentioned that the version bump to -r1 was the same as the previous for testing. Yes its still broken. Use 1.0 or -nls if you don't want an error. Solutions welcome. -r1 is there to assist in testing.
Removing the line with LC_ALL let me compile the package. I don't know how to test the package now :p
from where? src/gpg-error.c:262: setlocale (LC_ALL, "" ) ? I tried this again and it misteriously worked. Anyone else as lucky? I'll look more later
Compiles if #include <locale.h> is added to gpg-error.c.
libgpg-error-1.0-r1 fixed. Please test before and after sync and confirm that it is broken before and fixed afterwards. I was unable to reproduce the problem due to my system configuration changes however I have made the configure detect and include the presence of locale.h.
You should see:
checking where the gettext function comes from... libc
checking for ANSI C header files... (cached) yes
checking for stdlib.h... (cached) yes
checking locale.h usability... yes
checking locale.h presence... yes
checking for locale.h... yes
in the output.
Sorry this took so long.
I just noticed that my post #4 was for libgpg-error-1.0 not libgpg-error-1.9-r1. I was having the same problem and USE -nls worked for me. It was fixed for libgpg-error-1.0 by something else. I just tried both 1.0 and 1.0-r1 and they compiled with nls just fine.
*** Bug 71652 has been marked as a duplicate of this bug. ***
Julien, can you please include your complete output and attach config.log.
~x86 masked as requested.
As an alternate to downgrading you can try emergeing without nls USE flag.
Created attachment 44270 [details]
(julien) full emerge log
Created attachment 44271 [details]
Julien does libgpg-error-1.0-r1 work? env ACCEPT_KEYWORDS=~x86 emerge libgpg-error
yes, 1.0-r1 compiles fine
I tried doing this with USE=-nls, this did NOT work for me. Only thing that did work was downgrading to version 7, as seen in bug 71652.
Ben are you talking about 1.0-r1?
Daniel - Yes, talking about libgpg-error-1.0-r1.ebuild, or libgpg-error-1.0.ebuild. Same error with both. Worked with libgpg-error-0.7-r1.ebuild. Needless to say I didnt try 6. Note that I havent had any problems with 0.7, Ive successfully compiled gnome, openoffice, etc. since I resovled this problem by downgrading.
Ben, Please attach config.log, emerge info and the error output so I have something to go by in attempting to get 1.0-r1 working for you.
Daniel - I havent been able to duplicate the problem. Ive even successfully installed version 1.0-r1. I tested with and without settings in /etc/make.conf and doesnt make any difference. The only other major change to my system was that I recompiled the kernel. This may have something to do with it, although I really couldnt tell you what options I changed... Sorry for the trouble... Thanks for your help though. Ben.
ok - thanks ben
This bug is still "test-request". I installed libgpg-error-1.1 (newer version)
with both USE="-nls" and USE="nls" and it merged successfully. Kernel got nls