Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 63919 - libgpg-error-1.0-r1 fails to emerge
Summary: libgpg-error-1.0-r1 fails to emerge
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] Library (show other bugs)
Hardware: x86 Linux
: High normal (vote)
Assignee: Crypto team [DISABLED]
: 71652 (view as bug list)
Depends on:
Reported: 2004-09-13 12:17 UTC by Sven Siggelkow
Modified: 2005-09-06 15:03 UTC (History)
5 users (show)

See Also:
Package list:
Runtime testing required: ---

Output from "emerge -v libgpg-error" (libgpg-error.log,11.71 KB, text/plain)
2004-09-13 12:20 UTC, Sven Siggelkow
config.log (config.log,24.74 KB, text/plain)
2004-09-17 01:07 UTC, Daniel Black (RETIRED)
config.log for libgpg-error-1.0; my system's "emerge info" output (debug_info.txt,24.68 KB, text/plain)
2004-09-20 21:43 UTC, Kris Kelley
(julien) full emerge log (update-libgpg-error.log,13.61 KB, text/plain)
2004-11-19 04:10 UTC, Julien Cayzac
(julien) config.log (config.log,3.77 KB, text/plain)
2004-11-19 04:12 UTC, Julien Cayzac

Note You need to log in before you can comment on or make changes to this bug.
Description Sven Siggelkow 2004-09-13 12:17:39 UTC
emerge -v libgpg-error produces the output seen in the attached file and fails to complete. 
(Actually I stumbled across this,when trying to emerge kde, since it's a dependency of kde-pim)

Reproducible: Always
Steps to Reproduce:
1. emerge -v libgpg-error

Information from emerge info:

Portage 2.0.50-r11 (default-x86-1.4, gcc-3.3.4, glibc-, 2.6.6)
System uname: 2.6.6 i686 AMD Athlon(tm) XP 2400+
Gentoo Base System version 1.4.16
Autoconf: sys-devel/autoconf-2.59-r4
Automake: sys-devel/automake-1.8.5-r1
CFLAGS="-march=athlon-xp -pipe"
CONFIG_PROTECT="/etc /usr/X11R6/lib/X11/xkb /usr/kde/2/share/config
/usr/kde/3.2/share/config /usr/kde/3.3/env /usr/kde/3.3/share/config
/usr/kde/3.3/shutdown /usr/kde/3/share/config /usr/lib/mozilla/defaults/pref
/usr/share/config /usr/share/texmf/dvipdfm/config/
/usr/share/texmf/dvips/config/ /usr/share/texmf/tex/generic/config/
/usr/share/texmf/tex/platex/config/ /usr/share/texmf/xdvi/ /var/qmail/control"
CONFIG_PROTECT_MASK="/etc/gconf /etc/terminfo /etc/env.d"
CXXFLAGS="-march=athlon-xp -pipe"
FEATURES="autoaddcvs ccache sandbox"
USE="3dnow X aalib acpi alsa apm avi berkdb bitmap-fonts bonobo canna cdr
cryptcups dga directfb dnd dvd dvdr emacs encode esd esk fbcon flash foomaticdb
freetype gdbm gif gnome gpm gtk gtk2 guile icq imlib jabber jack java joystick
jpeg kde leim libg++ libwww mad mikmod mmx motif mozilla mpeg mule ncurses nls
oggvorbis opengl oscar oss pam pdflib perl png python qt quicktime readline sdl
slang spell ssl svga tcltk tcpd tetex truetype unicode videos x86 xml2 xmms
xprint xv zlib"
Comment 1 Sven Siggelkow 2004-09-13 12:20:04 UTC
Created attachment 39523 [details]
Output from "emerge -v libgpg-error"
Comment 2 Andrey Shytov 2004-09-13 13:42:59 UTC
I had exactly the same problem. I then emerged libgpg-error with NLS support off: 

USE="-nls" emerge libgpg-error

It worked.
Comment 3 Sven Siggelkow 2004-09-13 14:13:56 UTC
Worked here as well. Thanks a lot!
Comment 4 Wilson M. Michaels 2004-09-15 06:45:16 UTC
I have exactly the same problem. I work around works for me too. 
Comment 5 Peter 2004-09-16 07:23:22 UTC
Confirmed here aswell, USE=-nls works for me too.
Comment 6 Daniel Black (RETIRED) gentoo-dev 2004-09-16 14:14:56 UTC
solutions welcome peoples.
Comment 7 Daniel Black (RETIRED) gentoo-dev 2004-09-17 01:07:36 UTC
Created attachment 39745 [details]

Removed nls USE flag from libgpg-error-1.0 until the cause this can be found.
Copied libgpg-error-1.0 to libgpg-error-1.0-r1 to continue debugging effort.

Attached is my config.log. Please compare/and or attach yours for comparison
along with your emerge info.

bash-2.05b# emerge info
Portage 2.0.51_rc1 (default-x86-2004.2, gcc-3.3.4, glibc-,
2.6.8-gentoo-r1 i686)
System uname: 2.6.8-gentoo-r1 i686 AMD Athlon(tm) XP 1900+
Gentoo Base System version 1.4.16
distcc 2.16 i686-pc-linux-gnu (protocols 1 and 2) (default port 3632) [enabled]
ccache version 2.3 [enabled]
Autoconf: sys-devel/autoconf-2.59-r4
Automake: sys-devel/automake-1.8.5-r1
Binutils: sys-devel/binutils-
Headers:  sys-kernel/linux26-headers-
Libtools: sys-devel/libtool-1.5.2-r5
CFLAGS="-march=athlon-xp -O2 -pipe"
Comment 8 Kris Kelley 2004-09-20 21:43:50 UTC
Created attachment 40050 [details]
config.log for libgpg-error-1.0; my system's "emerge info" output
Comment 9 Kris Kelley 2004-09-20 21:45:05 UTC
I am seeing this problem with the new version of the 1.0 ebuild.  The compile results are the same; it complains about LC_ALL not being defined, shortly before the compile aborts.  Needless to say, disabling the nls USE flag no longer works around this problem.  See the above attachments for my config.log and "emerge info" output.
Comment 10 Daniel Black (RETIRED) gentoo-dev 2004-09-22 01:56:50 UTC
Kris - I mentioned that the version bump to -r1 was the same as the previous for testing. Yes its still broken. Use 1.0 or -nls if you don't want an error. Solutions welcome. -r1 is there to assist in testing.
Comment 11 Philippe Lafoucrière 2004-10-24 02:35:10 UTC
Removing the line with LC_ALL let me compile the package. I don't know how to test the package now :p
Comment 12 Daniel Black (RETIRED) gentoo-dev 2004-11-04 13:05:39 UTC
from where? src/gpg-error.c:262:  setlocale (LC_ALL, "" ) ? I tried this again and it misteriously worked. Anyone else as lucky? I'll look more later
Comment 13 Albert Holm 2004-11-04 14:11:34 UTC
Compiles if #include <locale.h> is added to gpg-error.c.
Comment 14 Daniel Black (RETIRED) gentoo-dev 2004-11-16 03:39:58 UTC
libgpg-error-1.0-r1 fixed. Please test before and after sync and confirm that it is broken before and fixed afterwards. I was unable to reproduce the problem due to my system configuration changes however I have made the configure detect and include the presence of locale.h.

You should see:
checking where the gettext function comes from... libc
checking for ANSI C header files... (cached) yes
checking for stdlib.h... (cached) yes
checking locale.h usability... yes
checking locale.h presence... yes
checking for locale.h... yes

in the output.

Sorry this took so long.
Comment 15 Wilson M. Michaels 2004-11-16 20:38:09 UTC
I just noticed that my post #4 was for libgpg-error-1.0 not libgpg-error-1.9-r1. I was having the same problem and USE -nls worked for me. It was fixed for libgpg-error-1.0 by something else. I just tried both 1.0 and 1.0-r1 and they compiled with nls just fine. 
Comment 16 Daniel Black (RETIRED) gentoo-dev 2004-11-19 02:49:05 UTC
*** Bug 71652 has been marked as a duplicate of this bug. ***
Comment 17 Daniel Black (RETIRED) gentoo-dev 2004-11-19 02:58:26 UTC
Julien, can you please include your complete output and attach config.log.
~x86 masked as requested.

As an alternate to downgrading you can try emergeing without nls USE flag.
Comment 18 Julien Cayzac 2004-11-19 04:10:48 UTC
Created attachment 44270 [details]
(julien) full emerge log

As requested
Comment 19 Julien Cayzac 2004-11-19 04:12:35 UTC
Created attachment 44271 [details]
(julien) config.log

As requested
Comment 20 Daniel Black (RETIRED) gentoo-dev 2004-11-19 05:12:43 UTC
Julien does libgpg-error-1.0-r1 work? env ACCEPT_KEYWORDS=~x86 emerge libgpg-error
Comment 21 Julien Cayzac 2004-11-19 06:29:34 UTC
yes, 1.0-r1 compiles fine
Comment 22 Benjamin Burns 2004-11-19 09:55:15 UTC
I tried doing this with USE=-nls, this did NOT work for me.  Only thing that did work was downgrading to version 7, as seen in bug 71652.
Comment 23 Daniel Black (RETIRED) gentoo-dev 2004-11-19 10:23:58 UTC
Ben are you talking about 1.0-r1?
Comment 24 Benjamin Burns 2004-11-19 15:12:28 UTC
Daniel - Yes, talking about libgpg-error-1.0-r1.ebuild, or libgpg-error-1.0.ebuild.  Same error with both.  Worked with libgpg-error-0.7-r1.ebuild.  Needless to say I didnt try 6.  Note that I havent had any problems with 0.7, Ive successfully compiled gnome, openoffice, etc. since I resovled this problem by downgrading.  
Comment 25 Daniel Black (RETIRED) gentoo-dev 2004-11-19 15:43:56 UTC
Ben, Please attach config.log, emerge info and the error output so I have something to go by in attempting to get 1.0-r1 working for you.
Comment 26 Benjamin Burns 2004-11-20 19:45:41 UTC
Daniel - I havent been able to duplicate the problem.  Ive even successfully installed version 1.0-r1.  I tested with and without settings in /etc/make.conf and doesnt make any difference.  The only other major change to my system was that I recompiled the kernel.  This may have something to do with it, although I really couldnt tell you what options I changed...  Sorry for the trouble... Thanks for your help though.   Ben.
Comment 27 Daniel Black (RETIRED) gentoo-dev 2004-11-20 19:58:08 UTC
ok - thanks ben
Comment 28 Albert Holm 2005-09-06 15:03:33 UTC
This bug is still "test-request". I installed libgpg-error-1.1 (newer version) 
with both USE="-nls" and USE="nls" and it merged successfully. Kernel got nls