Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 639178 - wine-d3d9-9999 - configure: error: libxfixes development files not found, Xfixes won't be supported. This is an error since --with-xfixes was requested.
Summary: wine-d3d9-9999 - configure: error: libxfixes development files not found, Xfi...
Status: RESOLVED NEEDINFO
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Wine Maintainers
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2017-11-29 15:09 UTC by Branko Badrljica
Modified: 2018-01-21 05:16 UTC (History)
3 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
build.log (build.log,28.09 KB, text/plain)
2017-11-29 20:18 UTC, Branko Badrljica
Details
emerge --info wine-d3d9 (emerge-info-wine.txt,6.08 KB, text/plain)
2017-11-29 20:21 UTC, Branko Badrljica
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Branko Badrljica 2017-11-29 15:09:34 UTC
I've noted that I can't emerge it anymore ( nor the vanila version ).

They all fail at the same point during configure process - when configure tries compiling test programs and linking them to libraires.

It finds headers fine ( checking for X11/extensions/xf86vmproto.h... yes ), but then fails to link against the library ( checking for -lXxf86vm... not found ).

I tried manually compiling those test code snippets ad they compile and execute fine...

I might be wrong on this, but it looks as if configure scripts is getting wrong the library dir and tries to link the 32-bit code with the libraries in /usr/lib instead of /usr/lib32 and that is the reason compile fails....

I tried several compilers-- gcc.5.5.0/6.4.0/7.2.0, all with the same result...

I run hardened profile, if that matters ( hardened/linux/amd64 ).
Comment 1 Branko Badrljica 2017-11-29 15:19:11 UTC
I tried to attach build log etc, but at the moment each attempt has fizzled out ( connection time out etc).

Will try later.
Comment 2 Branko Badrljica 2017-11-29 20:18:16 UTC
Created attachment 507218 [details]
build.log
Comment 3 Branko Badrljica 2017-11-29 20:21:54 UTC
Created attachment 507220 [details]
emerge --info wine-d3d9
Comment 4 Adam Feldman gentoo-dev 2017-12-04 07:10:27 UTC
Maybe it is a gold linker problem? Are you able to try without that?
Comment 5 Adam Feldman gentoo-dev 2018-01-21 05:16:28 UTC
Feel free to re-open if you can provide additional information as requested.