Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 638976 - net-im/centerim-5.0.1 stable
Summary: net-im/centerim-5.0.1 stable
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Stabilization (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Sven Wegener
URL:
Whiteboard: Was: net-im/centerim-4.22.10 (and -r1...
Keywords: PATCH, STABLEREQ
Depends on:
Blocks: gcc-6 633914
  Show dependency tree
 
Reported: 2017-11-27 14:59 UTC by Thomas Petersen
Modified: 2018-02-06 16:24 UTC (History)
3 users (show)

See Also:
Package list:
net-im/centerim-5.0.1
Runtime testing required: ---
stable-bot: sanity-check+


Attachments
centerim-4.22.10-ansi-c.patch (centerim-4.22.10-ansi-c.patch,2.49 KB, patch)
2017-11-27 14:59 UTC, Thomas Petersen
no flags Details | Diff
centerim-4.22.10-ncurses-pkg-config.patch (centerim-4.22.10-ncurses-pkg-config.patch,633 bytes, patch)
2017-11-27 15:02 UTC, Thomas Petersen
no flags Details | Diff
centerim-4.22.10-r2.ebuild (centerim-4.22.10-r2.ebuild,2.82 KB, text/plain)
2017-11-27 15:05 UTC, Thomas Petersen
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Thomas Petersen 2017-11-27 14:59:58 UTC
Created attachment 506820 [details, diff]
centerim-4.22.10-ansi-c.patch

I have come across two problems when compiling centerim-4.22.10.

1.
When compiling with gcc-6.4 which has been stabilized recently I get compilation errors in the src and /src/hooks subdirectories. The error occurs because c++11 is now default in gcc-6 and files in these directories makes use of variables called "auto".
The patch centerim-4.22.10-ansi-c.patch adds -ansi to CXXFLAGS in these two directories.

2.
If ncurses has been compiled with the tinfo useflag and the terminfo library is separated out in libtinfo.so centerim fails to link because -ltinfo is missing from the link command. This is caused by the outdated macros in m4/ax_with_curses.m4 which don't make use of pkg-config. Removing that file and reconfiguring pulls in more recent macros which use pkg-config to find the correct link flags. The new macro sets CURSES_LIBS instead of CURSES_LIB.

See the attached patches and modified ebuild.
Comment 1 Thomas Petersen 2017-11-27 15:02:33 UTC
Created attachment 506822 [details, diff]
centerim-4.22.10-ncurses-pkg-config.patch
Comment 2 Thomas Petersen 2017-11-27 15:05:22 UTC
Created attachment 506824 [details]
centerim-4.22.10-r2.ebuild
Comment 3 Pacho Ramos gentoo-dev 2017-12-03 11:07:18 UTC
Why not use 5.0.1 version?
Comment 4 Pacho Ramos gentoo-dev 2017-12-06 09:49:07 UTC
I would opt for stabilizing 5.0.1 then :/
Comment 5 Thomas Petersen 2017-12-07 12:30:38 UTC
Moving on to 5.0.1 also solves the problems ofcourse.
Personally I'm not too fond of the dependency on purple but I can get used to that I guess.
Comment 6 Pacho Ramos gentoo-dev 2017-12-08 16:53:11 UTC
We need to stabilize the fixed version as current one doesn't compile with stable gcc6
Comment 7 Tobias Klausmann gentoo-dev 2017-12-16 17:25:11 UTC
Stable on amd64.
Comment 8 Thomas Deutschmann gentoo-dev Security 2018-02-06 16:24:45 UTC
x86 stable, closing